No announcement yet.

Event ID error message 10016

  • Filter
  • Time
  • Show
Clear All
new posts

  • Event ID error message 10016

    Hello again,

    I'm seeing a lot of these messages in the event log. My 'SBS 2008 unleashed book" and the sbs post install known issues page both point to which describes the issue exactly.

    The workaround described seems simple enough, until I get to step 7:
    In the Select Users, Computers, or Groups dialog box, type the domain user account that you specified as the Windows SharePoint Services 3.0 service account, click Check Names, and then click OK.

    The problem is that I'm not sure what user account to use, if I need to create one etc. The SBS 2008 install program installed sharepoint fine without me, and I don't recall anything about creating a account for sharepoint.

    Any recommendations? Thanks.

  • #2
    Re: Event ID error message 10016

    What user name is it referencing in the event log?


    • #3
      Re: Event ID error message 10016


      From the General tab for this event in the Event Viewer, the user is listed as 'NETWORK SERVICE'.

      This is the descriptive:
      'The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
      to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool. '.


      • #4
        Re: Event ID error message 10016

        The event log entry is giving you all the info you need. Go into Component Services... expand until you see the DCOM Config folder... select View Detail from the menu bar... find the application that has Application ID {61738644-F196-11D0-9953-00C04FD919C1} which is the IIS WAMREG admin Service... right click it and select properties... click the Security tab... click the Edit button under "Launch and Activation Permissions" section... click the Add button... type "network service" (without the quotes) in the Select Users, Computers, or Groups box... then check the Local Launch and Local Activation permissions boxes... click OK all the way out and that should do it. I would recommend a reboot of the server after making this change so that you are assured it will take affect.