Announcement

Collapse
No announcement yet.

Remote Web Workplace won't login

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote Web Workplace won't login

    Hey folks,
    I've had a bit of a problem with a server we've recently built for a customer. We've done plenty of servers before and never had this - even used the same install media that was used a few weeks prior and that had no problems (CD1 off a CD that we have, the rest of the media copied onto a folder on a second partition on the server for speed).

    Everything seems ok except Remote Web Workplace which just will not accept any login credentials whatsoever. I think it is important to point out that the password prompt is the HTTP style popup box and NOT the forms based login you would expect thus I reckon its something to do with anonymous access not working for RWW.

    OWA works fine, the users are set to password never expires so no problems with password prompts. The domain name is only three characters so there's no problems with it being truncated.

    The only thing I have noticed is that the IWAM and IUSR accounts seems to be automatically generated with the wrong servername. I guess this is because the server had the basic install done with one name and then when the post install wizard was run a different name was specified.

    I found an article that ran through how to change the IWAM and IUSR account names to the right one using some of the admin scripts and setting a registry entry to prevent it from regenerating the old ones but that had no effect.

    I have also compared the /Remote directory configuration with that of another server that I know works, I've re-run the SBS wizards and reinstalled the RWW application through add/remove windows components.

    Nothing seems to work and we can't rebuild this machine because the software company already crashed the first build a day after we installed it!

    Can anyone see anything I've missed or give me pointers on where to look?

  • #2
    Re: Remote Web Workplace won't login

    Typical, I get somewhere the moment I post for help.

    I suddenly recalled a .net v2 error at some point during the install

    The continual login prompt has now gone away by running the following:

    Code:
    C:\Documents and Settings\Administrator>cd\
    
    C:\>cd WINDOWS\Microsoft.NET\Framework\v2.0.50727
    
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis -ir
    Start installing ASP.NET (2.0.50727) without registering the scriptmap.
    ..................................
    Finished installing ASP.NET (2.0.50727) without registering the scriptmap.
    *additional - I also ran aspnet_regiis -ir in the v1.1.4xxx folder

    So RWW is now up and running and I'll remember this one. I had problems installing Backup Exec because .net 2 wouldn't install at first (some error about no permissions for forms). That went away after installing the latest 3.5 from Microsoft Update though. Hopefully it'll help someone else too!
    Last edited by beddo; 13th May 2009, 12:00.

    Comment


    • #3
      Re: Remote Web Workplace won't login

      Thanks for posting back with the fix. However, changing server names in the middle of the installation seems a bit wacko IMHO. Since it usually takes less than 40 mins to install CD1, I would have restarted the wholeinstallation with the final server name from the start. That would have probably taken you less time than the fix you found and looking for it!

      All IMHO, of course
      TIA

      Steven Teiger [SBS-MVP(2003-2009)]
      http://www.wintra.co.il/
      sigpic
      Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

      We donít stop playing because we grow old, we grow old because we stop playing.

      Comment


      • #4
        Re: Remote Web Workplace won't login

        Whilst what you are suggesting makes sense logically, it was out of the question. The server was in production at a site and the client had already had extra days of downtime caused by the software company hitting Last Known Good and somehow returning the server to the state it was in *before* running any of the configuration wizards!

        The name being changed wasn't actually anything to do with the problem - it was purely a problem with ASP .net extensions not installing correctly through the wizards.

        As a sidenote, you can do the first build with one name and then change the name before running the wizards. Just change it manually rather than expecting the wizards to change it for you!

        Comment


        • #5
          Re: Remote Web Workplace won't login

          But as you see, you get IWAM and IUSR accounts wrongly named. These accounts are used extensively for access to IIS, so it is a real PITA to update everything - NOT recommended.
          TIA

          Steven Teiger [SBS-MVP(2003-2009)]
          http://www.wintra.co.il/
          sigpic
          Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

          We donít stop playing because we grow old, we grow old because we stop playing.

          Comment


          • #6
            Re: Remote Web Workplace won't login

            The accounts only get wrongly names if you change the name of the server using the SBS installation wizard. If you change the computer name manually before hand, reboot and then run the SBS installation wizard everything works. The problem is with the SBS wizard allowing you to specify a change of server name without insisting on a reboot before continuing.

            As a side note, renaming the accounts isn't as difficult as you might think.

            You rename then in active directory and create a DWORD registry key under HKLM\Software\Microsoft\InetStp called "DisableUserAccountRestore". Set the value to 0.

            Then there are some scripts to do the rest for you from a command prompt in \InetPub\Adminscripts:

            Code:
            cscript.exe adsutil.vbs set w3svc/anonymoususername "username"
            cscript.exe adsutil.vbs set w3svc/WAMusername "username"
            cscript.exe synciwam.vbs -v
            iisreset

            Comment

            Working...
            X