No announcement yet.

After SP1 install, can't connect using RDC.

  • Filter
  • Time
  • Show
Clear All
new posts

  • After SP1 install, can't connect using RDC.

    I'm brand new here and wasn't sure whether to post this here or in terminal services, but I decided to go with this.

    I'm running SBS 2003 as the only DC in a domain with 2 other servers running W2K. Last Friday I installed SBS 2003 SP1 exactly as laid out on this website. Went fairly smooth with some small problems until I came in today.

    I am in the LAN and cannot connect to the SBS server using Remote Desktop Connection. I get the error :
    "The client could not connect to the remote computer.
    Remote connections might not be enabled or the computer might be too busy to accept new connections.
    It is also possible that network connections are preventing your connection."

    Remote connections are enabled on this server and the firewall on it is disabled. I can connect to the other 2 servers same as always. I can't even find the SBS server when I browse. I also can't connect using Terminal Services. I can VNC to the SBS with no problem except that it's slow!

    Obviously something in the SP1 installation changed, but I don't know what.
    I would really appreciate it if somebody could help me out.


  • #2
    I see that this has had a lot of views, so I'll post how I fixed it.

    I recreated the RDP connection via Admin Tools - Terminal Services Configuration, rebooted the server and RDP worked.

    The strange thing was when I browsed for more computers, it couldn't find the server, but when I typed in the name, immediate connection.

    So, after you install SBS2003 SP1, you'll have to recreate your RDP connections.


    • #3
      Well done on working out the fix. Thanks also for taking the time to post back with the fix. It is greatly appreciated. Hope you stick around.
      Joined: 23rd December 2003
      Departed: 23rd December 2015