No announcement yet.

SBS 2003 Lost Password

  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003 Lost Password

    A client of mine has a SBS 2003 server with a failed motherboard. I've installed a new motherboard and am ready to log in and set up the new hardware for the system to recognize. However, no one knows the admin password. The only passwords anyone knows are user login accounts, but they don't have the ability to log in at the console.
    By the way, the reason they don't know is because this server is used for historical data only and accessed about once a month at most, however, the running programs and data are important to them.

    Anyway, I've been trying for days to reset the password for the local admin account so I can then use some other tool to reset the AD admin account, but I keep failing.

    Most of the password utilities I have used (many from this site) see the local admin and guest account, allow me to either change or blank the password, or unlock the user in the case of guest, BUT when I get to the login screen, I'm still locked out.

    The best I can figure is that the situation is unique due to the dynamic raid setup the original system builder used when building the server.

    I have tried everything I can from this site and others, but to no avail.

    The server takes about 5 minutes to boot into Safe Mode where I can try to log in as a local user, or it takes about 2 hours (due to failing services) to log into 'regular' mode; either way, nothing I previously set the password to works.

    One other note, in the case of the guest account, I promoted Guest to Admin status AND unlocked the account, yet upon login it says that the guest account is disabled!

    I'm ready to give up, but hate to. Does anyone have any suggestions?
    Is it the Dynamic disk that is causing my problem?

    Thanks in advance,

  • #2
    Re: SBS 2003 Lost Password

    Most of the tools reset the local account password which are not really relevant for a Domain Controller (DC). SBS is of course a DC so its passwords are stored in Active Directory (AD). If you reset the local admin password, then you must restart the SBS by hitting F8 and going in to DSRM (Directory Services Restore Mode) which effectively means you are starting the machine without AD. From there you can use another article on this site which will enable you to recover the administrator password.


    Steven Teiger [SBS-MVP(2003-2009)]
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.


    • #3
      Re: SBS 2003 Lost Password

      Yes, I was aware that this is a two-step process, which would require using another tool once I get into the local admin account.

      What is new to me that you are saying is to make the change and then go into DSRM. Nothing I have read says that, so this is new and I'll give it a try.

      Right now, every time I do a password reset or password blank, it just fails the next time I try to log in, saying my password is not correct! The change I make doesn't seem to stick.

      I'll give your technique a try.

      Thanks for taking the time to answer back.


      • #4
        Re: SBS 2003 Lost Password

        Ok, for all of those who will run across this thread in the future with the same problem.......

        As I read through the instructions to first change the local account, then change the AD account, my biggest problem was likely caused by not reading the instructions in enough detail.

        In step one (changing the local admin's password), after you change the password, you need to log into the machine in Directory Services Restore Mode, as teiger said in his post below. That was the key for me. I had been trying to log in while in safe mode, thinking it was the same, but it's not. Because I wasn't seeing the domain in the login screen, I was assuming that I wasn't authenticating against AD, but I was!

        Once I got in via DSRM, then I was able to run the second script, also found on this website and all worked ok.

        Thank you teiger for your comment that ultimately led to the solution I was looking for.