Announcement

Collapse
No announcement yet.

Connect to the Internet problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connect to the Internet problem

    Hi Folks, I'm having a problem with the Connect to the Internet Wizard in SBS 2003. I need to use this tool to make Outlook Web Access available outside. When I run the script I get an alert which says that there is an error during a component configuration and I see a red cross on the "firewall setup".
    I tried all the options, I even tried to disable the firewall but i get the same message.
    I also installed all the Microsoft updates, even the Windows 2003 Sp2, but nothing happens.
    Any idea about that?
    Last edited by guidone; 19th March 2009, 09:33.

  • #2
    Re: Connect to the Internet problem

    I am sure I saw a post once, may not be reltaed, where they resolved the issue by changing the ASP mode to 1.1 or backwards with what is installed by default in IIS on a SBS server.

    Comment


    • #3
      Re: Connect to the Internet problem

      Thank you very much for your fast answer. I see in the IIS administration that both ASP 1.1 and 2.0 are available but all the web applications use the 1.1.4322 version. I saw in another well-working server that the ASP version is exactly the same. Anyway I disabled the ASP 2.0 but nothing happened.
      I do think that there is something wrong with the IIS becouse sometime i see that the websites are not running and I have to start them manually. However I have to admit that I'm not a genius with IIS.
      Thank you again and, obviously, any other advice will be appreciated.

      Comment


      • #4
        Re: Connect to the Internet problem

        Originally posted by guidone View Post
        Thank you very much for your fast answer. I see in the IIS administration that both ASP 1.1 and 2.0 are available but all the web applications use the 1.1.4322 version. I saw in another well-working server that the ASP version is exactly the same. Anyway I disabled the ASP 2.0 but nothing happened.
        I do think that there is something wrong with the IIS becouse sometime i see that the websites are not running and I have to start them manually. However I have to admit that I'm not a genius with IIS.
        Thank you again and, obviously, any other advice will be appreciated.
        In SBS the wizard usually needs to be run again when changes have taken place. That may help resolve your current issue as well.

        Have you got two websites using port 80?

        Comment


        • #5
          Re: Connect to the Internet problem

          OK, I always restart the wizard from the beginning everytime I make something new.
          I have the standard SBS websites: Companyweb, OWA, Remote Workplace ecc...
          Nothing different from the default. The sites work on both 80 and 443 ports.
          Last edited by guidone; 19th March 2009, 12:28.

          Comment


          • #6
            Re: Connect to the Internet problem

            Search for the Wizard's Log file (ICWLOG.TXT) and see what that tells you. Post it here if you want further help....
            Last edited by teiger; 19th March 2009, 15:27. Reason: Grammar Correction
            TIA

            Steven Teiger [SBS-MVP(2003-2009)]
            http://www.wintra.co.il/
            sigpic
            Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

            We donít stop playing because we grow old, we grow old because we stop playing.

            Comment


            • #7
              Re: Connect to the Internet problem

              Is this SBS 2003 Standard or Premium? If premium, is it connected to the internet directly using ISA as the firewall? If not, what is the network's firewall?

              Just a stab in the dim... is UPnP enabled on the router? SBS 2008 uses UPnP to frob with the router, but I'm not sure if 2003 does the same and my brief interlude with Google didn't help me. You can try enabling UPnP on the router and then run the SBS wizard. Make sure to disable UPnP after the wizard has done its work. UPnP is heinously insecure.
              Wesley David
              LinkedIn | Careers 2.0
              -------------------------------
              Microsoft Certifications: MCSE 2003 | MCSA:Messaging 2003 | MCITP:EA, SA, EST | MCTS: a'plenty | MCDST
              Vendor Neutral Certifications: CWNA
              Blog: www.TheNubbyAdmin.com || Twitter: @Nonapeptide || GTalk, Reader and Google+: [email protected] || Skype: Wesley.Nonapeptide
              Goofy kitten avatar photo from Troy Snow: flickr.com/photos/troysnow/

              Comment


              • #8
                Re: Connect to the Internet problem

                Thank you all for your useful answers. This is a Standard SBS 2003 and it has 2 nics. One is connected to the Internet with a D-Link router. I prefer not to try the UPnp now because I'm on remote and I can't take the risk to lose the connection. Anyway this wizard support Upnp. I saw the log file and I found an error. I think that the problem is there. Here is the log:

                19/03/2009 15.56
                C:\Programmi\Microsoft Windows Small Business Server\Networking\ICW\wizcert.dll, version 5.2.2893.0
                Calling CCertCommit::ValidatePropertyBag
                Nothing is published, will not touch SSL Settings
                *** CCertCommit::ValidatePropertyBag returned ERROR 1
                19/03/2009 15.56
                C:\Programmi\Microsoft Windows Small Business Server\Networking\ICW\wizemail.dll, version 5.2.2893.0
                calling CEmailCommit::ValidatePropertyBag ().
                calling pdispPPPBag->QueryInterface (IPropertyPagePropertyBag, 0x6e50c).
                Call to pdispPPPBag->QueryInterface () returned ok.
                calling ReadInt4 (0xfcaee0, DB5E5E45-3598-4F1D-8FF7-0ED35B9EB6A4).
                Call to ReadInt4 () returned ok.
                The out param of ReadInt4() is -1.

                Do you know what this error mean?

                Comment


                • #9
                  Re: Connect to the Internet problem

                  A little update.
                  I realized the the problem is correlated to the SSL certificate. At the moment a SSL certificate is not installed. I think this because the option "Use the existing certificate" is not available in the wizard. The wizard doesn't find the certificate and, for some reason, it can't build a new one. IMHO installing manually a new self-signed certificate could solve the issue. Can you tell me if that operation is possible?
                  Thanks

                  Comment


                  • #10
                    Re: Connect to the Internet problem

                    Originally posted by guidone View Post
                    A little update.
                    I realized the the problem is correlated to the SSL certificate. At the moment a SSL certificate is not installed. I think this because the option "Use the existing certificate" is not available in the wizard. The wizard doesn't find the certificate and, for some reason, it can't build a new one. IMHO installing manually a new self-signed certificate could solve the issue. Can you tell me if that operation is possible?
                    Thanks
                    \you may be best to purchase a 3rd Party one to ensure that your users do not receive an error when accessing emails from outside.

                    Comment

                    Working...
                    X