No announcement yet.

SBS 2003 - Group policys not being applied

  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003 - Group policys not being applied


    We have several small domains which all have their own SBS onsite. On 1 site I started testing group policys but they are nto being applied.

    It is a logon script in vbs. the script is put on the sysvol share and is accessible by the clients. When applying the script manually netwrok drives and printers are mapped without problems. Through group policys I do not get any result.

    I have set proper permissions to the GPO and linked the GPO to the correct OU.

    When running the results of the GPO on the client via mmc, I do not see the login script so still seems as a permission problem to me.

    I have disabled script scanning in the antivirus software, did not help, took down the AV services. did not help.

    At my previous job I managed many GPO's on a 2003 server without problems, can't see what is going wrong on the SBS.

    What more to check?



  • #2
    Re: SBS 2003 - Group policys not being applied

    There is no inherent difference between GPO management on SBS and 2003 - SBS does add quite a few policies of its own, but that doesn't change the issue.

    Have you tried running RSOP.MSC on an affected station and see what is causing the problem? Or GPO Modelling in the management console?

    Steven Teiger [SBS-MVP(2003-2009)]
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.


    • #3
      Re: SBS 2003 - Group policys not being applied


      I have run rsop. I can see that the group policys are not being forced to the local system. So permission problem probably.

      Again, the client can access the share on which the script is put and i have set permissions to the group policy object itself, as well to the computer as to the user.

      FYI - I have disabled the built in GP objects of the SBS.
      ... ?


      Last edited by bertk; 19th February 2009, 17:37.


      • #4
        Re: SBS 2003 - Group policys not being applied

        It sounds to me like the script is in the wrong location. Legacy scripts go in the Netlogon folder. GPO scripts go in the appropriate scripts folder in the GPO folder like this: \\dc\SYSVOL\domain.local\Policies\{2D34527D-FA44-40CA-9AF4-4011458D5A00}\User\Scripts\Logon. Where exactly is your script?


        • #5
          Re: SBS 2003 - Group policys not being applied

          Does the script file name have spaces? I seem to remember a similar problem and removing the spaces on the script name allowed it to run through a GPO.


          • #6
            Re: SBS 2003 - Group policys not being applied


            Thanks for the replies. I have checked few thing out but no success.

            The script is put in \\srv-geel-int\sysvol\intertime.local\policies{79C33359-3F10-4ED9-BC3B-B1652A91512E}\user\scripts\logon\intertime.vbs .

            Previously the script was called, I changed it to intertime.vbs , ran gpupdate /force on the client. Still when running rsop.msc nothing is put under the login scripts.

            Is it wise to delete the folder \\srv-geel-int\sysvol\intertime.local\policies{79C33359-3F10-4ED9-BC3B-B1652A91512E}\ or should I stay of.

            Meanwhile, I have created a new GPO with the same script at the logon but still no result when running rsop.msc.

            I deleted the user profiles from the client, logged on to the domain again, nothing. Tried on another client to see if it was not computer related, nothing. I both tried on XP and 2000 client.

            The script is as follows:

            Option Explicit
            Dim oNetwork, strDriveLetter, strHomeServer, strDriveLetter2, strHomeServer2
            Dim oGroupList
            Set oNetwork = CreateObject("WScript.Network")
            Set oGroupList = CreateObject("Scripting.Dictionary")
            strDriveLetter2 = "I:"
            strHomeServer2 = "\\SRV-GEEL-INT\intertime"
            oNetwork.MapNetworkDrive strDriveLetter2, strHomeServer2
            Wscript.Echo "Mapped Drive " & strDriveLetter2 & " to " & strHomeServer2
            On Error Resume Next
            On Error Goto 0

            script is working without problems when launched local on client
            Last edited by bertk; 20th February 2009, 12:43.


            • #7
              Re: SBS 2003 - Group policys not being applied

              Have you tried adding the script to a file share with users given read access to it. You could create it as a hidden share. That way you know the permissions are set up right. The share will just need to be visible by all DCs and of course, the script won't replicate anymore but worth a try.

              To be honest, I run all my scripts that way as I know they are always handy to get to should I want to manually run them.

              The other thing, when you run the script locally, has it been tested with one of the users it needs to apply to?


              • #8
                Re: SBS 2003 - Group policys not being applied

                Created a share, set permissions correct. Tried to access from client, all ok. Copied the script to the new share and linked the GPO script to the new share. Still nothing going on at the client.

                When I run the script local, the windows secutiy warning came up, I have disabled it now so vbs scripts will run immediately without needing to click OK. (added FQDN to trusted sites)

                Still when running gpupdate no results. Seems to me like clients are not setup correctly in the domain although not much can go wrong there.


                • #9
                  Re: SBS 2003 - Group policys not being applied

                  There are other parameters that can be set for silent install of the script in the GPO itself. They may be worth looking at.

                  Also, double check the permissions on the GPO. Make sure the PCs and/or relevant user groups have read and apply permission to it.

                  Also, check that inheritance is not blocking any GPOs on OUs etc.

                  Apologies if you have already done this below.


                  • #10
                    Re: SBS 2003 - Group policys not being applied

                    Deleted OU's, GPO, script. Recreated everything.

                    Script is working now under "computer config - win scripts - startup", for some reason it won't work under "user settings - win - scripts - logon" which was the meaning.

                    Network shares need to be mapped according to the person that is accessing the computer. any ideas?

                    What I have seen in the GPmgt module is that when I create a report from the GPO, it still displays settings that I have deleted (i deleted the user configuration logon option). When I go and check these settings via GPO edit, these settings are blank. In the report they are visible. Is there a way to refresh everything that is GPO related on a server (without the need to reboot)?
                    Last edited by bertk; 20th February 2009, 16:55.


                    • #11
                      Re: SBS 2003 - Group policys not being applied

                      You could create a separate GPO for each Network Share or Shares that need to be mapped for a user and then lock it down with appropriate groups. Remove the everyone or authenticated users group if present and set another group as Read and Apply permisisons for the GPO.

                      With regards to refreshing Group Policy, it may work if you run 'gpupdate' from the command line.


                      • #12
                        Re: SBS 2003 - Group policys not being applied

                        Thanks, might be worth checking out. Will have it checked by Tuesday and post reply after.
                        Last edited by bertk; 22nd February 2009, 12:07.


                        • #13
                          Re: SBS 2003 - Group policys not being applied

                          No luck. I will apply the policy on machine level and try to continue from there. If I find a solution to apply the policu on user level I will post it back in this thread.

                          Thanks for all the input!! Really appreciated the help.