Announcement

Collapse
No announcement yet.

IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

    I just cannot get my head around this whole sites, virtual directories and applications.

    We've got two sbs2008 servers, on one when you go to www.domain.com you automatically come to www.domain.com/remote
    On the second when you go to www.domain.com you get a "permission denied", but if you manually go to www.domain.com/remote everything works.

    What i want to do is make /remote the default application when user go to www.domain.com, i cannot understand how to do this.
    I made a somewhat bad solution by changing the physical path for the sbs web applications directory.

    The biggest problem here is that i've actually managed to do it with our own server, i'm not sure if i did it manually or it came because i migrated our own server from sbs2003. The second server is a clean install.

    I tried asking on iis.net:s forum but they told me it's a sbs problem.

  • #2
    Re: IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

    Assuming alot based on the scant details provided: you need to redirect the default web site to the /remote virtual directory to accomplish what you're after.

    Comment


    • #3
      Re: IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

      Originally posted by joeqwerty View Post
      Assuming alot based on the scant details provided: you need to redirect the default web site to the /remote virtual directory to accomplish what you're after.
      Do i do this redirect in the IIS Manager or in a configuration file somewhere or do i do an asp-redirect in default.asp?

      What i did was to start IIS Manager, go to myserver, "SBS Web Applications", click advanced settings.
      I then changed "Physical Path" from
      C:\Program Files\Windows Small Business Server\Bin\WebApp\SBS Web Applications to
      C:\Program Files\Windows Small Business Server\Bin\WebApp\Remote.
      This is because when i went to www.domain.com i apparently came to the root application for "SBS Web Applications" application-group, which was nothing.

      I assume that this will backfire on me sometime soon.

      I'm not sure if this makes it clearer or not
      We have mail.ourdomain.com that automatically transfers me to mail.ourdomain.com/Remote

      The client-server runs mail.theirdomain.com that doesn't work, 403 forbidden: access is denied.
      If i however type mail.theirdomain.com/remote i get the right page. What i want is mail.theirdomain.com to take me to /remote instead, in other words have /remote to be the default application.

      Comment


      • #4
        Re: IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

        Yes, you do this in IIS. Right click the Default Web Site and select Properties, select the Home Directory tab, select the third radio button and type in the URL that you want users to go to: /remote. That will send users to www.domain.com/remote when they type www.domain.com in their browser (assuming that there is a /remote virtual directory).

        Comment


        • #5
          Re: IIS7 & /Remote - How do i configure what application starts at domain.com/ ?

          Originally posted by joeqwerty View Post
          Yes, you do this in IIS. Right click the Default Web Site and select Properties, select the Home Directory tab, select the third radio button and type in the URL that you want users to go to: /remote. That will send users to www.domain.com/remote when they type www.domain.com in their browser (assuming that there is a /remote virtual directory).
          Thanks alot for your help, this was a much cleaner and better solution.

          This beeing iis7 we no longer have a "properties" option and "home directory"-tab, we click "default web site", choose the "HTTP Redirect" icon under IIS.
          I chose to redirect only content in this directory, not subfolders, to https://www.domain.com/remote with status code 302 (found). Could probably have put permanent there.

          I also reset the previous settings i had made, pointing sbs web applications to the default folder again.

          At the same time i got an error when trying www.domain.com/owa, "The custom error module does not recognize this error." I fixed this by going to "C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa" and adding iis_iusrs read access to the web.config file

          Everything works fine, so again thanks alot.

          Comment

          Working...
          X