Announcement

Collapse
No announcement yet.

SBS 2003 Terminal Service Application mode

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003 Terminal Service Application mode

    I know in SBS 2003 TS application mode is disabled. I am able to enable it by a registry tweak - changing TSAppcompat to 1. But on restarting the server none of the MMC works and the display properties screen shows weird screens, most of the start menu options seems to lost the icons. When starting any MMC it give message "Failed to create emty document". Do anybody have any idea how i can tackle this? When I change TSAppcompat back to 0, then all back to normal, but i need to enable TS application mode in the server somehow, pls help me out

    thanks
    suji[/b]

  • #2
    As you say it's not possible, I don't know of any work arounds (that work properly anyway).

    Why would you want your users accessing your DC\Exchange server anyway ? That could be a potential disaster.

    topper
    * Shamelessly mentioning "Don't forget to add reputation!"

    Comment


    • #3
      Originally posted by topper
      As you say it's not possible, I don't know of any work arounds (that work properly anyway).

      Why would you want your users accessing your DC\Exchange server anyway ? That could be a potential disaster.

      topper
      i'm not concerned about the disaster...cos i dont expect much and as well i can restrict users to access onlyt he required application thru TS...hence the first part of disaster is taken care of....it a small company....i have to get this worked out somehow...
      i am able to enable TS in application mode by this tweak and that works fine...but cant resolve the issue of the mmc's and the misbehaviour

      Comment


      • #4
        Can't you just make do with running it in Admin mode with just the 2 connections ?

        topper
        * Shamelessly mentioning "Don't forget to add reputation!"

        Comment


        • #5
          Originally posted by topper
          Can't you just make do with running it in Admin mode with just the 2 connections ?

          topper
          No...i need 7 concurrent connections atleast.....

          Comment


          • #6
            SBS Application mode

            Hi there, over the past couple of months I have been put in a similar position.
            I have had to force enable application mode on my SBS 2003 box.
            I have no issue on the security and performance.
            My box has Dual XEON's - 4 GB of RAM - turned, locked down and major Policies so that the users are severly restricted in their business abilities.

            I have been experiencing the same behavour. There needs to be some other registry element that affects the mangement of the graphics.

            I hvae an onboard Radeon 7000m grapics engine. Once I updated my graphics driver from IBM .. it got better.

            Here is a quick trick - log on to the console first.
            Then startup a TS session.
            I am then able to lanunch the MMC.

            But I am still getting some other graphics related issues with the users session., and based on my testing, it is all around the video.

            I have read some other forums on how TS handles the video and that is what I now looking into.

            I would welcome comments please.

            Again, I am not a novice at locking down user access.
            I am not concerned about the potential security or issue with being on a DC. I only have 15 users and a very controlled environment.

            This needs to work.

            John

            Comment


            • #7
              Adding FlatTempDir to my testing for proper Application mode

              I have just realized that I may need to add FlatTempDir set to 1
              to properly enable the way that temporary files are processed.
              I will let you know the results.


              Value: FlatTempDir
              Type: REG_SZ
              Data value: 1 (enabled, the default setting)

              JG

              Comment


              • #8
                FlatTempDir and MMC Server management

                Ok,so far so good .. but it takes a bit of time and a bit of a load for me to see some of the problems associated with enabling Application mode..

                Again, you can run the MMC from a TS session, not from the conosole.
                And with a bit of luck, I can also get it to run from the console.
                At the end of the day, as long as I can get it to run, I am fine with it.

                I am more concerned about our applications on the TS session.
                Missing icons in the gui, etc. that is what I am focusing on.
                And I will get it fixed.
                I have to.
                J

                Comment


                • #9
                  More tricks for TS 2003 SBS Application mode

                  Ok, I just saw that my graphics accelerator was turn down.
                  I turned it up and so far so good.
                  also uncheck mark the box below the accelerator (that is if your graphic card supports the option).
                  J

                  Comment


                  • #10
                    Limiting the Max Color depth to 8bit

                    Ok, I have also set the max color depth to 8bit in the RDP-tcp properties.
                    This is limiting the color depth to 256 (and that is all that I need to support
                    our business applications) - heck we only had 256 with TS 2000 !

                    So far .. so good .. J

                    Comment


                    • #11
                      yes...this looks fine now...as you said 8bits diaplay setting in the TS makes the difference, on doing this i'm able to get my MMC aleast thru TS sessions..24bit also work ok...but 8bits is better even though it doesnt giver me the proper color in certain screens but gives me all the functionalities from admin point of view...

                      these r the changes i did so far:
                      in the registry:
                      TSappcompat=1
                      FlatTempDir=1

                      Terminal Service Configuration -> RDP-Tcp -> Client Setting -> Limit Max Color Depth - 8bits

                      i have to still update my display driver: ATI RAGE XL and see if it makes any diff...

                      Comment


                      • #12
                        Sujivp, are you experiencing any problems with applications that complain about memory ? to low in memory ?
                        please let me know .. I have an app that works fine when not in TS Application mode and then complains when I re-enable TS App mode.
                        J

                        Comment


                        • #13
                          hi john

                          so far i dont have any mem issues...in fact i dont have any other appl running on the server other than exchange, and file sharing and antivirus stuff.....the only appl i have to use the server for is a dos appl...will be accessed over lan and then 7 users thru TS...TS will go live tomrw....so i'll be able to know further how it behaves...i tried it with 2-3 users...its fine so far..i'll let u know the outcome..

                          Comment


                          • #14
                            hi john...
                            things look fine so far from operational point of vew...there r now issues from user end...but on the server side the same story of MMC, but am able to manage a TS session on the console....

                            Comment


                            • #15
                              hi

                              i'm now facing low memory issues when i installed an applicaiton on the server...i cant load this application even on a TS session on the console...still its complaining of lowa memory....any suggetion on this??

                              Comment

                              Working...
                              X