No announcement yet.

wsus 3.0 install

  • Filter
  • Time
  • Show
Clear All
new posts

  • wsus 3.0 install

    My goal was to uninstall wsus 3.0 (the beta I downloaded a while ago) and install wsus 3.0 sp1. During the install process, I canceled out when it brought up the configuration page as the instructions said to do. Then I checked the update services in the server management console and I had the blue shield message stating that it was not working because I had changed settings.
    Windows Small Business Server (Windows SBS) Update Services is not running because it automatically turns off if you customize Windows Server Update Services (WSUS).
    For a list of specific settings that cause Windows SBS Update Services to turn off, see the Microsoft Web site. Even if WSUS is managing updates for your network, the
    accuracy of the status in the Windows SBS monitoring report or on the Update Services home page cannot be guaranteed. To use Windows SBS Update Services, reverse 
    the changes that you have made to WSUS or reinstall Windows SBS 2003 R2.
    I changed no settings. So, I did some googling and found that it should be set to "update automatically" rather than "update manually" and changed that. Now I get this:

    Server Error in '/UpdateServices' Application.
    This is an unexpected token. The expected token is 'NAME'. Line 1, position 2.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    Exception Details: System.Xml.XmlException: This is an unexpected token. The expected token is 'NAME'. Line 1, position 2.
    Source Error: 
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 
    [XmlException: This is an unexpected token. The expected token is 'NAME'. Line 1, position 2.]
       Microsoft.UpdateServices.Internal.ClassFactory.CallStaticMethod(Type type, String methodName, Object[] args) +220
       Microsoft.UpdateServices.Internal.BaseApi.Subscription.GetSynchronizationHistory(DateTime fromDate, DateTime toDate) +116
       Microsoft.UpdateServices.Internal.BaseApi.Subscription.GetLastSynchronizationInfo() +98
       Microsoft.SBS.UpdateServices.DataProvider.GetSyncStatus() +74
       Microsoft.SBS.UpdateServices.StatusPage.Utility.SyncInProgress(DataProvider dp) +168
       Microsoft.SBS.UpdateServices.StatusPage.formHome.Page_Load(Object sender, EventArgs e) +290
       System.Web.UI.Control.OnLoad(EventArgs e) +67
       System.Web.UI.Control.LoadRecursive() +35
       System.Web.UI.Page.ProcessRequestMain() +750

    Any ideas what I can do to get this working again? I am running sbs 2003 r2 on a dell poweredge 2900. If you need any more info, let me know. Thanks.
    Last edited by noRulez43; 11th September 2008, 14:55.

  • #2
    Re: wsus 3.0 install

    I was able to fix it after 4 days of online research. Finally found the right page and used method 2(an sql script) to fix the problem. Here's the page:


    • #3
      Re: wsus 3.0 install

      Thanks for posting back with the solution. This sort of Community Spirit is what we aim for and appreciate your participation.
      Last edited by biggles77; 13th September 2008, 13:55. Reason: Typo
      Joined: 23rd December 2003
      Departed: 23rd December 2015