Announcement

Collapse
No announcement yet.

RPC over HTTP not connecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTP not connecting

    Laptop is not connected to the SBS 2003 Domain.
    OWA (https) works without a problem, so 443 is ok and open on the firewall.
    Website can be accessed externally so 80 is ok and open on the firewall. Obviously both have the correct Port Forwarding configured.

    I have UTFW but still no connection. Outlook works when physically connected to the Domain (with the laptop not joined to the Domain) but that may be a TCP connection and not RPC over HTTPS.

    No errors in the Event Viewer.

    Any ideas what I have missed?
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

  • #2
    Re: RPC over HTTP not connecting

    It could be a multitude of things but here are two that I would check:

    1. Is the "RPC-HTTP back-end server" option selected on the RPC-HTTP tab of the Exchange server properties?

    2. Have you verified that you have the following registry values on your Exchange server, making sure you have the appropriate NetBios and FQDN names in the key?

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
    "Enabled"=dword:00000001
    "ValidPorts"="SERVERNETBIOSNAME:6001-6002;SERVER.INTERNALFQDN.COM:6001-6002;SERVERNETBIOSNAME:6004;SERVER.INTERNALFQDN.CO M:6004;"

    Comment


    • #3
      Re: RPC over HTTP not connecting

      Originally posted by joeqwerty View Post
      It could be a multitude of things but here are two that I would check:

      1. Is the "RPC-HTTP back-end server" option selected on the RPC-HTTP tab of the Exchange server properties?
      NOT on SBS - see attachment and UTFW is fine.
      Take it one stage further. Open up //<servername>/remote and log on. Open up the link "Configure your Computer to Use Outlook over the Internet" and use that document as a check. One of the brilliant things about that document is that is it written specifically for your server - you can cut and paste the URL's into your Outlook.
      BTW if you want to see how you are connecting with Outlook, hold down the CTRL key and rt-click on the Outlook icon in the system tray. Choose "Connection Status" which gets added to the context menu and you get a full report!

      HTH
      Attached Files
      TIA

      Steven Teiger [SBS-MVP(2003-2009)]
      http://www.wintra.co.il/
      sigpic
      Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

      We donít stop playing because we grow old, we grow old because we stop playing.

      Comment


      • #4
        Re: RPC over HTTP not connecting

        It was a case of not seeing the wood for the trees. Bloody syntax error.......now if I can just find the snake who installed it.

        Once I knew it was connecting via HTTPS I was able to see the error.

        CTRL Right Click, Thanks Steven. And Joe, appreciate your contribution as well.
        1 1 was a racehorse.
        2 2 was 1 2.
        1 1 1 1 race 1 day,
        2 2 1 1 2

        Comment


        • #5
          Re: RPC over HTTP not connecting

          Originally posted by teiger View Post
          BTW if you want to see how you are connecting with Outlook, hold down the CTRL key and rt-click on the Outlook icon in the system tray. Choose "Connection Status" which gets added to the context menu and you get a full report!

          HTH
          Very useful suggestion,

          I appreciated so much that.

          Thank you VM

          Comment


          • #6
            Re: RPC over HTTP not connecting

            I think I know where is the problem ....
            - You have run the wizard and have selected OWA
            - You know that Outlook can conenct inside on the network
            - You have tried to access the exchange over the Internet by https://(your server)/exchange and you see the login page so we know 443 is there

            Now you are outside network and your Outlook cannot open ...right?
            Follow up this few steps to setup the Outlook to conenct over RPC to your SBS

            In Outlook 2003
            - TOOLS / OPTIONS
            - Select Mail Setup/ Email Accounts
            - Click NEXT and your account should be highlighted and click on CHANGE
            - Down left click on MORE SETTINGS
            - Click Connection
            - Make sure you have checked "Connect to my Exchnange mailbox using HTTP"
            - Click on the button " Exchnage Proxy Settings"
            - On the https:// type your FQA such as mail.mycompany.com
            - On last line click on drop down menu and select BASIC AUTHENTICATION
            - Hit OK -- you will need to Close and open Outlook
            - if everything is setup OK on server and firewall you should get a popup in your oUtlook to enter user name SRV\User and passwqord and conenct to your Exchnage over RPC
            - you can in Taskbar right clikc on Outlook icon with CTRL pressed and select Connection STATUS to see if the Outlook is connecting

            Good luck!

            Comment


            • #7
              Re: RPC over HTTP not connecting

              Just re-read over this thread and I have a question? Is this computer a member of the domain? Does it have the domain certificate installed?
              Last edited by teiger; 21st November 2007, 17:35. Reason: Typo
              TIA

              Steven Teiger [SBS-MVP(2003-2009)]
              http://www.wintra.co.il/
              sigpic
              Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

              We donít stop playing because we grow old, we grow old because we stop playing.

              Comment


              • #8
                Re: RPC over HTTP not connecting

                Ths problem was solved on November 12 after your post Steven. The CTRL + Right Click and the resulting info lead me to find the typo I made in the setup.

                This is a solved thread. Perhaps it could be closed.
                1 1 was a racehorse.
                2 2 was 1 2.
                1 1 1 1 race 1 day,
                2 2 1 1 2

                Comment

                Working...
                X