Announcement

Collapse
No announcement yet.

Company Web Access Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Company Web Access Issue

    Hi,

    Recently I had an issue with the Company Web on an SBS Server. When I go to connect I get the following message:-

    Access denied. You do not have permission to perform this action or access this resource.

    Access requests are not enabled.

    Troubleshoot issues with Windows SharePoint Services.

    Previously I couldn't get anything to come up when I typed in http://companyweb/default.aspx the page would redirect out to search the web. I updated the dns records and now I get the surroundings of the company web page but apparently I can't access it.

    Not sure how many people have played with this prior to me getting involved so I don't really know how to approach this issue. Is there a general troubleshooting guide / methodology for company web issues??.

    Any help would greatly appreciated.


    Thanks

  • #2
    Re: Company Web Access Issue

    UTFW: In the server management console, under users, there is a Change User Permissions wizard. Choose one of th estandard templates and you will have standard access to Companyweb, if that doesn't have too many changes.
    TIA

    Steven Teiger [SBS-MVP(2003-2009)]
    http://www.wintra.co.il/
    sigpic
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.

    Comment


    • #3
      Re: Company Web Access Issue

      Just for completeness, Teiger's "UTFW" comment means "Use the Wizard". Think about it.


      Tom
      For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

      Anything you say will be misquoted and used against you

      Comment


      • #4
        Re: Company Web Access Issue

        That's why I posted SBS abbreviations at the head of this forum.
        TIA

        Steven Teiger [SBS-MVP(2003-2009)]
        http://www.wintra.co.il/
        sigpic
        Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

        We donít stop playing because we grow old, we grow old because we stop playing.

        Comment


        • #5
          Re: Company Web Access Issue

          Unfortunately that didn't work for me. I get a login screen which prompts for username and password twice and then reverts to the following error message

          Server Error in '/_layouts' Application.
          --------------------------------------------------------------------------------

          Runtime Error
          Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

          Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".


          <!-- Web.Config Configuration File -->

          <configuration>
          <system.web>
          <customErrors mode="RemoteOnly"/>
          </system.web>
          </configuration>


          Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


          <!-- Web.Config Configuration File -->

          <configuration>
          <system.web>
          <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
          </system.web>
          </configuration>


          Am really lost now??.

          Comment


          • #6
            Re: Company Web Access Issue

            Sorry, but you can sift through the links provided. http://www.google.com.au/search?hl=e...e+Search&meta=
            1 1 was a racehorse.
            2 2 was 1 2.
            1 1 1 1 race 1 day,
            2 2 1 1 2

            Comment


            • #7
              Re: Company Web Access Issue

              Okay the error message I was receiving when trying to access the Company Web relate to .Net. I removed .Net and the error message goes away and is replaced by a normal "page cannot be displayed" message.

              Still can't get company web to work but getting closer I think.

              Comment


              • #8
                Re: Company Web Access Issue

                Okay there are files missing from the C:\WINDOWS\Microsoft.NET\Framework\"any version"\Temporary ASP.NET Files

                Appears to be missing the directories and files for root, monitoring, and remote.

                Any idea how I can get these files to install?... Or any tools available to troubleshoot .net.

                Thanks again for your help

                Comment


                • #9
                  Re: Company Web Access Issue

                  I'm not for sure I can help, but lets backup a little bit here. When you say you removed .NET, what does that mean? What exactly did you do?

                  Comment


                  • #10
                    Re: Company Web Access Issue

                    Originally posted by Cogent View Post
                    Okay there are files missing from the C:\WINDOWS\Microsoft.NET\Framework\"any version"\Temporary ASP.NET Files

                    Appears to be missing the directories and files for root, monitoring, and remote.

                    Any idea how I can get these files to install?... Or any tools available to troubleshoot .net.

                    Thanks again for your help
                    IN CP/Add Remove Programs take away the Intranet and then reinstall it. Are you Pre-SP1 ? then http://support.microsoft.com/kb/829114
                    TIA

                    Steven Teiger [SBS-MVP(2003-2009)]
                    http://www.wintra.co.il/
                    sigpic
                    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                    We donít stop playing because we grow old, we grow old because we stop playing.

                    Comment


                    • #11
                      Re: Company Web Access Issue

                      Thanks Teiger,

                      I have run the sbs setup a number of times now and the intranet installation always fails. Have removed IIS as well and then re-run the sbs setup all to no avail.

                      What would you suggest I do from here. I am running service pack 1, have the sr2 disk here and have tried to install that also. The installation failed.

                      Thanks again

                      Comment


                      • #12
                        Re: Company Web Access Issue

                        Hi,

                        FYI I ended up putting a call in to Microsoft Technical support and paying for an SBS senior technician to work on this issue for me.

                        Below are the steps he outlined as a fix to this issue. Prior to the technician performing the steps below I had already uninstalled and reinstalled IIS / exchange / etc on the server which is necessary for the steps below to work. The technician tried this on our live server without doing the IIS removal / reinstall and was not successful.

                        Hope this helps. Thanks

                        Resolution
                        ==========

                        1. Manually delete the Host(A) record of the companyweb in the DNS console of the SBS server.

                        2. Follow the below KB article to reinstall the Companyweb

                        829114 How to remove and how to install the Windows Small Business Server 2003 SharePoint Services companyweb Web site
                        http://support.microsoft.com/default...b;EN-US;829114

                        3. Make sure the SBS server Companyweb is running under .Net Framework 1.1 instead of 2.0.

                        Go to the properties of companyweb.
                        Go to the ASP.NET tab.
                        On the ASP.NET version select the drop-down and change from the 2.0.50727 to 1.1.4322.
                        Apply and close out the properties.

                        That should do it!!.

                        Good Luck

                        Comment


                        • #13
                          Re: Company Web Access Issue

                          Thank you for posting back with a solution after all this time. Your Community Spirit is appreciated and the Rep Points added for this reason.

                          All I can say is "you gotta be shitting me". Why are these blasted .Net Frameworks NOT compatible.
                          1 1 was a racehorse.
                          2 2 was 1 2.
                          1 1 1 1 race 1 day,
                          2 2 1 1 2

                          Comment


                          • #14
                            Re: Company Web Access Issue

                            your bad luck... May be you don't know or the person who suggested you doesn't know about COMPANYWEB.

                            You should never ever try to un-install the IIS. ......BIG MISTAKE..


                            always use support.microsoft.com/kb/829114 for Intranet installation and removal purpose.





                            ===========
                            I m my Answer.

                            Comment


                            • #15
                              Re: Company Web Access Issue

                              Nobody told him to uninstall IIS - only the Intranet/Companyweb .
                              FYI there is also a white paper out how to install WSS3.0 on SBS but it should be a SIDE-BY-SIDE installation and Companyweb should remain on WSS2.0 with the ASP.NET framework of v1.whatever-it-is.
                              TIA

                              Steven Teiger [SBS-MVP(2003-2009)]
                              http://www.wintra.co.il/
                              sigpic
                              Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                              We donít stop playing because we grow old, we grow old because we stop playing.

                              Comment

                              Working...
                              X