Announcement

Collapse
No announcement yet.

Problems with mirrored disk on sbs 2000 - SOS!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with mirrored disk on sbs 2000 - SOS!!!

    Hi folks (great job on the forums Petri),
    A client has a server with SBS 2000. On that server he has 2 IDE disks configured as a hardware mirror (on board).
    The client got hit by some mass mailing worm, so to be on the safe site, he took out one of the disks (I don't know which one) and broke the mirror. He then connected the remaining disk to the regular IDE connector (not the mirror one) and booted.
    (I will call the disk still in use as disk0, and the one he took out as disk1.)

    I got to him at that point. I cleared the worm, fixed his system, all works fine now. Then I wanted to get his 2nd disk back to the mirror array (i.e get disk1 into the array).

    I shut down the server, inserted the second disk as slave (here was my BIG mistake!!! ) and connected the 2 disks to the regular IDE connector, not to the RAID1 connector!

    Now, because disk0 was configured as master, I made the mistake of configuring disk1 as slave and booted the machine.

    W2K booted, I got to the logon screen, and there I found out that the computer has booted from the 2nd disk - disk1, not disk0. How do I know? I tried to logon as the admin with the password I configured that same day and couldn't, it wanted the password that was set back when disk1 was a part of the mirror.

    There I made mistake #2 and logged on. I looked around and I found that the system still had all the viruses inside the BADMAIL queue - i.e from disk1. Also I found out that it used the AD database from disk1. Also, the computer has switched drive letters.

    Let me explain:

    disk0 and disk1 are broken parts of the same mirror.
    disk0 is ok, disk1 has the viruses.
    disk0 has the WINNT and NTDS and EXCHSRVR folders. disk1 has the same databases - but they're 2 weeks old.
    disk0 is used as C:\
    when I connected disk1 and booted, it called disk0 as C: and disk1 as F:
    w2k booted into C:\, then loaded the W2K system from C:\, but strangely it used the NTDS and EXCHSRVR folders from F:\, not from C:\

    I tried to boot the os by adding a new line in BOOT.INI and pointed it to RDISK(1). It booted but again, it switched drive letters and folder locations!

    i.e: now, disk0 was still C:\ but disk1 got the letter D:\.
    w2k booted into C:\, then loaded the W2K system from D:\, but strangely it used the NTDS and EXCHSRVR folders from C:\, not from D:\.

    So it now seems that if I load the os from disk0 I get the os from disk0 but the AD and E2K db from disk1.

    And if I load the os from disk1 I get the os from disk1 but the AD and E2K db from disk0.

    I want to get things back to normal, meaning boot from disk0, load up the os from disk0, and use the AD and E2K db from disk0.

    HELP????

    Sorry for the v e r y long post, I hope it got through.

  • #2
    Is it still possible to boot only using the clean and most up-to-date versions of the DB disk ?
    Then you have again a system running... And then we can look further, I think that's the most important thing for your client not?

    Marty.
    Good technicians / scripters don't know everything, they just know where to look for the answer.

    Comment

    Working...
    X