Announcement

Collapse
No announcement yet.

Swing SBS Migration problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Swing SBS Migration problems

    Hi all

    I am currently using the swing migration method to move to a new SBS 2003 server.

    Current server uses SBS 2003, new server is using SBS 2003 R2 Premium. I am logged into the server using the domain administrator account which is a member of the local Administrators group, so rights/permissions should not be the problem.

    The problem I am getting is during the phase where SBS installs Exchange. The error message is:
    "Setup failed while installing sub-component Microsoft Windows Active Directory schema update with error code 0xC103798A (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again."

    I have googled and the nearest thing I can come up with is this article http://support.microsoft.com/kb/822583

    Anyone been through/seen this before????

    Here is the log of problems I am getting:


    [11:32:14] ***** RETRYING THE FAILED OPERATION *****
    [11:32:14] Beginning Install of Microsoft Windows Active Directory schema update sub-component
    [11:32:14] Entering CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScRemove
    [11:32:14] Entering CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScStopAtomServices
    [11:32:14] Leaving CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScStopAtomServices
    [11:32:14] Entering CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemove
    [11:32:14] Entering CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemoveRegistryKeys
    [11:32:14] Removing registry entries for Microsoft Windows Active Directory schema update
    [11:32:14] Entering CRegistryManager::ScProcessFile
    [11:32:14] ++++ Starting interpreter on file d:\exchsrvr65\setup\i386\exchange\schema.uns ++++ -- ID:31258 --
    [11:32:14] Leaving CRegistryManager::ScProcessFile
    [11:32:14] Leaving CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemoveRegistryKeys
    [11:32:14] Removing Active Directory objects for Microsoft Windows Active Directory schema update
    [11:32:14] Entering CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemoveShortcuts
    [11:32:14] Leaving CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemoveShortcuts
    [11:32:14] Removing IIS Metabase objects for Microsoft Windows Active Directory schema update
    [11:32:14] Leaving CBaseAtom(Microsoft Windows Active Directory schema update)::ScRemove
    [11:32:14] Entering CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScDeleteAtomServices
    [11:32:14] Leaving CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScDeleteAtomServices
    [11:32:14] Leaving CBaseServiceAtom(Microsoft Windows Active Directory schema update)::ScRemove
    [11:32:14] Entering CAtomSchema::ScAdd
    [11:32:14] Entering CAtomSchema::ScAddDSObjects
    [11:32:14] Creating Active Directory objects for Microsoft Windows Active Directory schema update
    [11:32:14] Leaving CAtomSchema::ScAddDSObjects
    [11:32:14] Entering CAtomSchema::ScAddRegistryKeys
    [11:32:14] Checking to see whether we have permission to import the display specifiers
    [11:32:14] Entering ScHavePermissionToCreateDSObject
    [11:32:14] Leaving ScHavePermissionToCreateDSObject
    [11:32:14] We have permissions; calling schema.ins
    [11:32:14] Entering CBaseAtom(Microsoft Windows Active Directory schema update)::ScAddRegistryKeys
    [11:32:14] Configuring registry entries for Microsoft Windows Active Directory schema update
    [11:32:14] Entering CRegistryManager::ScProcessFile
    [11:32:14] ++++ Starting interpreter on file d:\exchsrvr65\setup\i386\exchange\schema.ins ++++ -- ID:31258 --
    [11:32:14] Interpreting line <CreateProcess:d:\exchsrvr65\setup\i386\exchange\b in;regsvr32.exe /i /n /s maildsmx.dll;4294967295> -- ID:31259 --
    [11:32:14] Process created ... waiting (-1)
    [11:33:22] Process has exited with 0x000005
    [11:33:22] The command

    regsvr32.exe /i /n /s maildsmx.dll

    failed, returning error code 5 (Access is denied.). -- ID:31136 -- ScCreateProcess (f:\titanium\admin\src\libs\exsetup\hiddenw1.cxx:1 821)
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] CInsParser::ScProcessLine (f:\titanium\admin\src\libs\exsetup\hiddenw1.cxx:1 225)
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] Processing file 'd:\exchsrvr65\setup\i386\exchange\schema.ins', at or near line 8 (CreateProcess:d:\exchsrvr65\setup\i386\exchange\b in;regsvr32.exe /i /n /s maildsmx.dll;4294967295) -- ID:31111 -- CInsParser::ScProcessLine (f:\titanium\admin\src\libs\exsetup\hiddenw1.cxx:4 92)
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] Registry file name: 'd:\exchsrvr65\setup\i386\exchange\schema.ins' CRegistryManager::ScProcessFile (f:\titanium\admin\src\udog\setupbase\tools\regmgr .cxx:125)
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] Filename = 'd:\exchsrvr65\setup\i386\exchange\schema' CBaseAtom::ScAddRegistryKeys (f:\titanium\admin\src\udog\setupbase\basecomp\bas eatom.cxx:140
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] CAtomSchema::ScAddRegistryKeys (f:\titanium\admin\src\udog\exsetdata\components\r oot\a_schema.cxx:31
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] Leaving CAtomSchema::ScAddRegistryKeys
    [11:33:22] CAtomSchema::ScAdd (f:\titanium\admin\src\udog\exsetdata\components\r oot\a_schema.cxx:150)
    Error code 0XC103798A (31114): An internal component has failed.
    [11:33:22] Leaving CAtomSchema::ScAdd
    [11:33:22] mode = 'Install' (61953) CBaseAtom::ScSetup (f:\titanium\admin\src\udog\setupbase\basecomp\bas eatom.cxx:842)
    Error code 0XC103798A (31114): An internal component has failed.
    Last edited by hks-s14; 18th December 2006, 16:24.

  • #2
    Re: Swing SBS Migration problems

    Further to this, I ran some of the fixes implemented in the KB that I posted a link to in my first post and seem to have come up with some interesting results when running netdiag /fix

    For example, the domain membership/DC discovery and the like failed, even though the server holds these roles

    Server "pms001" knows about 5 roles
    Schema - CN=NTDS Settings,CN=PMS001,CN=Servers,CN=Default-First-Site-Name,CN=Sit
    es,CN=Configuration,DC=mydomain,DC=local
    Domain - CN=NTDS Settings,CN=PMS001,CN=Servers,CN=Default-First-Site-Name,CN=Sit
    es,CN=Configuration,DC=mydomain,DC=local
    PDC - CN=NTDS Settings,CN=PMS001,CN=Servers,CN=Default-First-Site-Name,CN=Sites,
    CN=Configuration,DC=mydomain,DC=local
    RID - CN=NTDS Settings,CN=PMS001,CN=Servers,CN=Default-First-Site-Name,CN=Sites,
    CN=Configuration,DC=mydomain,DC=local
    Infrastructure - CN=NTDS Settings,CN=PMS001,CN=Servers,CN=Default-First-Site-Nam
    e,CN=Sites,CN=Configuration,DC=mydomain,DC=local


    Here is the log of running netdiag /fix



    E:\Documents and Settings\Administrator.mydomain>netdiag /fix

    ....................................

    Computer Name: PMS001
    DNS Host Name: pms001.mydomain.local
    System info : Microsoft Windows Server 2003 (Build 3790)
    Processor : x86 Family 15 Model 4 Stepping 10, GenuineIntel
    List of installed hotfixes :
    KB911164
    Q147222


    Netcard queries test . . . . . . . : Passed
    [WARNING] The net card 'Intel(R) PRO/1000 MT Network Connection #2' may not
    be working.
    [WARNING] The net card 'Intel(R) PRO/1000 MT Network Connection' may not be
    working because it has not received any packets.



    Per interface results:

    Adapter : Server Local Area Connection

    Netcard queries test . . . : Passed

    Host Name. . . . . . . . . : pms001.mydomain.local
    IP Address . . . . . . . . : 192.168.0.254
    Subnet Mask. . . . . . . . : 255.255.255.0
    Default Gateway. . . . . . :
    Primary WINS Server. . . . : 192.168.0.254
    Dns Servers. . . . . . . . : 192.168.0.254


    AutoConfiguration results. . . . . . : Passed

    Default gateway test . . . : Skipped
    [WARNING] No gateways defined for this adapter.

    NetBT name test. . . . . . : Passed
    [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
    r Service', <20> 'WINS' names is missing.

    WINS service test. . . . . : Passed

    Adapter : Network Connection

    Netcard queries test . . . : Failed
    NetCard Status: DISCONNECTED
    Some tests will be skipped on this interface.

    Host Name. . . . . . . . . : pms001
    Autoconfiguration IP Address : 169.254.192.152
    Subnet Mask. . . . . . . . : 255.255.0.0
    Default Gateway. . . . . . :
    Primary WINS Server. . . . : 192.168.0.254
    Dns Servers. . . . . . . . : 192.168.0.254




    Global results:


    Domain membership test . . . . . . : Failed
    [WARNING] Ths system volume has not been completely replicated to the local
    machine. This machine is not working properly as a DC.


    NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
    NetBT_Tcpip_{06F3AB2B-4423-400F-A852-DD2E41F16CAD}
    NetBT_Tcpip_{9256E7FF-0C2B-4278-8443-673671A8EE95}
    2 NetBt transports currently configured.


    Autonet address test . . . . . . . : Passed


    IP loopback ping test. . . . . . . : Passed


    Default gateway test . . . . . . . : Failed

    [FATAL] NO GATEWAYS ARE REACHABLE.
    You have no connectivity to other network segments.
    If you configured the IP protocol manually then
    you need to add at least one valid gateway.


    NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
    ce', <03> 'Messenger Service', <20> 'WINS' names defined.


    Winsock test . . . . . . . . . . . : Passed


    DNS test . . . . . . . . . . . . . : Passed
    PASS - All the DNS entries for DC are registered on DNS server '192.168.0.25
    4' and other DCs also have some of the names registered.


    Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
    NetBT_Tcpip_{06F3AB2B-4423-400F-A852-DD2E41F16CAD}
    NetBT_Tcpip_{9256E7FF-0C2B-4278-8443-673671A8EE95}
    The redir is bound to 2 NetBt transports.

    List of NetBt transports currently bound to the browser
    NetBT_Tcpip_{06F3AB2B-4423-400F-A852-DD2E41F16CAD}
    NetBT_Tcpip_{9256E7FF-0C2B-4278-8443-673671A8EE95}
    The browser is bound to 2 NetBt transports.


    DC discovery test. . . . . . . . . : Failed
    [FATAL] Cannot find DC in domain 'mydomain'. [ERROR_NO_SUCH_DOMAIN]


    DC list test . . . . . . . . . . . : Failed
    'mydomain': Cannot find DC to get DC list from [test skipped].


    Trust relationship test. . . . . . : Skipped


    Kerberos test. . . . . . . . . . . : Skipped
    'mydomain': Cannot find DC to get DC list from [test skipped].


    LDAP test. . . . . . . . . . . . . : Failed
    Cannot find DC to run LDAP tests on. The error occurred was: The specified d
    omain either does not exist or could not be contacted.

    [WARNING] Cannot find DC in domain 'mydomain'. [ERROR_NO_SUCH_DOMAIN]


    Bindings test. . . . . . . . . . . : Passed


    WAN configuration test . . . . . . : Skipped
    No active remote access connections.


    Modem diagnostics test . . . . . . : Passed

    IP Security test . . . . . . . . . : Skipped

    Note: run "netsh ipsec dynamic show /?" for more detailed information


    The command completed successfully

    Comment


    • #3
      Re: Swing SBS Migration problems

      Originally posted by hks-s14 View Post
      Global results:


      Domain membership test . . . . . . : Failed
      [WARNING] Ths system volume has not been completely replicated to the local
      machine. This machine is not working properly as a DC.
      I would say one of 3 things:

      Did you run adprep /forestprep and adprep /domainprep off the CD2 Support tools folder?
      or
      Did you remove the SP1 firewall on the second server to allow replication to complete?
      or
      Did you wait long enough for the replication to complete in either the joining of the tempDC to the domain or when joining the final server to the tempDC domain?

      In any case you are entitled to full support from sbsmigration.com with the kit you bought from there. ( You did buy it, didn't you...... ?)
      TIA

      Steven Teiger [SBS-MVP(2003-2009)]
      http://www.wintra.co.il/
      sigpic
      Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

      We donít stop playing because we grow old, we grow old because we stop playing.

      Comment


      • #4
        Re: Swing SBS Migration problems

        Thanks for the response.

        I think I may not have waited long enough for replication to occur. Yes I did buy the kit (well the guy who was in this job previously did) however I can't find out the registration details, annoying.

        Looks like I am going to have to go back and start again.

        Thanks for your help.

        Comment


        • #5
          Re: Swing SBS Migration problems

          Try contacting [email protected] and giving your details. Jeff may be able to trace your purchase.
          (BTW ycst=You Can Script That)
          TIA

          Steven Teiger [SBS-MVP(2003-2009)]
          http://www.wintra.co.il/
          sigpic
          Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

          We donít stop playing because we grow old, we grow old because we stop playing.

          Comment

          Working...
          X