No announcement yet.

Read-only File System

  • Filter
  • Time
  • Show
Clear All
new posts

  • Read-only File System

    I trying to use Austrumi nt_pass to reset my user password and unlock my account on a laptop with winnt 4.0. I don't have sysadmin privilages.

    At step 1, when it attempts to mount the NTFS partition, i get the following error:

    Mounting on /dev/ide/host0/bus0/target0/lun0/part2
    NTFS volume version 1.2.
    NTFS-fs error (device hda2): ntfs_check_logfile(): the two restart pages in $LogFile do not match.
    NTFS-fs error (device hda2): load_system_files(): failed to load $LogFile. Mounting read-only. Mount in Windows.
    Filesystem is: NTFS

    If I continue on with default prompts, it appears to allow me to reset the failed count, unset/disable and lockout, and reset password. However, I get the following output when I quit:

    Writing sam
    cpnt: /disk/WINNT/system32/config/sam: Read-only file system
    NOTE: A disk fixup will now be done.. it may take some time
    Mounting volume... OK
    Processing of $MFT and $MFTMirr completed successfully.
    NTFS volume version is 1.2
    Setting required flags on partition... OK
    Going to empty the journal ($LogFile)... OK
    NTFS partition /dev/ide/host0/bus0/target0/lun0/part2 was processed successfully
    NOTE: Windows will run a diskcheck (chkdsk) on next boot.
    NOTE: this is to ensure disk integrity after the changes

    ****** EDIT COMPLETE *****

    Although it appears to have worked, it did not. Nothing was changed. I still can't access the user account. If I run nt_pass again, it show the same account settings as before.

    Any suggestions?


  • #2
    Try using an older version of the program, I believe I ended up using 040116 or something like that. If you read through his FAQs, he mentioned the issue.


    • #3
      I searched his site and SourceForge and couldn't find a FAQ?

      Is the version number you show the date? The earliest I can find on SourceForge is austrumi-0.8.4 which has a date of 040328. I'll try that one.

      Would appreciate any additional info or links you can provide.



      • #4
        Nevermind...I figured it out... You were talking about the "Offline NT password & Registry Editor site" and not the Austrumi Distro site.

        Read the FAQ and got it to work perfectly. Thanks for the help.