No announcement yet.

Backup Exec 10 job takes age to complete

  • Filter
  • Time
  • Show
Clear All
new posts

  • Backup Exec 10 job takes age to complete


    First post on here so please go easy on me.

    I've got Backup Exec 2010R3 running on a real Windows 2008 R2 server, which is backing up to an external LTO4 tape drive.

    I do a full backup every day, however the length of the time the job takes to complete is very variable. Sometimes it's about 7 hours, other times it's 10 hours plus.

    The job is based on a policy which is set to run every week day and starts no earlier than 22.30 and no later than 22.59.

    Looking at the job summary information it says:-

    Original start time : Monday, January 27, 2014 10:30:00 PM
    Job started : Wednesday, January 29, 2014 10:30:00 PM
    Job ended : Thursday, January 30, 2014 11:01:34 AM
    Elapsed time : 12:31:34

    Firstly, why is the original start time two days before the job actually started?

    Looking at the media the tapes says they have used roughly 550GB of 745GB, so it doesn't look like the job is rolling onto a second tape.

    Also the last verify job in the job history finishes at 5am, which sounds about right.

    Any thoughts would be welcome!


  • #2
    Re: Backup Exec 10 job takes age to complete

    It seems there could be a number of reasons for the difference between "original start time" and "job started", such as the tape drive being busy. Are you certain that a writable tape was available on January 27? Do you have other backup jobs running at different times? It does seem a bit odd that the job would start precisely two days later. Does this happen often?

    As for the backups taking a long time to finish, LTO4 drives are pretty fast, so the problem could be excessive "shoe shining" if the server is unable to keep up with the drive. Have you observed the tape drive while the job is running?


    • #3
      Re: Backup Exec 10 job takes age to complete

      Check your AV as well, make sure that there are no scheduled scans etc during the backups. I've seen on-access scanning cause backups to run slowly too.
      BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
      Cruachan's Blog


      • #4
        Re: Backup Exec 10 job takes age to complete

        There are a few things that could cause this...

        Check the Window Event Logs (system and application) for errors, make sure that there aren't any other maintanance jobs getting in the way.

        also, the job/policy could be corrupt. Try recreating them.