Announcement

Collapse
No announcement yet.

Asus Z97-Pro BIOS update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus Z97-Pro BIOS update

    Hey, folks

    My home PC has an Asus motherboard, a Z97-Pro. The UEFI BIOS is V.1304 and I was going to update it.

    With our Dell machines at work I simply download and run an exe. Quick and easy.

    The Asus requires a .cap file being copied to USB and then using the BIOS to install it - no problem with that, but having watched a couple of vids and reading about it the update will reset all the settings. I did not setup the BIOS so have no idea what the settings are and there are a LOT of configuration options in the UEFI BIOS. I don't use RAID, so don't think there are any settings that I really need to worry about, but the problem, of course, is that I really don't know if flashing the BIOS might render the machine inoperable or affect it in some other way. One thing I am aware of is that a Corsair CPU liquid cooler is installed so don't know if compatibility issues might be introduced.

    Anyone know if there is a simpler, user-friendly way to do this, please?

    Thanks!
    A recent poll suggests that 6 out of 7 dwarfs are not happy

  • #2
    The last Asus board that I had included an applet that allowed you to install the BIOS Update from within Windows. It wasn't a UEFI one but from memory (which I don't trust that much now), it didn't change anything that had been customised. In other words, it keep any configuration changes that had been set.

    While you are most likely to be aware of the Flash Utility, I have included it for Justin Case. ASUS EZ Flash 2 Utility
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

    Comment


    • #3
      Thanks a lot Those are the instructions I have seen. I guess I'll take the plunge...
      A recent poll suggests that 6 out of 7 dwarfs are not happy

      Comment


      • #4
        Update: Worked a treat.

        Reason for doing it? My machine was freezing up when playing demanding games. I have two GTX770 cards installed, 16GB RAM, 8-core i7, SSD, and, as mentioned above a Corsair liquid cooler for the CPU. Less demanding games = no problems. But, playing Borderlands 2/Hard Reset Redux the machine would be OK for about 10-15mins, then the screen would freeze and the audio micro-stutters (I always have iTunes playing when gaming).

        I thought it might be a heat issue so I used an air duster to blow the cobwebs out - in all it was OK. I updated the system's drivers using a driver update utility - did not help. There was nothing in the logs. I ran driver verifier but that put the machine in an endless restart loop (it would last for about 10secs after logging in and then it was as if the machine had been forcibly restarted as it went straight back to the BIOS screen). No graceful shutdown, no BSOD's to help me.

        I updated the BIOS this morning. The first thing I noticed was that after restarting and logging in and running the Corsair Link program was that it requested an update. After updating it was able to configure the cooler. Previously, I had to use the BIOS utility to configure it, and I had used the Corsair Link program to monitor the temps etc. I had wondered why it seemed so limited - it had been like this since I bought the computer... During the last few weeks the cooler had been 'stuck' in 'Performance' mode - tweaking made no difference as the fans were spinning for all they were worth even after choosing 'Quiet' mode in the BIOS utility. Everything now seems fine!

        Fingers-crossed!

        [Edit]
        In case anyone else needs to update their BIOS if they have the same MB: The flash update utility did not recognise my USB drive, but it could see all the HDD's. I just drilled down to the folder on my data drive containing the .cap file and it saw it and installed it.
        Last edited by Blood; 20th August 2017, 21:24.
        A recent poll suggests that 6 out of 7 dwarfs are not happy

        Comment


        • #5
          The USB drive it didn't recognise, was it USB 3.0/3.1 or old USB 2.0? (Me guessing a 3x version)
          Last edited by biggles77; 21st August 2017, 09:17.
          1 1 was a racehorse.
          2 2 was 1 2.
          1 1 1 1 race 1 day,
          2 2 1 1 2

          Comment


          • #6
            Originally posted by biggles77 View Post
            The USB drive it didn't recognise, was it USB 3?
            No, it was a Kingston DataTraveler 512MB (a USB 2 drive). I tried the drive in USB 2 and 3 sockets on both the front and back of the machine.
            A recent poll suggests that 6 out of 7 dwarfs are not happy

            Comment

            Working...
            X