No announcement yet.

Unable to take ownership

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to take ownership


    I have a folder named Rachel on a 1TB USB hard drive (a Toshiba 3.5" HDD) that I am unable to take ownership of. The folder was originally on our data server (Win 2008 Storage Server), within a subfolder off the root: D:\pmail\Rachel. I used Robocopy to perform daily backups of the pmail folder to the USB HDD on my Win7 client. The original permissions were for full control for authenticated users on the pmail folder. The sub folders, which are named after mail accounts, are set up so that the mail box owner has full control, the domain administrator has full control and authenticated users have write permissions only.

    I need to remove the pmail backup on the USB HDD as I now have a new backup at another location. I was unable to delete the pmail fiolder and tried deleting the sub-folders instead. I received a 'Continue' message ('You don't currently have permission to access this folder') when bulk-selecting the folders for deletion but was still unable to delete them. Instead, I needed to double-click each folder, acknowledge the 'Continue' prompt after which permissions were given to my account (an account with domain admin and local admin permissions) and I could then delete the folders. About 100GB was deleted.

    However, when double-clicking the folder named Rachel and clicking Continue a dialog appears stating 'You have been denied permission to access this folder' and it states that I should use the Security tab to obtain access.

    The security tab shows the following:

    Normally, clicking Continue allows you to take ownership by specifying an account. When I try this I see 'Unable to display current owner' in the Current owner field. When I select my account, the local administrator account or the domain administrator account I see:

    I have tried sharing the folder and setting Full control on the Share permissions for my account and see another error when clicking OK:

    I have tried using the command line with rd and see a 'directory not empty' message. When trying cd Rachel (from pmail) I get access denied. I have tried Takeown but access denied is again displayed. I have also tried running cmd as administrator, killing the Explorer.exe process and then trying to delete the folder and also to use the cd command (which has worked in older versions of Windows) but it still generates an Access denied message.

    I can move the folder to the root of the USB drive and move it to other folders, but if I try to move it to a different drive I see Access denied. I am also able to rename it.

    I have run chkdsk on the Toshiba drive which reported:

    CHKDSK is verifying security descriptors (stage 3 of 5)...
    909984 file SDs/SIDs processed.

    Cleaning up 1707 unused index entries from index $SII of file 0x9.
    Cleaning up 1707 unused index entries from index $SDH of file 0x9.
    Cleaning up 1707 unused security descriptors.

    and after the free space check:

    CHKDSK discovered free space marked as allocated in the
    master file table (MFT) bitmap.
    Windows has made corrections to the file system.

    976760000 KB total disk space.
    822936148 KB in 618911 files.
    246444 KB in 59457 indexes.
    1016564 KB in use by the system.
    65536 KB occupied by the log file.
    152560844 KB available on disk.

    4096 bytes in each allocation unit.
    244190000 total allocation units on disk.
    38140211 allocation units available on disk.

    Luckily, I will never need access to the contents of this folder but would still like to try and fix this. Does anyone have any other troubleshooting tips I could use to restore access to the folder, please?

    A recent poll suggests that 6 out of 7 dwarfs are not happy