No announcement yet.

Ubuntu installation network issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu installation network issue

    I'm having real problems with what appears to be a simple task.

    I have installed Ubuntu Trusty server on a former Win 2003 server. This is my first foray into the world of Linux. The installation went fine, the system boots as it should. I wish to install a GUI until I am comfortable with using the CLI.

    I have searched and searched and the commands I have seen for this state that

    sudo get-apt install Ubuntu-desktop^

    or variations, should work.

    When I try this a message is displayed

    E: Unable to locate package.

    After more searching I discovered I should try the following first (omitted from every post I saw previously)

    sudo apt-get update

    but it just errors out continuously saying it was temporarily unable to resolve the domain names etc.

    During installation the installer tried to get an address via DHCP but failed, and although I configured the adaptor manually and added the A and PTR records to a Windows DNS server I am unable to ping the address from a Windows 7 client. I also tried installing Putty and connecting from a Win 7 client but it times out.

    So - Win 2003 was working fine on it - could navigate the network etc, but for some reason there appears to be no networking under Ubuntu Trusty.

    I have absolutely no idea how to check or edit the networking components. I've been stymied at the first hurdle. I know the networking configuration is correct - I work with this all day long.

    I've just found a command syntax site which I will now go through, however, if anyone can provide any specific help with this or provide links I will be grateful.

    A recent poll suggests that 6 out of 7 dwarfs are not happy

  • #2
    Does your Ubuntu installation have a NIC driver for your NIC?

    ifconfig seems to ring a bell for an Ubuntu installation.


    • #3
      Thanks a lot for the suggestion.

      This is my problem. I have no idea how to do this.

      My intention was to install the OS, install a GUI and then connect remotely and learn the ropes. During installation I was given a choice over which NIC to use so I may simply re-install and choose the other adaptor and see if that helps. I have found a 'basics' site online and am going through that, but even that assumes the installation and GUI are installed so it still falls short.

      A recent poll suggests that 6 out of 7 dwarfs are not happy


      • #4
        I've just reinstalled and chose the second NIC. It configured it fine - no problems. Am now downloading the GUI.

        That's amazing. We've had this server for many years and have only ever used the one NIC and disabled the other from within Windows. Would the disabling feature have persisted outside Windows? That might explain it if so.
        A recent poll suggests that 6 out of 7 dwarfs are not happy


        • #5
          No. Disabling in Windows will only disable at a software level. Depending on the server would depend on whether you can disable at a BIOS level.


          • #6
            Cheers. Well, that's amazing. That means that adaptor may have been dodgy since we bought the server.
            A recent poll suggests that 6 out of 7 dwarfs are not happy