No announcement yet.

Scsi drive not detected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Scsi drive not detected

    Know this probably isn't the best setup for scsi drives but have a 50 pin adaptec controller that i'm trying to use 80 pin sca-2 drives with. Trying to get one drive detected, using a Scsi sca-2 to 50 pin adapter, everything is hooked up including the power connector on the sca-2 adapter but no drives are detected in the 'adaptec scsi-select' software. The drive is connected to the first connector on the cable after the controller card, the active terminator is on the next connector after the drive, is that correct or should the terminator be on the last connector on the cable? Would the terminator in the wrong place cause the drive to not be detected?

  • #2
    Re: Scsi drive not detected

    Not a real SCSI person but have you tried the terminator on the end of the cable (don't know if it will make a difference or not?
    Are the drives jumpered with the correct IDs? Not a good idea to set any of them to ID7 either.
    Check that none of the pins on the adapter end have been bent in the process.
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Re: Scsi drive not detected

      Tried it at the end of the cable, no difference. Beginning to think the terminator is not really a terminator, need to double check what should be used for termination with this setup. Thanks for the help.