No announcement yet.

'EEP' Won't start without CIRAS.OCX

  • Filter
  • Time
  • Show
Clear All
new posts

  • 'EEP' Won't start without CIRAS.OCX

    Firstly I this is an NT question, so don't laugh or faint we all know someone who used it once upon a time.

    'EEP' is an bespoke application written years ago with no support now.

    But it works on 9X & NT & 2K.....The 'eep' app dials into our server and pulls down data for the end user to view in the applications own forms.

    The program installs without any problems, but when I go to run it I get this message.

    "Runtime error 339, 'CIRAS.OCX' not correctly registered: file is missing or invalid"

    - Mystery is I've never seen this error before,
    - There are no errors or logs in event viewer,
    - the file 'CIRAS.OCX' is present in the /winnt/system32 folder,
    - I've replaced it with a copy from a working PC and no change,
    - I've googled the error & file, all I find are sites selling the .ocx file for $12
    - I've tested the RAS & Dialup network by installing an dialup isp connection.

    If anyone can help with NT related or .OCX errors of this nature I'd be very gratefull.

  • #2
    Re: 'EEP' Won't start without CIRAS.OCX

    Not too worry m8 there are thousands of sites still using NT4 for there systems.

    Have you tried re-registering the OCX file

    Go to Start, run and type

    Regsvr32.exe c:\Winnt\System32\ciras.ocx

    Let us know how you get on


    • #3
      Re: 'EEP' Won't start without CIRAS.OCX

      Well...I have some really funky new error messages from that command lol!

      Entering the command as above gives this first message:

      OleMainThreadWndName: regsvr32.exe - Unable To Locate DLL
      The Dynamic link library RASAPI32.dll could not be found in the specified path.
      (and it lists the complete system PATH as stored in memory)

      Clicking OK to that error flags up a second message:

      Loadlibrary("c:\winnt\system32\cicras.ocx") failed.
      GetLastError returns 0x0000007e

      I've tried reinstalling NT4 SP6a which didn't fix the reg32 message, and still no errors in event viewer either.