Announcement

Collapse
No announcement yet.

SATA to USB Reading as Removable Media

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SATA to USB Reading as Removable Media

    Hello,

    I have an issue with a SATA to USB cable connected to a brand new Seagate HDD being read as a removable media drive instead of a hard drive, meaning I can't format it or allocate it in any way. I have tried it on multiple computers and with multiple drives, and the issue occurs no matter which drive is connected. I do not know the make/brand of the cable, unfortunately, but under device manager it is recognized as "ASMT 2105 USB Device." I have tried uninstalling it from device manager, having device manager search for new hardware, and rebooting my computer. None of these has worked to get it recognized as a hard disk drive.

    I appreciate any help with this issue. Thanks.

  • #2
    The computer is reading it correctly as it will be the controller on the converter that will be telling Windows that it is a removable device.

    Are you able to install the disk in the computer rather than using a converter?

    Comment


    • #3
      Control Panel
      Administrative Tools
      Computer Management
      Disk Management
      and
      Right click the drive and Initiate it.

      If that doesn't work, post a screen shot of the Disk Management so responders can see what is happening there.
      1 1 was a racehorse.
      2 2 was 1 2.
      1 1 1 1 race 1 day,
      2 2 1 1 2

      Comment


      • #4
        Here is a screenshot of the disk management screen. I have also confirmed that it is not an issue with my adapter or cable, as I was able to test them on an additional drive when I got to the office this morning, and it worked with that drive.

        Comment


        • #5
          Update. I plugged the drive directly into the SATA cables on another machine. I was able to initialize and format the drive, but I still have no luck when I connect it to the SATA to USB cable. When I get access to the computer I'm working on, I will try connecting it to the drive cables for the optical drive and see if I can do the clone that way, bypassing the need for this SATA to USB adapter. It's still driving me crazy that the cable won't work, though.

          Comment


          • #6
            Do you have another SATA to USB adapter you can try - since the drive seems to be OK
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              I do not have another adapter, unfortunately. I have a workaround for getting this drive cloned now, but it will not be using the adapter (which is still going to drive me insane).

              Comment


              • #8
                USB to SATA Adapter . I have used this adapter now for some time without any issues, if that helps.

                Comment


                • #9
                  Using the SATA cable connected to my CD drive worked. I cloned the failing drive, swapped in the new one, and the machine is back in action.

                  Comment


                  • #10
                    I just had a realization. The USB to SATA cable I was using came with an enclosure for a 2.5" Form Factor HDD, but the drives (except for the one that worked) were all 3.5" Form Factor. Is there a difference between the cables that might have caused this failure?

                    Comment

                    Working...
                    X