Announcement

Collapse
No announcement yet.

Date format changing to present year.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Date format changing to present year.

    Hello

    I am using Excel 2003 on an XP Pro SP3 machine whose region is set to English UK.

    I have a spreadsheet that I have been using for years and which I have had no problems with until today.

    One of the columns is formatted with a custom date format:

    Format Cells>Custom>mmm-yy

    When I type a date e.g. aug10 it will convert it to Aug-10. That's fine and is how I expect it to work.

    Today, when I type aug10 or aug-10, after pressing <enter> the date is displayed as Aug-11. Anything I now type that has a year on or after 01 (2001) is displayed as 11 (2011).

    However, anything typed in as mmm00 or earlier displays as expected.

    If I re-type mmmdd dates in existing cells they, too, are converted to mmm-11 (except for 00 or earlier).

    If I type aug2010 then the date is displayed correctly: Aug-10

    Anyone know why this is happening, please? I know that I have a solution in that typing the year as four digits instead of two works, but I would like to understand why this behaviour has changed. Is it related to the recent date corrections provided by Windows Update?

    Thanks!

    [Edit]
    False Alarm! The short date format under Regional Settings in Control Panel had changed so that the year was displayed first (US style). Changing this to dd/mm/yy fixed it!
    Last edited by Blood; 13th January 2011, 10:27.
    A recent poll suggests that 6 out of 7 dwarfs are not happy

  • #2
    Re: Date format changing to present year.

    Well done for fixing it, and thanks for posting back
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment

    Working...
    X