Announcement

Collapse
No announcement yet.

using in-place archive for 365 via retention policy and tagging...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • using in-place archive for 365 via retention policy and tagging...

    i have a tendancy to make things longer than they have to be, so i apologize in advance for the long read.. i guess i just like typing.

    so i have a massive tenant with about 2600 users in it. for the most part, things are easy to manage, but i have a couple ballers and shot callers that pay the bills and their inboxes have gotten to be unmanageable and slow for them... i take a look and i see that head honcho numero uno has a mailbox that has grown to 49.15 gigs. other homeslice is right behind him with 47 gigs and change...

    so i figure, let's set the retention policy and tags and enable the in-place archive and let MRM do its thing. i get them to agree on the folders i can mess with and the time frame... we agree that sent & deleted item folders can be set to archive everything older than 1 year, the inbox is now limited to 2 years. all other messages in said folders will be moved to the in-place archive.

    i create the retention tags, sent items moved to archive after 366 days, deleted items to archive after 366 days, inbox items moved to archive after 730. i modify the policy to reflect these tags. it was in a hybrid enviro, so i had some issues enabling the cloud archive, 365 wanted me to use a local mailstore for the archive, used enable-remotearchive.ps1 (link to m$ topic below) to correct the attributes to enable the archive...

    (https://support.microsoft.com/en-us/...fter-a-mailbox)

    after running the script, i was able to turn on the in-place archive. powershell reports that the archive is enabled for the account, value is $true...

    so long story longer, i let it run that first day and see absolutely nothing in the archive details. i figure maybe i have to run the agent or something, idk, so i try to run the managed folder assistant like:
    Start-ManagedFolderAssistant -identity JoeBlow

    and it didnt do anything. buncha red gobbledeygook returned in the shell. i gather that the agent is always running and cant be coaxed to run at will like that, so i quit poking at it and leave it alone. i do an onsite yesterday (in the middle of hurricane michael no less. car salesmen are such premadonnas. pffft.) and go home, then back to the desk this AM. i open the portal and go to the mailboxes, go to the archive and open the details of it... so after 2 days of just letting it do its thing, the archive now holds a whopping total of 9 megs.

    wtaf is going on and how can i get the assistant to move that stuff to the archive. i calculated that it should have moved at least 15-20 gigs of mail from those folders, but its moved virtually nothing.

    TL;DR
    i enabled the archive and its not doing crap.


    any ideas on what im doing wrong? its like its not processing any mail received prior to their move from internal exchange to 365 (happened about a year ago).
    its easier to beg forgiveness than ask permission.
    Give karma where karma is due...

  • #2
    Can the user see the Archive in Outlook, and can they move content to it?
    If they can, then start looking at the policies
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      good call. i will check that. i have been trying to do this all from behind the curtain... the money people always make me nervous and i try to stay away from their stations altogether, but you're right, i should see the archive show up in his instance...

      i will check and report back if i cant make any progress.

      thanks!
      its easier to beg forgiveness than ask permission.
      Give karma where karma is due...

      Comment

      Working...
      X