Announcement

Collapse
No announcement yet.

DHCP requests not being forwarded from dell powerconnect to cisco switch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP requests not being forwarded from dell powerconnect to cisco switch

    Hi all,

    I'm in the middle of testing for a project to segmenting our network, i have installed 2 x Cisco 3750 as a stacked core switch. i have created multiple vlans 201, 202, 203, 204, 205. our DHCP server resides on vlan 205.

    Vlan 201 - Desktops - DHCP - 10.0.12.0/22
    vlan 202 - VOIP - DHCP - 10.10.12.0/22
    vlan 203 - VDI - DHCP - 10.0.16.0/22
    vlan 204 - Management - Static 10.0.0.0/24
    vlan 205 - Servers - static 192.168.1.0 /24

    Or DHCP server resides on 192.168.1.99

    Cisco config.


    Trunk port

    interface GigabitEthernet1/0/47
    description ***Trunk to Dell***
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 204
    switchport trunk allowed vlan 201-205
    switchport mode trunk
    switchport nonegotiate

    Vlan config

    interface vlan 201
    ip address 10.0.12.1 255.255.252.0
    ip-helper 192.168.1.99
    no shut

    interface vlan 202
    ip address 10.10.12.1 255.255.252.0
    ip-helper 192.168.1.99
    no shut

    interface vlan 203
    ip address 10.0.16.1 255.255.252.0
    ip-helper 192.168.1.99
    no shut

    interface vlan 204
    ip address 10.0.0.1 255.255.254.0
    no shut

    interface vlan 205
    ip address 192,168.1.1 255.255.254.0
    no shut

    DHCP Server port

    interface GigabitEthernet1/0/4
    description DHCP Server
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 205
    switchport trunk allowed vlan 201-205
    switchport mode trunk
    switchport nonegotiate


    Dell Switch

    interface eth G3
    description *** Trunk to Cisco ***
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 205
    switchport trunk allowed vlan 201-205
    switchport mode trunk
    switchport nonegotiate


    interface vlan 201
    ip address 10.0.12.2 255.255.252.0
    no shut

    interface vlan 202
    ip address 10.10.12.2 255.255.252.0
    no shut

    interface vlan 203
    ip address 10.0.16.2 255.255.252.0
    no shut

    interface vlan 204
    ip address 10.0.0.2 255.255.254.0
    no shut

    interface vlan 205
    ip address 192,168.1.2 255.255.254.0
    no shut

    int eth e1
    switchport mode access vlan 201

    int eth e2
    switchport mode access vlan 202

    int eth e3
    switchport mode access vlan 203


    The cisco switch can ping the dell and vice versa. when i connect a laptop to the cisco switch and place the ports on vlans 201,202 203 the DHCP server allocates ip addresses to a laptop.

    When i do the same on the Dell powerconnect the DHCP server does not allocate an address it appears that the dell does not forward the request.

    any help much appreciated.

  • #2
    Re: DHCP requests not being forwarded from dell powerconnect to cisco switch

    I dont see any dhcp relay "ip helper address" on the SVI's on the Dell switch. Also there really isnt any need to have those layer 3 interfaces on the dell switch at all as you have them defined on the cisco switch. I would remove them and just let the dell switch the frames over the trunk to the cisco. The dell switch may being trying to route over to the cisco instead of switching the traffic over the trunk. Since dhcp messages are broadcasts then any layer 3 interface will not forward them (Hence the need for the helper address or dhcp relay configuration) Not sure if defining the Layer 3 vlan interfaces on the dell automatically enables routing on them or not.

    Also not sure why your dhcp port on the cisco is setup as a trunk?


    interface GigabitEthernet1/0/4
    description DHCP Server
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 205
    switchport trunk allowed vlan 201-205
    switchport mode trunk
    switchport nonegotiate


    If the only host on that port is the dhcp server then make it a static access port and put it in your server vlan.
    CCNA, CCNA-Security, CCNP
    CCIE Security (In Progress)

    Comment


    • #3
      Re: DHCP requests not being forwarded from dell powerconnect to cisco switch

      Hi agulan,

      The dhcp server is allocating ip on different scopes to different vlans.

      The dell doesn't have an ip helper function as its layer 2


      I couldn't ping the dell switch unroll I added the vlans and ip's to the dell

      Thanks for any help

      Comment


      • #4
        Re: DHCP requests not being forwarded from dell powerconnect to cisco switch

        I havent messed with many dell switches but typically on a cisco switch which is layer 2 only then you would create one layer 3 management interface (for telnet, ssh etc)

        for example:

        int vlan 10
        ip address 10.10.10.10 255.255.255.0


        The rest of the ports would be static access ports. That layer 3 interface is for remote management only. All traffic from hosts on that switch would be sent over the trunk either to another switch, router etc. Multiple layer 3 interfaces on a switch typically tells me that switch is routing as well. Thats why I asked why all the vlans on the dell had associated layer 3 interfaces. On cisco switches that are pure layer 2 it won't let you have multiple layer 3 interfaces at all. If you would try to bring another one up it would put the other one in a down state.

        This may be a difference in how Dell and Cisco switches work.

        Also I noticed the native vlan on the trunks on the cisco and dell are different. This could be your issue

        interface GigabitEthernet1/0/47
        description ***Trunk to Dell***
        switchport trunk encapsulation dot1q
        switchport trunk native vlan 204
        switchport trunk allowed vlan 201-205
        switchport mode trunk
        switchport nonegotiate

        interface eth G3
        description *** Trunk to Cisco ***
        switchport trunk encapsulation dot1q
        switchport trunk native vlan 205
        switchport trunk allowed vlan 201-205
        switchport mode trunk
        switchport nonegotiate
        Last edited by auglan; 24th August 2012, 00:14.
        CCNA, CCNA-Security, CCNP
        CCIE Security (In Progress)

        Comment

        Working...
        X