No announcement yet.

Connectivity between two router ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Connectivity between two router ?

    Hi All,

    We have two branch office interconnected by Dlink routers. - office A Router ip - - office B Router ip -

    In office B users who have internet access are assigned broadband modem ip as default gateway ( of them can able to access the resource in another branch that is however somebody cannot.

    Modem Ip is

    Router ip is as default gateway.

    Routing between two branch is working fine.

    I have ensured firewall is turned off.but still is not working.Solution will be extremely helpful.

  • #2
    Re: Connectivity between two router ?

    The problem is default routing.

    when a client with IP of, say tries to access, it looks, and knows it's not on the same subnet.
    Because it's not on the same subnet, it then looks at the route table.
    The route table doesn't have a specific entry, so the computer passes the data to the default gateway, or gateway of last resort.

    This is all well and good, as long as the computer has a gateway of - that's because knows how to send traffic to

    so, in that instance, the data would go something like this:

    [1.100] ---> [1.1] <---> [2.1] --> [2.100]
    (If that makes sense)

    But you've confused it a little bit when you add the different internet gateway.

    Now, thinks "hmm. is not on my network,. and I don't have a route entry, telling it how to get there. So, I'll pass it to my default gateay,"

    Sounds good in theory.

    Except, doesn't have a route to, and you cannot route these addresses over the internet, so here's what happens.

    [1.100] ---> [1.7] ---> ???????

    there's a couple of options to sort it out.

    the best option would be to manually configure a Static route, on each of your computers, telling them to send all traffic for network via the gateway of
    This would then occur regardless of the default gateway configuration.
    Please do show your appreciation to those who assist you by leaving Rep Point


    • #3
      Re: Connectivity between two router ?

      Hi tech camel,

      Thanks for your nice reply,but i would really appreciate if you could tell me that how to accomplish a static routing in each computer so that i can able to rectify the same.

      Yes,i have same doubt that if machine has as default gateway then how it route the packets to other segment.But some of the machine is working by default without add any static route.

      So please reply with different way of overcome the task as you mentioned.

      Thanks in advance........


      • #4
        Re: Connectivity between two router ?

        I think a bigger question is why some PC's are working and others are not? On a PC that works correctly and one that does not, compare the output of "ipconfig /all" and "route print". This should give you a clue as to how packets are being routed and howto correctly fix this problem.

        Windows "route" command gives some good examples of how to add static routes... I have highlighted the syntax that should answer your question. Modify to meet your requirements. NOTE: Given your network topology, the METRIC and IF arguments are probably NOT needed and can be left out.

            > route PRINT
            > route PRINT -4
            > route PRINT -6
            > route PRINT 157*          .... Only prints those matching 157*
            > route ADD MASK METRIC 3 IF 2
                     destination^      ^mask      ^gateway     metric^    ^
              If IF is not given, it tries to find the best interface for a given
            > route ADD 3ffe::/32 3ffe::1
            > route CHANGE MASK METRIC 2 IF 2
              CHANGE is used to modify gateway and/or metric only.
            > route DELETE
            > route DELETE 3ffe::/32
        Also, from a design perspective, I have never been a fan of adding static routes on PC's. If you change your network topology in the future, then you will have to go back and update each PC <GROAN!>. A better solution might be to investigate adding a static route on your broadband router or the dlink router.