No announcement yet.

puzzled - windows 2008 network error

  • Filter
  • Time
  • Show
Clear All
new posts

  • puzzled - windows 2008 network error

    Hi everyone - I have a peculiar issue. I REALLY AND TRULY hope you can help! (apologies for length, tried to make it specific as possible)

    I have CRM software which is critical to my business ( which runs on SQL Express 2005 and IIS 7 on a Win Server 2008 Std x64 SP2 Hyper-V Guest. The server part of the CRM is installed on this server and the workstations each have an app installed which pulls the data from the server. There is also a web access and a BlackBerry app.

    One day, (yes, really) access to the CRM failed and the only way I could access it was to RDP onto the server and open the application locally. (ie the desktop app and the web connection no longer worked. On redoing my PC and installing Win7 Pro, I tried to reinstall Maximizer finding that I the software could not access the database. (Frustrating because I can access it locally)

    Note, I can ping the server hosting Max's SQL database's IP and the FQDN resolves to the correct IP address.

    I then realised that when inside my network I could access the web version without an problem - Accessing the web version from the outside, though, doesn't work!

    So there are two issues, I think -
    1. Why my app can't correctly access the database on the server. (not the proper forum for this)

    2. (Why I am writing this here) Why I cannot access the web version from the outside and yet I can from the inside.

    **Perhaps they are related

    - I use DYNDNS (with an updater on the server) and port fowarding on my Cisco (RVS4000) router to access the web version of Max from the outside. This has always worked without fail.
    - The DYNDNS updater is working.
    - Pinging the DYNDNS address resolves to my external IP.
    - The correct ports are forwarded on my router

    Curiously -
    - When I set port 80 to forward TCP requests to my .102 server, "The page cannot be found".
    - When I set port 80 to forward TCP requests to my .103 web server (running Apache) it works perfectly.

    It all works perfectly from INSIDE which is why I am baffled.

    Any ideas? Is this a TCP setup error in SQL? Has something in my IIS7 setup been somehow changed? Is it another server issue? There are no errors in Event Viewer on the server which seem related except

    Some other bits of information which may be useful:
    - When the issue happened, my PC was running Vista SP2. Some time after the loss of communication with Max, I found I could no longer ping .102. Miraculously, when I formatted and installed 7, I could again ping .102. Weird I know.

    - Also, on my .102 server, I "sometimes" cannot access external webpages. I say sometimes, because usually I can. (I know because just yesterday, Windows Update downloaded and installed updates on my computer) My DNS server uses opendns for its forwarders.

    - My DC is a Windows 2008 Std machine, which used to be a member server of a SBS 2003 domain. I migrated the DC roles over to Server 2008 and removed the old server from the network. Then removed entries to the old server in DNS.

    Anyhow, as you can see, not sure where to go - hopefully you aren't as confused as I am! I look forward to your wisdom.

    I ran:

    netsh winsock reset catalog
    netsh int ipv4 reset reset.log
    netsh int ipv6 reset reset.log

    ...and restarted my server. I logged in via RDP but could not access the internet. I unchecked IPV6 from the connection properties and my RDP connection was lost. I can no longer ping server.domain.local or Access to my other hyper-v guests and the host are perfect.

    I reconnected via the hyper-v manager, re-checked the IPV6 setting and diasbled/reenabled the network adapter. Connection from my workstation works perfectly again.

    Currently, I can ping and access external web pages but when I diagnose the network connection, it says its an unidentified network and that "You might not be able to access the internet or some network resources".

    HELP! - desperate and willing to try anything!

  • #2
    Re: puzzled - windows 2008 network error

    I can't give you much more than this at the moment, but at least it's a start.

    You can access the web url internally - this tells me that, in essence, the application and web server, are functioning correctly.

    So I suspect that either there's a public dns issue, or port forwarding issue.

    Could you try something for me?
    On the internal computer that you're using to test the application, edit your hosts file C:\windows\system32\drivers\etc\hosts and add a hosts entry:
    make sure you replace "" with whatever you would use to access CRM from the outside.

    then, close and re-open your internet browser, and try and open the url

    The reason I want to do this is to ensure that for some reason IIS isn't suddenly expecting a host header.

    The next thing I need you to do is get outside your network, then try and telnet to port 80 on your public ip address.
    It's very important that you do this from outside your network - take your laptop to an internet cafe or something.
    (If all else fails, and you reply in the next half hour or so, I can do it for you)

    The next thing you need to do for me is wipe your dns resolver cache:
    ipconfig /flushdns

    then, while outside your network, do the name lookup again, and see if it resolves to what you expect the correct ip address to be.

    you could also try
    Please do show your appreciation to those who assist you by leaving Rep Point


    • #3
      Re: puzzled - windows 2008 network error

      Hi Tehcamel, thanks a bunch for replying.

      I have:
      - added my company com (changed url to my url) to my hosts file.
      Unfortunately, still cannot access my external URL.

      - Connected to a client network via VPN and from there, ran telnet on port 80 to my external IP producing:

      "Connecting To my external-domain com...Could not open connection to the host, on port 80: Connect failed"

      - Ran flushdns on the remote computer and tried to access my external-domain com to no avail.

      Checked www downforeveryoneorjustme com and it cannot access.

      An update since last night when I posted:

      I went to bed last night
      (after running: netsh winsock reset catalog,
      netsh int ipv4 reset reset.log and
      netsh int ipv6 reset reset.log

      then restarting the server). Then this morning, I go to access the server only to find that I do not have any IPV4 access. I cannot ping I can rdp "server" and I can ping "server", returning my IPV6 address. When I ping max.kingdom.local, it tries to find but can't. As usual, I cannot ping externally either.

      I can still ping the other servers, the router and wireless access point fine internally. I cannot now, unlike yesterday, ping my .103 server which runs apache on port 88 for testing. This is new new. Hope that helps or at least narrows things down.
      Last edited by animasana; 5th December 2010, 15:09.


      • #4
        Re: puzzled - windows 2008 network error

        OK. Was using a Linksys WRT120N as a wireless access point and switch. The Hyper-V network card connected to the network via this switch. I removed it and plugged it directly into my router (Cisco RVS4000) and then I could connect. Now remote access and internal access work flawlessly. I guess the Linksys was the issue. Don't know why though.

        If you, tehcamel, or another, are still keen, I would LOVE help with my second issue: When installing the workstation part of the CRM, it tries to make a connection to the SQL server - it finds the server and the SQL database when I choose browse, but when I connect it gives the error - "Login failed. Please make sure you entered the correct SQL server name and also use the right credential to connect to the SQL server".

        The crazy thing here is that the SQL instance of maximizer works perfectly on the web version.

        Again, thanks a TONNE for your help, and hoping you can help me suss this second issue out.

        Many thanks.


        • #5
          Re: puzzled - windows 2008 network error

          Hello again, I have found a work around for this error. One option was to remove the MASTER user and recreate it with an SQL authentication, inputting the new password and assigning it db_owner rights. (see here - www dot maximizercrmcentral dot com/forums/p/787/2186 dot aspx) Seeing as I already had the workstation working on 1 machine, it made no sense to remove the SQL user and redo the password, I used the remote machine work around discussed here - www dot maximizercrmcentral dot com/forums/p/505/1318 dot aspx

          Thanks for this great forum. Thanks again tehcamel for your support!!


          • #6
            Re: puzzled - windows 2008 network error

            no probs buddy - glad you sorted it out
            Please do show your appreciation to those who assist you by leaving Rep Point