No announcement yet.

"Reconnect at Login" not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • "Reconnect at Login" not working

    Hi there...

    Here at work, we have a couple of network shares that get mapped via policy, via net use in a batch file. They are Z and X. I have a couple of users who have their Y drive mapped to a couple of random shares they need.

    I'm getting ready to do a big data migration and want this migration to be invisible. I've mapped our graphics share to the Y drive in that batch file. After the migration, I'll edit the batch file to point to the new location, and no one will be the wiser (except the Mac users).

    So, I've gone to these two random users and remapped their old Y drives tho the W drive. "Reconnect at Login" is checked, but not working. Whenever they log in, they have to manually remap that W drive. I'm sure this must have *something* to with the fact that they previously had a Y drive, but can't suss it out.

    Anyone maybe have some insight on this?

    Users are W7-64; Z and X are 2008 R2. One of the users' W is 2008 R2; the other W is 2003.


  • #2
    Have you tried adding the /persistent:yes switch to the batch file? Have you tried running the batch file from a command prompt and watching the output? If you see errors then use echo at the start of each of the commands and place a pause command between them - that way you run each command with a key press, see which command is being executed and also see any associated error messages etc
    A recent poll suggests that 6 out of 7 dwarfs are not happy


    • #3
      Could your logon script be deleting the W drive?

      Why not use Group Policy Preferences? Easier to manage than a script.

      Network Consultant/Engineer
      Baltimore - Washington area and beyond