No announcement yet.

Problems with SpeedTouch Home/Pro - PLEASE HELP !!!!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with SpeedTouch Home/Pro - PLEASE HELP !!!!

    I configured my SpeedTouch Home as a Pro (to enable the routing feature for my local LAN) and it was working fine for several months.

    Unfortunately, we had a power failure (as my wife informed me) and now the modem fails the POST. (The pwr/alarm light goes from flashing red to solid orange - the manual claims this is a POST fail)

    My computer, which was also on at the time of this power failure is ok. (everything, including the modem, is plugged into a $250 surge protector - which is also fine)

    I have tried telnetting the modem but no response, I then tried resetting the modem via the reset button on the rear - but no luck.

    I finally tried the 'ping of life' but also no joy.

    The modem starts up as always, with the power light flashing, then goes to orange - but instead of finally turning green, it just stays orange.

    Can anyone give me some suggestions on possibly how to fix this, or is it now a paperweight ?

    My thanks in anticipation,

  • #2
    Hi There
    I had the same problem 5 days ago, unfortunatlly i have bad news for you. the firmware is probably dead / gone somehow, i tried also all the possible ways to fix it but with no luck, so i went and bought a new ECI ADSL Modem/Router (very cheep) and very good modem.
    My ST Pro is still on my desk as we speek, SORRY


    • #3
      Have you tried resetting it to Factory Defaults using the dip switches on the back of the modem?
      Joined: 23rd December 2003
      Departed: 23rd December 2015


      • #4
        After the upgrade from home to pro the reset button on the back doesnt work anymore!!!


        • #5
          Originally posted by biggles77
          Have you tried resetting it to Factory Defaults using the dip switches on the back of the modem?
          No DIP switches on my modem. (must be a later model)



          • #6
            Home - Pro upgraded - reset button dead

            I had the same problem on 2 such units. The reset button on the "ST Home" model appears to do nothing. All instructions I have seen have all said that when the reset button is pressed, the "Power" LED should change to amber to signify that it is actually resetting back to default settings.

            I tried for days to get these modems to reset (as it appeared that someone had set passwords on them, and I couldn't get into them to configure).

            Eventually, I removed the "mainboard" from one and checked the functionality of the reset switch. The push button switch appears to function correctly (based on the multi-meter readings). I still could not get it to reset to default (and get rid of the password request).

            Keep in mind thet the "mainboard" is likely to be the same for both the Home and Pro, and I started to think about the "default reset" procedure for the "Pro" units. The only apparent difference, is that the Pro models have the set of 4 dip-switches, and the Home models have just the one push-button reset switch. The mainboard in the "Home" model still has the 8 connectors (or rather the solder points for them) on the board for the 4 dip-switches and the 9 connectors for the serial console port.

            By looking at the layout of the dip-switches and the serial console port for the Pro model, you can easily see which "pair" of solder points on the board need to be bridged to perform the "Pro version reset". This procedure did reset the defaults (and maintained the "Pro upgrade").

            This method is not for the "beginners", but it did work on my 2 modems. You will need to dismantle the modem by removing (in my case, at least) 4 "torx" screws that were hiding under the barcodeed serial number sticker under the modem. You don't really need to remove the mainboard from the lower casing, as you can access the connections from above.

            I hope this helps a few people out, as I have seen this issue on a few boards before.

            I think that, as a part of the upgrade process, the reset function is changed to the "Pro" and therefore disables the push button reset option. I don't have acces to another of these modems at the moment, but the next time I have one, I'll upgrade it and test the reset, and then revert to "Home" and see if the reset option is re-instated.

            Good luck.