Announcement

Collapse
No announcement yet.

configuring a laptop for both static and automatic IP address

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • configuring a laptop for both static and automatic IP address

    Hi,
    I like to ask if there is a way to configure a laptop to work with a wirless internet networks that has static IP dareess and an automatic one.
    I have a wirless internet at home which needs a static IP address and once I go to places which aytomaticaly gives the IP address I am forced to reconfigure the network TCP/IP configuration and then do the same way again when I get back home.
    Thank you
    Avremi

  • #2
    Re: configuring a laptop for both static and automatic IP address

    If your using XP you have the option for an alternative IP address on the TCP/IP properties of you network card. Leave the first option as DHCP and then set the required IP addresses on the Alternative tab. The way it works is that if it cant pick up a DHCP lease it will use the alternative IP address instead.

    Michael
    Attached Files
    Michael Armstrong
    www.m80arm.co.uk
    MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    Comment


    • #3
      Re: configuring a laptop for both static and automatic IP address

      Thank you for your answer .
      I have tried it before and have tried it again after reading your answer but for some reason it does not work.
      When I set the primery IP address to DHCP I have no internet capabilities.
      Any ideas what can go wrong?
      Avremi

      Comment


      • #4
        Re: configuring a laptop for both static and automatic IP address

        Does your wireless device at home have DHCP enabled?
        1 1 was a racehorse.
        2 2 was 1 2.
        1 1 1 1 race 1 day,
        2 2 1 1 2

        Comment


        • #5
          Re: configuring a laptop for both static and automatic IP address

          Originally posted by biggles77
          Does your wireless device at home have DHCP enabled?
          No it does not as it requires a static IP

          Comment


          • #6
            Re: configuring a laptop for both static and automatic IP address

            I think the only way to done this job is, " Make a batch file of the following script. Its just a single click away..."
            REMEMBER THAT YOU CHANGE THE NAME OF YOUR WIRELESS LAN CARD FROM "Local Area Connection" to "LAN" This will not confuse u, i hope.

            Open Notepad.exe and write the following command according to your dhcp settings and save it as "DHCP.BAT"

            netsh interface ip set address "LAN" dhcp

            and then

            Open Notepad.exe and write the following command according to your static settings and save it as "STATIC.BAT"

            netsh interface ip set address name="LAN" static 192.168.XXX.100 255.255.255.0 192.168.XXX.1 1
            netsh interface dns set address name="LAN" static 192.168.XXX.2



            Iím sure this will fulfill your requirements. If you are unable to do this, donít hesitate I can write these scripts for you. Just give me your static IP, SUBNET MASK, GATEWAY AND DNS SERVER NAMES. My email address is [email protected]


            Regards;
            Hassan
            Last edited by ailia; 24th January 2006, 00:48.

            Comment


            • #7
              Re: configuring a laptop for both static and automatic IP address

              I have had to this in the past as well. Doing as stated prior about using DHCP primary and then setting a static using alternate does in fact work. The caviot is that you have to let the DHCP time out. So hooking and then going is not going to work. You have to let it connect and try to set IP via DHCP and let it fail. Once it fails, it would either set a generic 192.168.0.1 or set the pre-configured IP address that you stipulate in the configs.

              I believe that you are just not letting it fail out in time.

              Comment

              Working...
              X