No announcement yet.

SpeedTouch Home destroyed ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • SpeedTouch Home destroyed ?

    Hi all,

    During the downgrade process from PRO to HOME version, my modem went totally out of service. Even a hardware reset did not work : when I press the reset button on the rear pannel, I hear a "click" but nothing happens... the leds do not blink nor goes out, which indicates that the modem does not reboot. (I have tried to manually short-circuit the 3 legs of the reset switch inside the modem, but it still does not respond.)

    When I trun the modem on, it boots correctly (the right led turns from red to green) and if connected to an ADSL line, the 2nd led from right, comes to green. But from there it is impossible tu use the modem, as a HOME version nor as a PRO version. I've tried to connect to it via IP address (my PC beeing configured with IP address, sub-net mask) or via IP address like it was before I downgraded it (my PC beeing configured with IP address, sub-net mask).

    Does one of you, or maybe Daniel himself, have a trick to reset the modem to its original configuration ? Have you experienced some equivalent problems and do you think the modem is "salvable" ?

    Many thanks in advance,

    Kind regards,


  • #2

    This is interesting because the same thing just happened to me... well, not quite. I have the Home which i upgraded to a Pro and then upgraded again to a 510 but then i decided to go and install firmware version Gv8baa3.426 Who told me to do that?! The router appeared to be dead; it wasn't replying to a ping so of course i couldn't even telnet into it. Anyways, here's how i fixed it:

    I followed the "Ping-of-Life" instructions in the ST manual which reassigned an IP Address to the router and then i was able to access the web configuration. The only problem is that the web interface looked, errrm, weird lol that's because it was the interface for the firmware 426

    So all i did was telnet into it and switch over to the passive firware which was the 510 version and VOILA! it's working again!

    If you DON'T have the manual for your ST then let me know and i'll type out the instructions for you.



    • #3
      Thanks baj, for your suggestions. I've already tested that, but with no success...

      This morning I had someone from my isp, and he told me to keep on reseting the modem via the reset button, during 30sec or more... I'll try this this afternoon and let you all know !

      Talk to you soo,



      • #4
        There are also 4 DIP switches on the rear of the device that with the correct setting returns the router to factory defaults.
        If the device is "dead" what have you got to loose.
        Joined: 23rd December 2003
        Departed: 23rd December 2015


        • #5
          There is a nice program for "ping to default" and "ping to life": alcaping.exe ( )

          For more solutions to your problem check: