No announcement yet.

ISP connection problem upgrading to Alcatel SpeedTouch Pro

  • Filter
  • Time
  • Show
Clear All
new posts

  • ISP connection problem upgrading to Alcatel SpeedTouch Pro

    My problem is two-fold. I have been trying all morning to manually upgrade my Alcatel SpeedTouch Home dsl modem to the Pro version using the hack found at many location on the net. Some guide are better than others of course, but I have researched this problem with as many as I can find with no success as of yet. My problem is as follows:
    I type in my modem's IP address to manually configure it in my web browser and delete all the settings there under Phone book, PPP, and Bride. I have found no other settings to delete under any other headings. I of course then set up my MXS connection under the Phone Book ( I have tried VCI 35 and 4. I then set up my connection under PPP. After completing the configuration for my DSL connection, I click the apply button. Once I switch the Status of the connection to On, nothing happens. The modem State isn't trying at all. I check my settings again, and for some reason, my ISP password has changed (from my 6 character password to some 8 character password) for no apparent reason. I change it back, click apply, and attempt to connect again. Once again, no response. This password switch happens repeatedly, as a matter of fact, the only way around this problem I have found is to leave the field completely blank. If blank, and I click apply, no password appears.
    So with this extensive information, my questions are:
    1)Why is a random password being generated in the password field that isn't correct?
    2)Why is there no attempt to connect to my ISP at the PPP connection screen?
    Any help is apprecitaed and thanks in advace!

  • #2
    You didn't mentioned so I'll ask.
    Have you checked
    Memento Mori


    • #3
      Thanks for the response. Yes, I have been to that set of instructions and have read them several times. That is actually the site that I realized the status should say "Trying" after I switch the status to On. As I said, this does not happen for whatever reason.


      • #4
        OK, not sure how much this will help...
        1. Disregard the password issue. the 8 asterix (or dots, or whatever) do not mean that the underlying password is 8 characters long. It simply does not disclose the actual password length (why make it easy for intruders by letting them know the correct length?).
        2. I used the instructions on this site ( to do the modifications, worked great. So basically if you follow them to the letter, this should work.
        3. THe modification involves two steps - converting to pro and then configuring to "always on". If you did not do so already, I would suggest splitting the process. Convert to pro, leave configuration as it was (I think you can restore to default configuration via the http interface), make sure everything works and only then proceed with the configuration. As said, if you follow the instructions on this site it should work.