No announcement yet.

MTU size after upgrading to PRO

  • Filter
  • Time
  • Show
Clear All
new posts

  • MTU size after upgrading to PRO

    someone said on a mailing list, after someone else posted about upgrading the Alcatel modem:

    אם מישהו הולך לשנות את המודם שלו לתצורה שמוסברת במסמך, כדאי לדעת
    שצריך לשנות גם את ה- MTU של המחשב ל- 1462. הדיפולט של חלונות 2000 ומעלה
    הוא 1500, וזה לא מתאים. כתבתי על זה גם לבחור שכתב את המסמך, אני מקווה שהוא יפרסם את ההערה.
    הבעיה מתחילה כאשר לפאקטים שיוצאים החוצה יש ביט do not fragment. פאקטים כאלה יתקלו בבעיה
    כאשר הגודל שלהם יהיה 1500 בייט וינסו לצאת דרך שער שמאפשר גודל מקסימלי של 1462 בייט.
    בד"כ אמורה לחזור הודעת ICMP עם הודעת need to fragment (יחד עם הגודל המקסימלי של השער),
    הבעיה היא שהיום כולם משתמשים בפיירוולים, והפורט ש- ICMP משתמש בו חסום בדיפולט (למשל ב- XP,
    וגם במודם עצמו למי שמשתמש בפיירוול הפנימי שלו ולא ביטל אותו).
    במקרה כזה תהיה בעיה ב- upstream, ואף אחד לא יידע למה.

    any comments?

  • #2
    Looks correct. It's easy to find out what the biggest MTU you can use.
    Type: ping [your ISP dns server] -f -l [MTU size]

    Try it with [MTU size] = 1500 and you will get a reply: "Packet needs to be fragmented but DF set." which means it's too high. Reduce it step by step untill you get a standard ping reply.

    I checked my MTU with Alcatel Pro and Bezeq International ISP and got 1472 as the highest.


    • #3

      if the highest MTU size is 1272...does it mean
      my connection isn't good enough?
      i have an Alcatel Pro modem of course, and am connected through Netvision (their DNS is

      how do i change my MTU size?



      • #4
        No, not at all. Some ISPs have equipment that is configured for lower MTU. Ofcourse the higher the MTU the faster is the connection, but I dont know how much effect it has in reality. Much worst is to send oversized packets that need to be fragmented.

        To change the MTU (in windows I assume) you can use a utility called Dr. TCP. Very good one for changing many others hidden TCP/IP settings: . Just change the MaxMTU of the adapter which is connected to the modem and reboot.

        Good luck


        • #5
          thanx buddy!