Announcement

Collapse
No announcement yet.

Failed to create static NAT entry

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to create static NAT entry

    i am trying to open port 6346 , for P2P program Shareaza .
    as discribed at

    http://www.petri.com/enable_alcatel_...rt_mapping.htm

    =>nat
    [nat]=>create
    protocol = tcp
    inside_addr = 10.0.0.5
    [inside_port] = 6346
    outside_addr = 0.0.0.0
    [outside_port] = 6346
    Failed to create static NAT entry.

    where 10.0.0.5 is my defserver

    but i am getting and error "failed to create static nat entry "


    what is wrong ?

  • #2
    You do not need to create a NAT entry.
    defserver means that ALL traffic is routed to the 10.0.0.5 any way.
    So why you need a NAT for?
    I personally would advise to remove the defserver option.
    Memento Mori

    Comment


    • #3
      How do i remove defserver ? Will it improve perfomance of P2P programs ?

      and if i will remove it , should I create NAT entry for ports opening anyway ?

      Could u explain me in few words the meaning of defserver ?

      Comment


      • #4
        Taken from manual:

        Code:
        nat defserver
        Define the default server behind the SpeedTouchTM NAPT device that receives all (unknown) incoming packets.
        In typical LAN configurations one local 'default' server will be responsible for all WAN-LAN mail, http, ftp, ... connectivity.
        This command allows to specify this server. For specific services, use :nat create.
        SYNTAX:
        EXAMPLE INPUT/OUTPUT:
        nat defserver [addr = <ip-address>]
        [addr] [b]The IP address of the server (on the ‘inside‘) that will receive all
        (unknown) incoming packets.[/b]If not specified the current default server is shown.
        OPTIONAL
        =>nat defserver
        Default server is undefined
        =>nat defserver addr=10.0.0.1
        =>nat defserver
        Default server is 10.0.0.1
        =>
        No it will not improve the performance of P2P.
        If you remove the defserver you MUST create a static NAT in order to get proper connection.

        To remove the defserver use the following command:

        Code:
        nat defserver addr=0.0.0.0
        GoodLuck
        Memento Mori

        Comment


        • #5
          Originally posted by STEN
          To remove the defserver use the following command:

          Code:
          nat defserver addr=0.0.0.0
          GoodLuck
          its very strange ,after removing defserver , my modem started to reboot every few minutes and when i returned defsever - started to work as ususal .

          Comment


          • #6
            I would advise you to RESET the modem to default, remove the defserver, redefine the connection to ISP and check again.
            Reset I mean the hardware reset to erase all the current settings.
            Memento Mori

            Comment


            • #7
              ok . i have another question :
              i need to open port 6346 for P2P program shareaza


              I disabled built in firewall , than removed defserver .

              after all , in my MCafee firewall opened port 6346

              so why after all , when i start Shareza i get :
              "Shareaza has detected that you are behaind NAT router or firewall " ?

              If built in firewall is disabled i dont need to create NAT entries for modem , right ?

              Comment


              • #8
                Wrong.
                NAT on the router is working.
                You need to open the desired port.
                Remove the Macafee firewall, you do not need it any more.
                Jusr leave the anti-virus.
                Memento Mori

                Comment


                • #9
                  thank you for your quick response Sten ,
                  now , when i creating nat entry , what shuld i set in :

                  inside address
                  and
                  outside address ?

                  Comment


                  • #10
                    Inside address is your computer where p2p program installed.
                    Outside address should be 0.0.0.0 which means all IP's.
                    Memento Mori

                    Comment


                    • #11
                      in this case inside address is 10.0.0.151 , right ?

                      Ethernet adapter Internet:

                      Connection-specific DNS Suffix . : lan
                      Description . . . . . . . . . . . : 3Com Gigabit LOM (3C940)
                      Physical Address. . . . . . . . . : 00-0C-6E-83-64-B1
                      Dhcp Enabled. . . . . . . . . . . : Yes
                      Autoconfiguration Enabled . . . . : Yes
                      IP Address. . . . . . . . . . . . : 10.0.0.151
                      Subnet Mask . . . . . . . . . . . : 255.255.255.0
                      Default Gateway . . . . . . . . . : 10.0.0.138
                      DHCP Server . . . . . . . . . . . : 10.0.0.138
                      DNS Servers . . . . . . . . . . . : 10.0.0.138

                      Comment


                      • #12
                        Yes.
                        But I would advise you to disable DHCP.
                        IF by any chance your computer will receive a new IP, the NAT rule will not work.
                        Memento Mori

                        Comment


                        • #13
                          thank you very much Sten for your help

                          and if i want to open not single port but range of ports , can i save configuration of modem as text file , then manually edit it and upload back to modem ?

                          it is user.ini file , right ? but how i can create them ?
                          i tried "config save " , but where is the will be craeted ?

                          Comment


                          • #14
                            You should check how to open multiple ports in the articles here on the site.
                            Memento Mori

                            Comment

                            Working...
                            X