Announcement

Collapse
No announcement yet.

Speedtouch 510 connection password recovery

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedtouch 510 connection password recovery

    I have a speedtouch and everythinng is working fine.

    I use two accounts to connect but now I forgot the old password. and the modem is now connected to that account..is there a way to unmask the password?

    Please help, I am really disparte to find out as I called the ISP and they wouldnt reset the password due to the fact that I have the wrong information of spilling of my information

    Thanks

  • #2
    Re: Speedtouch 510 connection password recovery

    Are you trying to reset your ISP account password or the password for the Thomson DSL device?

    Depending on your ISP, you might be able to change the password for your account settings or you might need to call them and confirm personal details over the phone. Don't forget to change the password in your Thomson device if this is what you want to do otherwise you will loose connectivity.

    To change the password for the Thomson device you will need to open the config page via your web browser by supplying the username and password. If you have lost these details, you can rest the device and it will default to whatever it states in the manual. Once logged in, you can make the changes from there.

    Comment


    • #3
      Re: Speedtouch 510 connection password recovery

      Hi there, I am having major traumas trying to remove the forgotten password from my speedtouch 510 router modem. I have tried the factory reset several times but it will not remove the password?? Any help would be much appreciated before I chuck it out of the window!! Many thanks!

      Comment


      • #4
        Re: Speedtouch 510 connection password recovery

        I had a problem resetting the password on one of these unit's when they first came out.

        Make sure you are following the guidelines on page 47 of 50 on the manual and post back.

        Simon

        Comment


        • #5
          Re: Speedtouch 510 connection password recovery

          Yeah, I'm resetting as per the manual and all the other posts I've found. I found one that said to try Administrator as the username and leave the password blank. That worked initially, then the configuration wizard hung and I tried again and the password would not work again! I'm trying to set it to "bridged" so I can use a wireless router....

          Comment


          • #6
            Re: Speedtouch 510 connection password recovery

            er, it sounds like you might be getting locked out due to a configuration error.

            The bridge facility is to join two access points together. If you are using one access point as your DSL gateway in infrastructure mode, this is not needed.

            I assume you are trying to configure this with a network cable and not wirelessly?

            Comment


            • #7
              Re: Speedtouch 510 connection password recovery

              Trying to link with cable yes. I have a netgear wireless router which says my speedtouch needs to be in bridge mode so that it's just a modem and not a router as such. Can't do anything until I can get into the settings though.

              Comment


              • #8
                Re: Speedtouch 510 connection password recovery

                It get stranger. After a few attempts and resets, it will eventually allow access using Administrator as the username but a blank password. When the setup cd is run and the settings selected, the speedtouch will disconnectat the end when the set up is verifying the configuration. Error message "speedtouch is not responding" appears and the LAN light goes out. Then the wole process is tried again with the same outcome! Any ideas before I bin it and get a new one?.........

                Comment


                • #9
                  Re: Speedtouch 510 connection password recovery

                  Has it just has a firmware flash? It might be worth leaving the power out of it overnight for a complete drain down and try again.

                  Sounds like it might have had it.

                  Comment

                  Working...
                  X