Announcement

Collapse
No announcement yet.

Speedtouch 510 not forwarding to server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedtouch 510 not forwarding to server

    Shalom,

    I am using a speedtouch modem 510 (router) I am using pppoa and the speedtouch connects to the internet and the attached computers can connect to various internet stuff.

    However, I need to make my web and mail server open to the world.

    When I type in the ISP assigned IP address I get the speedtouch homepage, whihch is what should happen.

    Then I add a NAPT setting for the web server behind the speedtouch. Then nothing opens when I try to surf to the ISP provided IP. This happens whether I define DEfault server or Napt Entries using port 80 for the web server. When I remove the NAPT entry I can then view the speedtouch page, after rebooting.

    I have physically disconnected the old firewall which is on a different server than the current test.

    Here are some settings that are current.

    Please tell me what needs to be done or give me an exact link, or at least some direction.

    Enjoy,
    Steve
    Product Name
    SpeedTouch 510


    Physical Address
    00-90-D0-E4-11-81


    Software Release
    4.2.3.0.0


    Board Name
    ADNT-Q



    Region
    World


    Provider
    Basic


    Service Name
    Routed PPPoA - DHCP - NAPT


    Service Description
    Routed PPPoA Packet Service configuration using always-on session connectivity.

  • #2
    Re: Speedtouch 510 not forwarding to server

    Sorry, a bit tired so if I have read you post wrong, let me know.
    Do you have a Static or Dynamic address from your ISP?
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

    Comment


    • #3
      Re: Speedtouch 510 not forwarding to server

      SHalom,

      I have a dynamic IP address. I use dyndns for the DNS nameing for the domains.

      IN the NAPT properties settings I use 0.0.0.0 which is supposed to be for ANY external address.

      Thanx A lot,
      Enjoy,
      Steve

      Comment


      • #4
        Re: Speedtouch 510 not forwarding to server

        Shalom and Peace,

        I will be really thrilled when I solve this NAT problem. Can you, kewl dudes of techies please give me some direction. It seems to be my final hurdle.

        My Old LInux server is an unstable one. So I have replaced it with Sarge. However, Sarge (IPtables) for some bizaare reason wont do IP forwarding (NAT) at all and no one knows why. The unstable debian does the forwarding without any issues. The same script wont work.

        The speedtouch does solve the prob that SARGE is obsitinate about. However it wont do it in both directions. I can surf the net from puters behind spedtouch but cant view my site behind speedtouch.

        Thanx,
        A blessing upon whoever helps me and his technological equipment,,
        Steve

        Comment


        • #5
          Re: Speedtouch 510 not forwarding to server

          Never needed to use DYNDNS so I can help you any there, but have you opened Port 80 on the firewall. You mention NAPT and port 80 but if there is a firewall enabled then you won't be able to get in from outside.
          1 1 was a racehorse.
          2 2 was 1 2.
          1 1 1 1 race 1 day,
          2 2 1 1 2

          Comment


          • #6
            Re: Speedtouch 510 not forwarding to server

            Shalom,

            No firewalls are up. they are physically disconnected so as not to cause such interference. I pulled the eth cable out of the LInux box

            I still really need to do this and have no idea how to solve it. So please do help???

            Will I need to back to Bezek to get a new modem router???

            Enjoy,
            Steve

            Comment


            • #7
              Re: Speedtouch 510 not forwarding to server

              I suppose you've been consulting this, right?
              Could you post some screen shots (blotting out the public IP of course). Maybe a port range is mis-configured or something...
              Also, I'd give that "SpeedTouch NAPT Manager" a look. It might simplify the configuration.
              Last edited by JeremyW; 17th October 2006, 02:35.
              Regards,
              Jeremy

              Network Consultant/Engineer
              Baltimore - Washington area and beyond
              www.gma-cpa.com

              Comment


              • #8
                Re: Speedtouch 510 not forwarding to server

                Originally posted by rabbisteve
                Shalom,

                No firewalls are up. they are physically disconnected so as not to cause such interference. I pulled the eth cable out of the LInux box

                I still really need to do this and have no idea how to solve it. So please do help???

                Will I need to back to Bezek to get a new modem router???

                Enjoy,
                Steve
                I was refering to the firewall in the SpeedTouch 510 having it's port 80 opened.
                1 1 was a racehorse.
                2 2 was 1 2.
                1 1 1 1 race 1 day,
                2 2 1 1 2

                Comment


                • #9
                  Re: Speedtouch 510 not forwarding to server

                  Shalom,

                  Thanx for the advice. I thought that it would work. I located instructions for bringing the firewall down from a speedtouch faq:
                  http://www.speedtouchdsl.com/supfaq510.htm#518

                  I did ip config firewalling=off and when reading the config settings after it stated that the firewall was off.

                  This did not help. The situtaion is still the same. when I dont set napt the routers speedtouch settings page comes up. When I add NAPT default server and type in the current IP address that the ISP dynamically assigned me NOTHING happens. then it times out and says server didn't respond. However, the router works well and I can surf the web and sign in to chats like AIM. But anyone outside of the router can not access my web site.

                  Please give me further advice.

                  Thanx a lot,

                  Comment


                  • #10
                    Re: Speedtouch 510 not forwarding to server

                    Originally posted by rabbisteve
                    Please give me further advice.
                    Please post screen shots
                    Have you tried the "SpeedTouch NAPT Manager"?
                    Regards,
                    Jeremy

                    Network Consultant/Engineer
                    Baltimore - Washington area and beyond
                    www.gma-cpa.com

                    Comment


                    • #11
                      Re: Speedtouch 510 not forwarding to server

                      Shalom,

                      enclosed are some screen shots for NAPT stuff an various system settings.

                      I really appreciate the help and am very psyched to solve the problem. So please help me.

                      Enjoy,
                      Steve
                      Attached Files

                      Comment


                      • #12
                        Re: Speedtouch 510 not forwarding to server

                        Shalom ,

                        Here is a little more info. I upgraded to 4.2.7.

                        the same problem still occurs.

                        I ran nmap on the external IP This is how the results look with NAPT set to point to my internal server.

                        $ ./nmap -P0 XXX.XXX.XXX.XXX

                        Starting nmap 3.50 ( http://www.insecure.org/nmap ) at 2006-10-17 22:19 Jerusale
                        m Standard Time
                        Interesting ports on xxx.xxx.xxx.1.dynamic.barak-online.net (XXX.XXX.XXX.XXX ):
                        (The 1654 ports scanned but not shown below are in state: closed)
                        PORT STATE SERVICE
                        21/tcp open ftp
                        23/tcp open telnet
                        80/tcp filtered http
                        1002/tcp filtered windows-icfw
                        1723/tcp open pptp

                        When I leave the napt setting untouched the http says that it is open instead of filtered as above, whichmakes sense since one can open the speetouch setting so it must be open:
                        PORT STATE SERVICE
                        21/tcp open ftp
                        23/tcp open telnet
                        80/tcp open http
                        389/tcp filtered ldap
                        1723/tcp open pptp

                        When I set "default server" to the internal IP the namp results show that almost every port in the univers is "filtered"

                        Thanx for all the assitance from around the world. PLease do help me to totally solve the issue. How can I unfliter the packets? I have already set the firewall to off but it makes no difference.


                        ENjoy,
                        Steve

                        Comment


                        • #13
                          Re: Speedtouch 510 not forwarding to server

                          Could you show a screen shot for when you are actually configuring the static NAPT entry?

                          Can you access your web server internally?

                          Have you tried "SpeedTouch NAPT Manager"?
                          Regards,
                          Jeremy

                          Network Consultant/Engineer
                          Baltimore - Washington area and beyond
                          www.gma-cpa.com

                          Comment


                          • #14
                            Re: Speedtouch 510 not forwarding to server

                            Shalom Jeremy and all,

                            Thanx for the help. I will be really thrilled when I solve this.

                            Originally posted by JeremyW
                            Could you show a screen shot for when you are actually configuring the static NAPT entry?

                            Steve: The third picture is an illustration of setting the "default server". This makes nmap respond that ALL ports are "Filtered". WHen I use the "napt properties" now attached nmap shows that particular port 80 as being filtered instead of open.

                            Can you access your web server internally?

                            Steve: Yes, I can access the server using the internal IP.

                            Have you tried "SpeedTouch NAPT Manager"?
                            I access it through the speedtouch web page at 10.0.0.138. Is this the NAPT manager? When I telnet to the router I can manage NAT but the results seem to be the same.

                            It is REALLY bizaare that the router still "filters" even after I manually turn the firewall off in IP config via telnet.

                            Enjoy,
                            Steve
                            Attached Files
                            Last edited by rabbisteve; 17th October 2006, 23:21. Reason: wrong picture

                            Comment


                            • #15
                              Re: Speedtouch 510 not forwarding to server

                              I was hoping for a screen shot of what it looks like when you click "New" as shown in the attached pic.

                              Click here and go to page 61 for info on the SpeedTouch NAPT Manager
                              Attached Files
                              Regards,
                              Jeremy

                              Network Consultant/Engineer
                              Baltimore - Washington area and beyond
                              www.gma-cpa.com

                              Comment

                              Working...
                              X