No announcement yet.

Urgent! Natting Issue on Pix 501

  • Filter
  • Time
  • Show
Clear All
new posts

  • Urgent! Natting Issue on Pix 501


    I'm having an issue on my Pix 501- ver. 6.3(5) firewall when i issue command sh xlate so don't see anything and i think i must enable natting on this firewall as same as on ASA nat-control.

    But i don't see such command here so can anybody help me to provide such command or give me any hints that how can i pass traffic from inside to outside.

    See below.

    PIX501(config)# sh run
    : Saved
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname PIX501
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    access-list outbound permit tcp any eq www
    pager lines 24
    icmp permit any outside
    icmp permit any inside
    mtu outside 1500
    mtu inside 1500
    ip address outside
    ip address inside
    ip audit info action alarm
    ip audit attack action alarm
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1
    nat (inside) 0 0 0
    nat (inside) 0 0 0
    nat (inside) 0 0 0
    nat (inside) 1 0 0
    access-group outbound in interface inside
    conduit permit icmp any any
    route outside 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    username saeed password xAmbVBkAB7NsAEuT encrypted privilege 15
    terminal width 80
    : end
    Last edited by engineersaeed; 22nd June 2011, 13:05.

  • #2
    Re: Urgent! Natting Issue on Pix 501

    First, I have not used this release of PIX OS in a very long time, so my response is based from memory.

    Given the following nat and global statements

    global (outside) 1
    nat (inside) 0 0 0
    nat (inside) 0 0 0
    nat (inside) 0 0 0
    nat (inside) 1 0 0
    The order in which the nat statements are processed is critical. If I remember correctly, the order is based on the netmask. So a /32 beats a /24 and so on down to the /0 you have on the "nat 1" statement.

    What does all this mean? I'd be willing to bet the network is being NAT excluded (the 2nd nat 0 statement) from inside to outside. Which is not what you want. You want the netblock to be port address translated to (or nat 1 -> global 1).

    I have no idea on why you have entered the first three nat 0 statments, but I would try to remove just the nat 0 statements and then give it a try. NOTE: You may need to clear the translation tables to test after the removal (clear xlate).

    Also, the "outbound" access-list you have attached to the inside interface is only allowing www traffic. Until you get the nat configuration working, I would suggest removing the access-list (via no access-group), then lock it down after you have completed testng.

    Again, I am going from memory here on this release of OS, but another useful nat command is "show nat inside outside".


    • #3
      Re: Urgent! Natting Issue on Pix 501

      Thanks for your reply.

      The issue has been resolved due to the DNS entry on the client end.