No announcement yet.

Only one way working fine - PIX 501 to DFL 210 VPN

  • Filter
  • Time
  • Show
Clear All
new posts

  • Only one way working fine - PIX 501 to DFL 210 VPN

    Hi guys,

    I've got a problem with ipsec vpn between DFL 210 and PIX 501.
    In fact, the ipsec tunnel can be up from PIX network or DFL 210 network, but traffic is available only if PIX network is sending some requests to DFL 210 network. I've been crazy about this....

    I can't understand why traffic is not working from my DFL210 network only if PIX network is the first sending something....

    Please help me

    Here is the PIX configuration :

    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname ligre
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    name rsx_neolith13
    access-list inside_outbound_nat0_acl permit ip rsx_neolith13
    access-list outside_cryptomap_20 permit ip rsx_neolith13
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside
    ip address inside
    ip audit info action alarm
    ip audit attack action alarm
    pdm location inside
    pdm location rsx_neolith13 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0 0
    route outside 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer x.x.x.x
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address x.x.x.x netmask no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    terminal width 80
    : end

    And my network configuration rsx 1 rsx 2

    rsx1 -- (DFL 210 inside) - (DFL 210 outside) -- (Box provider) x.x.x.x ----- Internet ------ y.Y.Y.Y (Box provider) -- (Pix Outside) -(Pix inside) -- rsx2

    When i ping from from rsx2 to rsx1, everything is working fine (ipsec tunnel up, and traffic ok)
    When i ping from rsx1 to rsx2, ipsec tunnel is up, but no traffic at all. Just a ping from rsx2 and traffic become ok
    Last edited by neolith13; 2nd September 2010, 15:40.