Announcement

Collapse
No announcement yet.

Cisco 837 Can Ping from telnet but not network?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 837 Can Ping from telnet but not network?

    Hi Everyone,

    I have a pair of Cisco 837, Im trying to get at least one connected to my dsl.

    I seem to have got it to talk with my isp, and from the router I can ping and traceroute to domain names and ip's.

    It all seems quite happy from there.

    However,

    All ethernets are up, but no machines can seem to get internet acces at all?

    Here is my running config:



    Building configuration...
    Current configuration : 2686 bytes
    !
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname C837(GATEWAY1)
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    enable secret 5 <mysecret>!
    clock timezone London 0
    clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
    no aaa new-model
    ip subnet-zero
    !
    ip dhcp pool dhcpool
    import all
    network 192.168.100.0 255.255.255.0
    dns-server 192.168.100.1 194.168.4.100
    lease infinite
    !
    !
    ip name-server 192.168.4.100
    ip name-server 194.168.8.100
    ip ips po max-events 100
    no ftp-server write-enable
    !
    !
    username doug privilege 15 secret <mysecret>
    !
    !
    no crypto isakmp enable
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Local LAN
    ip address 192.168.100.1 255.255.255.0
    ip access-group any in
    ip access-group any out
    ip nat inside
    ip virtual-reassembly
    no keepalive
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    ip access-group any in
    ip access-group any out
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    no ip address
    ip access-group any in
    ip access-group any out
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    ip access-group any in
    ip access-group any out
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    ip access-group any in
    ip access-group any out
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    ip access-group any in
    ip access-group any out
    duplex auto
    speed auto
    !
    interface Dialer1
    ip address negotiated
    ip access-group any in
    ip access-group any out
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    no ip split-horizon
    dialer pool 1
    no cdp enable
    ppp chap hostname <my adsl user>
    ppp chap password <my adsl password>
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    !
    !
    ip access-list standard any
    remark any
    remark CCP_ACL Category=1
    permit any
    !
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.100.0 0.0.0.255
    no cdp run
    !
    control-plane
    !
    !
    line con 0
    session-timeout 10
    exec-timeout 60 0
    password <mysecret>!
    no modem enable
    stopbits 1
    line aux 0
    session-timeout 10
    access-class 10 in
    no exec
    stopbits 1
    line vty 0 4
    session-timeout 30
    access-class 9 in
    privilege level 15
    password <mysecret>!
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    end

  • #2
    Re: Cisco 837 Can Ping from telnet but not network?

    A quick once over shows:
    No NATing. Seems you have an access-list for NATing but have not applied it to an interface.
    Try something like:
    ip nat inside source list 1 interface Dialer1 overload

    regards

    Comment


    • #3
      Re: Cisco 837 Can Ping from telnet but not network?

      Yep...NAT'ing indeed.

      Sorted that then it hoofed into life (getting the Vodafone suresignal box up and running was a little more frustrating... but thats going too now.)

      Cheers!

      Comment

      Working...
      X