No announcement yet.

VPN remote access user account

  • Filter
  • Time
  • Show
Clear All
new posts

  • VPN remote access user account

    How do you add more user accounts to PIX 501 so that remote users have different user names and passwords? Right now there is one one account that people share.


  • #2
    Re: VPN remote access user account

    Here is the config, right now VPN users login with vpnremote user but I have other accounts added as well. Should all user accounts have the same encrypted privilege level. Again the goal is to have VPN users using different accounts. I am confused on which accounts are for VPN and which are for logging into device.

    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password **** encrypted
    passwd **** encrypted
    hostname pix501
    domain-name ciscopix
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    access-list outside_access_in permit esp any any
    access-list inside_outbound_nat0_acl permit ip any
    access-list outside_cryptomap_dyn_20 permit ip any
    access-list SPLIT_TUNNEL permit ip
    pager lines 24
    logging on
    logging timestamp
    logging trap debugging
    logging history debugging
    logging facility 23
    logging host inside
    icmp deny any outside
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool
    pdm location inside
    pdm location inside
    pdm location inside
    pdm location outside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0 0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa-server AuthInbound protocol tacacs+
    aaa-server AuthInbound max-failed-attempts 3
    aaa-server AuthInbound deadtime 10
    aaa authentication enable console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http inside
    snmp-server host inside
    snmp-server location ****
    snmp-server contact ****
    snmp-server community ****
    snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup vpnremote address-pool vpnpool
    vpngroup vpnremote split-tunnel SPLIT_TUNNEL
    vpngroup vpnremote idle-time 1800
    vpngroup vpnremote password ********
    telnet inside
    telnet inside
    telnet inside
    telnet timeout 5
    ssh outside
    ssh timeout 5
    console timeout 0
    dhcpd address inside
    dhcpd dns
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    username user1 password **** encrypted privilege 2
    username user2 password **** encrypted privilege 15
    username user3 password **** encrypted privilege 15
    terminal width 80


    • #3
      Re: VPN remote access user account

      I figured it out. I added this.

      (config)# group-policy VPNREMOTEGrpPOLICY internal
      (config)# group-policy VPNREMOTEGrpPOLICY attributes
      (config-group-policy)# username user1 password user1 priv 0