Announcement

Collapse
No announcement yet.

Cisco 877W -VPN

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco 877W -VPN

    Could anyone please assist??


    I am trying to configure a remote access VPN in a cisco 877w router.I did the config as below but my internet is not working at all.Any help me be greatly appreciated...

    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname RegniGroup
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$TaxE$vZlURovuPAznAGRZOEmO31
    enable password vision2009
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authentication login Regni local
    aaa authentication login sdm_vpn_xauth_ml_1 local
    aaa authorization exec default local
    aaa authorization network Regni local
    aaa authorization network sdm_vpn_group_ml_1 local
    !
    !
    aaa session-id common
    !
    crypto pki trustpoint TP-self-signed-2105299344
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2105299344
    revocation-check none
    rsakeypair TP-self-signed-2105299344
    !
    !
    crypto pki certificate chain TP-self-signed-2105299344
    certificate self-signed 01 nvram:IOS-Self-Sig#2.cer
    dot11 syslog
    ip cef
    !
    !
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    !
    !
    username regni privilege 15 password 0 vision2009
    !
    !
    crypto isakmp policy 1
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 480
    !
    crypto isakmp client configuration group Regni
    key vision2009
    dns 10.1.1.2 61.9.133.193
    domain Envisionit.com
    crypto isakmp profile sdm-ike-profile-1
    match identity group Regni
    client authentication list sdm_vpn_xauth_ml_1
    isakmp authorization list sdm_vpn_group_ml_1
    client configuration address respond
    virtual-template 1
    !
    !
    crypto ipsec transform-set Regnivpn esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    !
    crypto ipsec profile SDM_Profile1
    set transform-set ESP-3DES-SHA
    set isakmp-profile sdm-ike-profile-1
    !
    !
    crypto ipsec client ezvpn samarinda
    connect auto
    group samarinda key vision2009
    mode network-extension
    peer 218.214.130.124
    xauth userid mode interactive
    !
    !
    crypto dynamic-map Regnimap 1
    set transform-set Regnivpn
    reverse-route
    !
    !
    crypto map Regnimap isakmp authorization list Regni
    crypto map Regnimap client configuration address respond
    !
    crypto map static-map 1 ipsec-isakmp dynamic Regnimap
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    crypto ipsec client ezvpn samarinda
    !
    interface ATM0.1 point-to-point
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    crypto map static-map
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface Virtual-Template1 type tunnel
    ip unnumbered Dialer0
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile SDM_Profile1
    !
    interface Dot11Radio0
    no ip address
    shutdown
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    54.0
    station-role root
    !
    interface Vlan1
    ip address 10.1.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1412
    !
    interface Dialer0
    ip address dhcp
    ip mtu 1452
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 xq123445
    ppp pap sent-username [email protected] password 0 xq123445
    !
    ip local pool Regnipool 192.168.1.1 192.168.1.126
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.1.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    snmp-server community public RO
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    privilege level 15
    password admin
    transport input ssh
    !
    scheduler max-task-time 5000
    end

    Thanks
    Steve
Working...
X