Announcement

Collapse
No announcement yet.

ASDM wont work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASDM wont work

    I have a ASA 5510, i reset it to default factory settings. I cant connect to ASDM. how do i enable ASDM on my managment port. What commands do I need to type to enable it. Thanks
    My running config is the following.

    : Saved
    :
    ASA Version 8.0(3)6
    !
    hostname ciscoasa
    enable password xxxxxxxxxxxxxxxx encrypted
    passwd xxxxxxxxxxxxxxxx encrypted
    names
    !
    interface Ethernet0/0
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface Ethernet0/1
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface Management0/0
    nameif mgmt
    security-level 0
    ip address 192.168.1.1 255.255.255.0
    !
    boot config disk0:/configtest
    ftp mode passive
    pager lines 24
    mtu mgmt 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-603.bin
    asdm history enable
    arp timeout 14400
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access mgmt
    dhcpd address 192.168.1.2-192.168.1.50 mgmt
    !
    threat-detection basic-threat
    threat-detection statistics access-list
    username adnan nopassword
    !
    !
    prompt hostname context
    Cryptochecksum:f4bfcb8f5a2a9c6a7d25da4ed189d3b3
    : end

  • #2
    Re: ASDM wont work

    I think you should do the following:

    1. enable http server
    2. specifiy the IP address to allow access to your ASA through HTTP.

    something like this:
    http server enable
    http ip-address-of-host netmask interface-name

    try this syntax from global config mode:

    ciscoasa(config)#http server enable
    ciscoasa(config)#http 192.168.1.1 255.255.255.0 mgmt

    we have console port on our ASA, no management interface to check if it will works with you, but hope it will give you an insight.

    Comment


    • #3
      Re: ASDM wont work

      This might help:
      http://www.netcraftsmen.net/welcher/papers/asdm01.html
      Marcel
      Technical Consultant
      Netherlands
      http://www.phetios.com
      http://blog.nessus.nl

      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
      "No matter how secure, there is always the human factor."

      "Enjoy life today, tomorrow may never come."
      "If you're going through hell, keep going. ~Winston Churchill"

      Comment


      • #4
        Re: ASDM wont work

        sorry I have made a mistake in the IP address, it should be like 192.168.1.0 or simply the ip address of the connected host like 192.168.1.6

        ciscoasa(config)#http server enable
        ciscoasa(config)#http 192.168.1.0 255.255.255.0 mgmt

        or maybe:

        ciscoasa(config)#http server enable
        ciscoasa(config)#http 192.168.1.3 255.255.255.0 mgmt

        The link provided by Dumber would be more helpful to check it

        Comment


        • #5
          Re: ASDM wont work

          Originally posted by sys-halt View Post
          I think you should do the following:

          1. enable http server
          2. specifiy the IP address to allow access to your ASA through HTTP.

          something like this:
          http server enable
          http ip-address-of-host netmask interface-name

          try this syntax from global config mode:

          ciscoasa(config)#http server enable
          ciscoasa(config)#http 192.168.1.1 255.255.255.0 mgmt

          we have console port on our ASA, no management interface to check if it will works with you, but hope it will give you an insight.

          Thank you, it realy worked. This is a great forum. You people are great.
          Once again, thx

          Comment

          Working...
          X