Announcement

Collapse
No announcement yet.

ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

    This is the first site-to-site VPN that I've set up and I'm not having any luck getting the tunnel to connect. I'm

    trying to setup a VPN between a PIX 501 (version 6.3(3)) and an ASA 5500 (version 7.0(7)).

    Originally, there were multiple remote sites with 501s connecting back to the main site's 501. The main site's 501 is

    being replaced by the ASA so basicallly, all I did was change the IP the remote was using to point to the new IP of

    the host ASA and then setup the VPN config on the ASA using the VPN Wizard. To me it all looks like it should work.

    I've attached a doc with both configs (Outside IPs changed from actual but you should still be able to figure it out).

    ASA Outside IP 192.168.55.56/27
    PIX Outside IP 192.168.5.250/29

    --- ASA Config ---

    ASA Version 7.0(7)
    !
    hostname somehost
    domain-name somedomain.com
    enable password **************** encrypted
    names
    dns-guard
    !
    interface Ethernet0/0
    nameif outside
    security-level 0
    ip address 192.168.55.56 255.255.255.224
    !
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 10.0.0.2 255.255.255.0
    !
    interface Ethernet0/2
    nameif outside-in
    security-level 100
    ip address 10.1.0.1 255.255.255.0
    !
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    !
    passwd **************** encrypted
    ftp mode passive
    same-security-traffic permit inter-interface
    access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.255.255.0 10.0.
    8.0 255.255.255.0
    access-list outside_cryptomap_20 extended permit ip 10.0.0.0 255.255.255.0 10.0.
    8.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    mtu outside-in 1500
    mtu management 1500
    asdm image disk0:/asdm-507.bin
    no asdm history enable
    arp timeout 14400
    nat (inside) 0 access-list inside_nat0_outbound
    route outside 0.0.0.0 0.0.0.0 192.168.55.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
    timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    http server enable
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer 192.168.5.250
    crypto map outside_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    isakmp policy 65535 authentication pre-share
    isakmp policy 65535 encryption 3des
    isakmp policy 65535 hash sha
    isakmp policy 65535 group 2
    isakmp policy 65535 lifetime 86400
    tunnel-group 192.168.5.250 type ipsec-l2l
    tunnel-group 192.168.5.250 ipsec-attributes
    pre-shared-key *
    peer-id-validate nocheck
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    !
    class-map inspection_default
    class-map inspection_default
    !
    !
    policy-map global_policy
    class inspection_default
    inspect dns maximum-length 512
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect netbios
    inspect rsh
    inspect rtsp
    inspect skinny
    inspect esmtp
    inspect sqlnet
    inspect sunrpc
    inspect tftp
    inspect sip
    inspect xdmcp
    !
    service-policy global_policy global

    --- Pix Config ---

    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password ****************** encrypted
    passwd ************** encrypted
    hostname Remote-Pix
    domain-name somedomain.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 172
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list Host permit ip 10.0.8.0 255.255.255.0 10.0.8.0 255.255.255.0
    access-list Host permit ip 10.0.0.0 255.255.255.0 10.0.0.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.5.250 255.255.255.248
    ip address inside 10.0.8.2 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list Host
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 192.168.5.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http 10.0.8.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto map partner-map 20 ipsec-isakmp
    crypto map partner-map 20 match address Host
    crypto map partner-map 20 set peer 192.168.55.56
    crypto map partner-map 20 set transform-set ESP-3DES-SHA
    crypto map partner-map interface outside
    isakmp enable outside
    isakmp key ******** address 192.168.55.56 netmask 255.255.255.255
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash sha
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet timeout 5
    ssh 63.227.213.104 255.255.255.248 outside
    ssh timeout 5
    console timeout 0
    dhcpd address 10.0.8.200-10.0.8.250 inside
    dhcpd dns 4.2.2.1 4.2.2.2
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd enable inside
    terminal width 80

    -------------------
    I really don't know what to do next...any suggestions? Thanks!

  • #2
    Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

    Does it not come up at all or do you just think that because traffic doesn't pass?

    If you type:
    show crypto isa sa
    on the pix what do you see?

    Also try the debug commands.

    debug crypto isa
    debug crypto ips
    debug crypto eng

    I can't see anything immediately wrong but will have another look in a bit.
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

      I have had problems in the past with my ASA connecting to a PIX if the Perfect Forwarding Secrecy was enabled on the connection.
      MCITP:SA, MCSA 2003, MCP, CCNA, A+, Net+, Security+

      Comment


      • #4
        Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

        may need to clear the cryptos and then generate some traffic.
        What do I know, I am only 26.

        Comment


        • #5
          Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

          Got this fixed. I added "nat (inside) 0 access-list CRYPTO_ACL" to the PIX. Sorry for the delayed reply.

          Comment


          • #6
            Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

            Originally posted by jjj08 View Post
            access-list Host permit ip 10.0.8.0 255.255.255.0 10.0.8.0 255.255.255.0
            access-list Host permit ip 10.0.0.0 255.255.255.0 10.0.0.0 255.255.255.0

            nat (inside) 0 access-list Host
            Thanks for letting us know. I am a little confused as you don't have a "CRYPTO_ACL" access list and your nat 0 used the "Host" access list therefore doing what you stated already. Anyway, at least it is working now
            cheers
            Andy

            Please read this before you post:


            Quis custodiet ipsos custodes?

            Comment


            • #7
              Re: ASA 5500 and Pix 501 Site-to-site VPN tunnel won't come up

              Thanks to Boon, I was having a similiar problem and the error message reported on ASA was misleading. during phase 1 the error message said no acceptable SA's found when I went in and turned off perfect forwarding secrecy for that tunnel it all worked great. Thank you again.

              Comment

              Working...
              X