No announcement yet.

cisco ASA 5505 rommon mode

  • Filter
  • Time
  • Show
Clear All
new posts

  • cisco ASA 5505 rommon mode

    have an ASA 5505 unlimited license. When I booted it this morning it started in ROMMON mode and it looks like it lost its image file. please help me restore it back to normal mode.

    Also please give me the basic configuration to run internet.

  • #2
    Re: cisco ASA 5505 rommon mode

    Do you have anything in flash?
    I've never tried but you could see if you can upload an image using tftp

    Please read this before you post:

    Quis custodiet ipsos custodes?


    • #3
      Re: cisco ASA 5505 rommon mode

      During an IOS update on a new unit something happened during the transfer. Now the firewall will only boot to ROMMON mode. This in and of itself would not be that big of an issue, except the kind folks at Cisco decided not to include an xmodem command for this device. I have tried to use tftp to upload another copy of the image file, but when I attempt to do this, it asks for the following:

      ADDRESS = IP Address I am assigning to the firewall, no problem
      SERVER = The IP Address of the tftp server, too easy
      IMAGE = ???

      I have tried every idea I could come up with for what it needs in this field, but it will not fly. My assumption is that it wants either the image file name or the path on the tftp server, but there is no indication of what the syntax should be. Does anyone have a suggestion?


      • #4
        Re: cisco ASA 5505 rommon mode

        I am able to ping the tftp server from the firewall, and I am able to ping the firewall from the tftp server.


        • #5
          Re: cisco ASA 5505 rommon mode

          Also, in the documentation it states that the USB port on the device can be used to load config and IOS files, but they do not appear to be enabled by default. Does anyone know if there is a way to do this from rommon? I doubt that it can be done without the driver files located in the IOS.bin.