Announcement

Collapse
No announcement yet.

What routing protocol should I be using to switch links between campuses

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What routing protocol should I be using to switch links between campuses

    We have two campuses connected with 2 wireless links, primary at 200 Mb/s and secondary/failover at 100 Mb/s. Layer 3 switches used on each campus are 3750.

    We are using eigrp to manage the failover but have noticed that when it fails over it doesn't failback when the faster link returns. I'm therefore wondering if eigrp is the right choice and if so is there something amiss in my configuration?

    router eigrp 1
    maximum-paths 1
    network 10.0.0.0
    passive-interface default
    no passive-interface Vlan900
    no passive-interface Vlan901
    no passive-interface GigabitEthernet1/0/24
    no passive-interface GigabitEthernet2/0/24
    eigrp stub connected summary

    interface GigabitEthernet1/0/24
    description TasmaNet link to Penquite Campus
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 901
    switchport trunk allowed vlan 901
    switchport mode trunk
    bandwidth 200000
    logging event trunk-status
    logging event spanning-tree
    flowcontrol receive on
    spanning-tree portfast disable
    spanning-tree bpdufilter enable
    spanning-tree bpduguard disable

    interface GigabitEthernet2/0/24
    description WipAir link to Penquite Campus
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 900
    switchport trunk allowed vlan 900
    switchport mode trunk
    bandwidth 100000
    logging event trunk-status
    flowcontrol receive on
    spanning-tree portfast disable
    spanning-tree bpdufilter enable
    spanning-tree bpduguard disable

    interface Vlan900
    description Intercampus VLAN - WipAir
    ip address 10.252.90.253 255.255.255.0
    !
    interface Vlan901
    description Intercampus VLAN - TasmaNet
    ip address 10.252.91.253 255.255.255.0
    !

  • #2
    Re: What routing protocol should I be using to switch links between campuses

    Could you pls supply A) a diagram of the relevant parts of your network with the IP ranges and B) a dump of 'sh ip route' for each switch which has ip routing turned on? I use 3750 switches exclusively throughout my network, and haven't run into this before. I don't think it's EIGRP as a more correct or less correct protocol, I think it's your config. But since I haven't seen it running like this, I'd like some more info to work it out.

    Your trunk ports are configured to only allow a particular vlan on each, but since both links go to the same destination, what vlan(s) are actually being used at the other end? If your trunks don't allow that traffic, how do your clients communicate? The figure and routing tables should make this clearer.
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Re: What routing protocol should I be using to switch links between campuses

      Try adding a delay statement to the less preferred SVI (not the trunks). In your case vlan 900 (at both ends)

      Example:

      interface Vlan900
      description Intercampus VLAN - WipAir
      ip address 10.252.90.253 255.255.255.0
      delay 10
      By doing so, EIGRP will recalculate the administrative distance and make vlan 900 the less preferred path. So failover and failback should work as expected.

      --Steve

      Comment

      Working...
      X