Announcement

Collapse
No announcement yet.

hsrp on sub-interface issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • hsrp on sub-interface issue

    Router1

    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.2 255.255.255.0
    standby version 2
    standby 10 ip 192.168.10.1
    standby 10 priority 120
    standby 10 preempt
    !


    ROUTER-2

    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.3 255.255.255.0
    standby version 2
    standby 10 ip 192.168.10.1
    standby 10 preempt
    !




    ROUTER1

    Router#sh standby
    GigabitEthernet0/0.10 - Group 10 (version 2)
    State is Active
    9 state changes, last state change 00:08:45
    Virtual IP address is 192.168.10.1
    Active virtual MAC address is 0000.0C9F.0000
    Local virtual MAC address is 0000.0C9F.F00A (v2 default)
    Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.122 secs
    Preemption disabled
    Active router is local
    Standby router is unknown
    Priority 120 (configured 120)
    Group name is hsrp--10 (default)



    ROUTER-2

    Router#sh stand
    GigabitEthernet0/0.10 - Group 10 (version 2)
    State is Active
    20 state changes, last state change 00:41:37
    Virtual IP address is 192.168.10.1
    Active virtual MAC address is 0000.0C9F.0000
    Local virtual MAC address is 0000.0C9F.F00A (v2 default)
    Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.958 secs
    Preemption disabled
    Active router is local
    Standby router is unknown
    Priority 100 (default 100)
    Group name is hsrp--10 (default)


    Switch ports are in vlan10

    interface FastEthernet0/1
    switchport access vlan 10
    switchport mode access
    spanning-tree portfast

    interface FastEthernet0/2
    switchport access vlan 10
    switchport mode access
    spanning-tree portfast

    interface FastEthernet0/3
    switchport access vlan 10
    switchport mode access
    spanning-tree portfast


    why my both routers in Active. Have I missed something in config.

    routers are c2911
    switch is sg-300

  • #2
    Re: hsrp on sub-interface issue

    Which switchport is Gi0/0 on router1 connected to, and what is the configuration of that switchport? (It must be a trunk port with a native VLAN other than 10.)

    Comment


    • #3
      Re: hsrp on sub-interface issue

      thanks,

      It worked for standby group 10, but I have to more groups 20 & 30. These group status is active/active in both routers. Connected to the same switch, now all switch ports are configured to mode trunk.

      Router1

      interface GigabitEthernet0/0
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/0.10
      encapsulation dot1Q 10
      ip address 192.168.10.2 255.255.255.0
      standby version 2
      standby 10 ip 192.168.10.1
      standby 10 priority 120
      standby 10 preempt
      !

      interface GigabitEthernet0/1
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/1.20
      encapsulation dot1Q 20
      ip address 192.168.20.2 255.255.255.0
      standby version 2
      standby 10 ip 192.168.20.1
      standby 10 priority 120
      standby 10 preempt
      !

      interface GigabitEthernet0/2
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/2.30
      encapsulation dot1Q 30
      ip address 192.168.30.2 255.255.255.0
      standby version 2
      standby 10 ip 192.168.30.1
      standby 10 priority 120
      standby 10 preempt
      !


      Router2

      interface GigabitEthernet0/0
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/0.10
      encapsulation dot1Q 10
      ip address 192.168.10.3 255.255.255.0
      standby version 2
      standby 10 ip 192.168.10.1
      standby 10 preempt
      !

      interface GigabitEthernet0/1
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/1.20
      encapsulation dot1Q 20
      ip address 192.168.20.3 255.255.255.0
      standby version 2
      standby 10 ip 192.168.20.1
      standby 10 preempt
      !

      interface GigabitEthernet0/2
      no ip address
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/2.30
      encapsulation dot1Q 30
      ip address 192.168.30.3 255.255.255.0
      standby version 2
      standby 10 ip 192.168.30.1
      standby 10 preempt
      !

      Router 1

      Router#sh stand
      GigabitEthernet0/0.10 - Group 10 (version 2)
      State is Active
      12 state changes, last state change 00:31:43
      Virtual IP address is 192.168.10.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F00A (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 0.96 secs
      Preemption enabled
      Active router is local
      Standby router is 192.168.10.3, priority 120 (expires in 7 sec)
      Priority 120 (configured 120)
      Group name is hsrp--10 (default)
      GigabitEthernet0/1.20 - Group 20 (version 2)
      State is Active
      18 state changes, last state change 00:27:34
      Virtual IP address is 192.168.20.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F014 (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 1.868 secs
      Preemption enabled
      Active router is local
      Standby router is unknown
      Priority 120 (configured 120)
      Group name is hsrp--20 (default)
      GigabitEthernet0/2.30 - Group 30 (version 2)
      State is Active
      18 state changes, last state change 00:27:34
      Virtual IP address is 192.168.30.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F0 (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 1.868 secs
      Preemption enabled
      Active router is local
      Standby router is unknown
      Priority 120 (configured 120)
      Group name is hsrp--30 (default)



      Router 2

      Router 1

      Router#sh stand
      GigabitEthernet0/0.1 - Group 10 (version 2)
      State is Standby
      21 state changes, last state change 00:31:51
      Virtual IP address is 192.168.10.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F00A (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 0.254 secs
      Preemption disabled
      Active router is 192.168.10.2, priority 100 (expires in 7 sec)
      MAC address is 0000.0C9F.0000
      Standby router is local
      Priority 100 (default 100)
      Group name is hsrp--10 (default)
      GigabitEthernet0/1.20 - Group 20 (version 2)
      State is Active
      18 state changes, last state change 00:27:34
      Virtual IP address is 192.168.20.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F014 (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 1.868 secs
      Preemption enabled
      Active router is local
      Standby router is unknown
      Priority 120 (configured 120)
      Group name is hsrp--20 (default)
      GigabitEthernet0/2.30 - Group 30 (version 2)
      State is Active
      18 state changes, last state change 00:27:34
      Virtual IP address is 192.168.30.1
      Active virtual MAC address is 0000.0C9F.0000
      Local virtual MAC address is 0000.0C9F.F0 (v2 default)
      Hello time 3 sec, hold time 10 sec
      Next hello sent in 1.868 secs
      Preemption enabled
      Active router is local
      Standby router is unknown
      Priority 120 (configured 120)
      Group name is hsrp--30 (default)
      Last edited by kris_amar; 7th September 2014, 03:44.

      Comment

      Working...
      X