Announcement

Collapse
No announcement yet.

Basic Router - switch issue but weird

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Basic Router - switch issue but weird

    3 devices: Laptop, Switch(2960), Router ( Cisco 2610XM - MPC860P. C2600-IPBASEK9-M) Version 12.4(15) T14. Release Software (fc2) 1x S0/0; 1xFe 0/0

    Subnet: 10.10.10.0 255.255.255.0

    Switch's management Vlan is 10.10.10.2.
    Laptop's IP adress is 10.10.10.3
    Router's Fe 0/0 is 10.10.10.1

    Laptop and Router are both plugged into the switch

    Issue: Laptop and Switch can't ping Router; Laptop and Switch can ping each other. Router can ping itself.

    *****I recently upgraded the Image on the Router to one with Cryptographic features. I can post config if needed but I didn't in this instance because it's a setup that should just work, right?

  • #2
    Re: Basic Router - switch issue but weird

    Check the status of the link between the switch and the router. If all 3 devices are in the same VLAN (and are, according to your addresses), as long as the links are up, you shouldn't have any issue.

    On the router, do a 'sh int fe 0/0' command. That will give you a status screen with information about the status of the interface. There are 2 'up' or 'down' states, one for the physical link, one for the protocol on that link. If the physical part is up, the lights will be on at port where the cable is plugged in, but if the protocol is in a 'down' state, no traffic passes.

    Ideally, the switch port where your router's link cable is plugged in should be in a trunk state, not access. Say the port is FA0/7, issue these commands:
    conf t
    int fa0/7
    shut
    switchport trunk encaps dot1q
    switchport mode trunk
    no shut

    Try that and let us know. If it works, don't forget to save the config after you've made the changes (copy run start).
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Re: Basic Router - switch issue but weird

      do what RicklesP say

      Comment


      • #4
        Re: Basic Router - switch issue but weird

        Thanks RicklesP,
        The switch is a 2960G series model and the encapsulation command isn't present as you describe, my guess is that it uses dot1q as its default encapsulation hence there is no need to set it on an interface.

        However, after converting the port where the Router is plugged into to trunk mode, I still can't ping beyond the Router interface!!

        Comment


        • #5
          Re: Basic Router - switch issue but weird

          also, the line statuses on the router are UP on the Router interface F0/0.

          Comment


          • #6
            Re: Basic Router - switch issue but weird

            When you say '...beyond the router interface...', do you mean from either the PC or the switch to some point beyond the router, or to the router? It makes a difference. Your original post read as to the router was failing.

            Just changing the IOS on the router to one with more Cryptography capabilities shouldn't break a link status, unless a link requires authentication. So unless you've entered settings to that effect, I'd say no.

            Pls post the following info: the results of 'sh run' for the trunk interface on the switch, and the results of 'sh int <port>' of that same interface (i.e. sh int fa0/1). Then do both of the same for the router port fa0/0.
            *RicklesP*
            MSCA (2003/XP), Security+, CCNA

            ** Remember: credit where credit is due, and reputation points as appropriate **

            Comment


            • #7
              Re: Basic Router - switch issue but weird

              I've separated them into different sections, for the switch and for the router. What I meant by not being able to ping beyond the router is that, the Router interface is 10.10.10.1, I can ping this IP address from the Router. I can't ping the same IP address (10.10.10.1) from the Switch which has IP address 10.10.10.2.

              The Router is connected to F0/5 on the switch hence the output from that interface.

              The Laptop (IP address 10.10.10.3) which I use is plugged into Fa0/1, , it can ping the switch on 10.10.10.2! I'm absolutely puzzled

              The Router can ping it's own interface and that's about it.



              __________________________________________________ ___________________________________
              Switch#show interfaces trunk

              Port Mode Encapsulation Status Native vlan
              Fa0/5 on 802.1q trunking 1

              Port Vlans allowed on trunk
              Fa0/5 1-4094

              Port Vlans allowed and active in management domain
              Fa0/5 1-2

              Port Vlans in spanning tree forwarding state and not pruned
              Fa0/5 1-2

              Show vlan:
              1 default active Gi0/1, Gi0/2
              2 VLAN0002 active Fa0/1, Fa0/2, Fa0/3, Fa0/4
              Fa0/6, Fa0/7, Fa0/8, Fa0/9
              Fa0/10, Fa0/11, Fa0/12, Fa0/13
              Fa0/14, Fa0/15, Fa0/16, Fa0/17
              Fa0/18, Fa0/19, Fa0/20, Fa0/21
              Fa0/22, Fa0/23, Fa0/24, Fa0/25
              Fa0/26, Fa0/27, Fa0/28, Fa0/29
              Fa0/30, Fa0/31, Fa0/32, Fa0/33
              Fa0/34, Fa0/35, Fa0/36, Fa0/37
              Fa0/38, Fa0/39, Fa0/40, Fa0/41
              Fa0/42, Fa0/43, Fa0/44, Fa0/45
              Fa0/46, Fa0/47, Fa0/48
              1002 fddi-default act/unsup
              1003 token-ring-default act/unsup
              1004 fddinet-default act/unsup
              1005 trnet-default act/unsup
              __________________________________________________ ______________________________________

              Show interface fastethernet 0/5:

              FastEthernet0/5 is up, line protocol is up (connected)
              Hardware is Fast Ethernet, address is 001a.6c37.f085 (bia 001a.6c37.f085)
              MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
              reliability 255/255, txload 1/255, rxload 1/255
              Encapsulation ARPA, loopback not set
              Keepalive set (10 sec)
              Full-duplex, 100Mb/s, media type is 10/100BaseTX
              input flow-control is off, output flow-control is unsupported
              ARP type: ARPA, ARP Timeout 04:00:00
              Last input never, output 00:00:00, output hang never
              Last clearing of "show interface" counters never
              Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
              Queueing strategy: fifo
              Output queue: 0/40 (size/max)
              5 minute input rate 0 bits/sec, 0 packets/sec
              5 minute output rate 1000 bits/sec, 1 packets/sec
              37 packets input, 66160 bytes, 0 no buffer
              Received 0 broadcasts (0 multicast)
              0 runts, 0 giants, 0 throttles
              7 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
              0 watchdog, 0 multicast, 0 pause input
              0 input packets with dribble condition detected
              708 packets output, 57142 bytes, 0 underruns
              0 output errors, 0 collisions, 1 interface resets
              0 babbles, 0 late collision, 0 deferred
              0 lost carrier, 0 no carrier, 0 PAUSE output
              0 output buffer failures, 0 output buffers swapped out




              Router:
              __________________________________________________ ____________________________ __________


              Show running-config full:
              Current configuration : 714 bytes
              !
              version 12.4
              service timestamps debug datetime msec
              service timestamps log datetime msec
              no service password-encryption
              !
              hostname Router
              !
              boot-start-marker
              boot-end-marker
              !
              !
              no aaa new-model
              no network-clock-participate slot 1
              no network-clock-participate wic 0
              ip cef
              !
              !
              !
              !
              no ip domain lookup
              multilink bundle-name authenticated
              !
              !
              !
              !
              !
              archive
              log config
              hidekeys
              !
              !
              !
              !
              !
              interface FastEthernet0/0
              ip address 10.10.10.1 255.255.255.0
              duplex auto
              speed auto
              !
              interface Serial0/0
              no ip address
              shutdown
              no fair-queue
              !
              ip forward-protocol nd
              !
              ip http server
              no ip http secure-server
              !
              !
              control-plane
              !
              !
              line con 0
              password cisco
              line aux 0
              line vty 0 4
              password cisco
              login
              !
              !
              end
              __________________________________________________ ___________

              Router#show running-config interface fastEthernet 0/0
              Building configuration...

              Current configuration : 95 bytes
              !
              interface FastEthernet0/0
              ip address 10.10.10.1 255.255.255.0
              duplex auto
              speed auto
              end

              Comment


              • #8
                Re: Basic Router - switch issue but weird

                Switch port f0/5 is configured to trunk while the router port f0/0 is not. So this means the switch will not strip off the dot1q header on transmit towards the router or encapsulate dot1q on receive from the router. Same thing applies on the router... its not encapsulating dot1q on transmit towards the switch port or removing the encapsulation on receive from the switch port. In short, both ends need to match either a trunk configuration or an access configuration.

                So either change switch port f0/5 to an access port on vlan 2 to match the router interface configuration -or- configure the router interface to trunk and encapsulate dot1q on vlan 2 to match the switch port trunk configuration.

                EXAMPLE: Do one or the other, but not both.

                On the switch, convert f0/5 to an access port

                int f0/5
                switchport mode access
                switchport access vlan 2

                OR on the router, convert f0/0 to accept a trunked port from switch (router on a stick).

                int f0/0
                no ip address

                int f0/0.2
                encapsulation dot1q 2
                ip address 10.10.10.1 255.255.255.0

                long pause...

                Or a 3rd option would be to just add native vlan 2 to switchport f0/5.

                Comment

                Working...
                X