Announcement

Collapse
No announcement yet.

OSPF / Routing Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSPF / Routing Issue

    Below is my Home Network layout. I am having trouble pinging the 50.2.30.0 subnet. I created OSPF routes and I am able to ping from HomeLAN router to BackUpHomeLAN router. My problem is that I can not ping from my laptop connected on the 192.168.1.0 subnet to the 50.2.30.0 subnet. Attached below is my current config for both routers and visual for my layout.

    HomeLAN

    HomeLAN-Rotuer#show run
    Building configuration...


    Current configuration : 1761 bytes
    !
    ! Last configuration change at 07:27:14 UTC Wed Mar 26 2014
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname HomeLAN-Rotuer
    !
    boot-start-marker
    warm-reboot
    boot-end-marker
    !
    !
    !
    no aaa new-model
    !
    dot11 syslog
    ip source-route
    !
    !
    !
    ip vrf A
    !
    !
    !
    ip cef
    ip domain name jjkkcc.org
    ip name-server 68.105.28.16
    ip name-server 68.105.29.16
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    ip name-server 192.168.1.252
    ip name-server 192.168.1.242
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    license udi pid CISCO2801 sn FTX1019Y2S4
    username woodjl1650 privilege 15 password 0 henry999 secret
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.2.10.2 255.255.255.248
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.1.5 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    ip address 10.0.10.1 255.255.255.224
    !
    interface Serial0/2/0
    ip address 10.0.10.3 255.255.255.224
    !
    router ospf 1
    network 10.2.10.0 0.0.0.7 area 1
    network 50.2.30.0 0.0.0.31 area 1
    network 192.168.1.0 0.0.0.255 area 1
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip nat inside source list NAT interface FastEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 10.2.10.1
    !
    ip access-list standard NAT
    permit 192.168.1.0 0.0.0.255
    permit 10.2.10.0 0.0.0.7
    permit 50.2.30.0 0.0.0.31
    !
    logging esm config
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login local
    transport input ssh
    !
    scheduler allocate 20000 1000
    end

    BackUpHomeLAN


    BackUpHomeLAN#show run
    Building configuration...


    Current configuration : 1695 bytes
    !
    ! Last configuration change at 06:35:05 UTC Wed Mar 26 2014
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname BackUpHomeLAN
    !
    boot-start-marker
    warm-reboot
    boot-end-marker
    !
    !
    !
    no aaa new-model
    !
    dot11 syslog
    ip source-route
    !
    !
    !
    ip vrf A
    !
    !
    !
    ip cef
    ip domain name jjkkcc.com
    ip name-server 68.105.28.16
    ip name-server 68.105.29.16
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    license udi pid CISCO2801 sn FTX1028W1PY
    username woodjl1650 privilege 15 password 0 henry999 secret
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback100
    ip vrf forwarding A
    no ip address
    !
    interface FastEthernet0/0
    ip address 10.2.10.3 255.255.255.248
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 50.2.30.1 255.255.255.224
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    ip address 10.0.10.2 10.2.10.1
    !
    router ospf 1
    network 10.2.10.0 0.0.0.7 area 1
    network 50.2.30.0 0.0.0.31 area 1
    network 192.168.1.0 0.0.0.255 area 1
    !
    router ospf 3
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip nat inside source list NAT interface FastEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 24.234.191.225
    !
    ip access-list standard NAT
    permit 192.168.1.0 0.0.0.255
    permit 10.2.10.0 0.0.0.7
    permit 50.2.30.0 0.0.0.31
    !
    logging esm config
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login local
    transport input ssh
    !
    scheduler allocate 20000 1000
    end
    Attached Files

  • #2
    Re: OSPF / Routing Issue

    (Could you please put configurations and such inside [code] [/code] tags to make them more readable?)

    Your OSPF configuration is technically invalid, as you don't have an "area 0" which is mandatory for OSPF. However, as far as I know, route information should still propagate between the routers as long as all networks are defined to exist inside the same area.

    You also have some superfluous OSPF network definitions on both routers. The "HomeLAN" router shouldn't have a "network" statement for the 50.2.30.0/27 network as it's not connected to that network, and the "BackUpHomeLAN" router shouldn't have a network statement for the 192.168.1.0/24 network for the same reason. Having said that, these settings should not actually cause any OSPF or routing issues.

    In other words, while the OSPF setup contains errors, it still ought to work.

    From what I gather, traffic from a host on the 192.168.1.0/24 network would have to take the following path to reach the 50.2.30.0/27 network:

    [192.168.1.0/24 network] -> (HomeLAN-Router) -> [10.2.10.0/29 network] -> (BackUpHomeLAN-Router) -> [50.2.30.0/27 network]

    Could you post the output from the show ip route and show ip ospf neighbor commands on both routers? Also, what happens if you run tracert -d 50.2.30.1 from a host on the 192.168.1.0/24 network?

    Comment


    • #3
      Re: OSPF / Routing Issue

      HomeLAN Router
      Code:
      HomeLAN-Rotuer#show ip route
      Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
             D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
             N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
             E1 - OSPF external type 1, E2 - OSPF external type 2
             i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
             ia - IS-IS inter area, * - candidate default, U - per-user static route
             o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
             + - replicated route, % - next hop override
      
      Gateway of last resort is 10.2.10.1 to network 0.0.0.0
      
      S*    0.0.0.0/0 [1/0] via 10.2.10.1
            10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C        10.2.10.0/29 is directly connected, FastEthernet0/0
      L        10.2.10.2/32 is directly connected, FastEthernet0/0
            192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
      C        192.168.1.0/24 is directly connected, FastEthernet0/1
      L        192.168.1.5/32 is directly connected, FastEthernet0/1
      OSPF Neighbor -- BackupHomeLAN
      Code:
      Neighbor ID     Pri   State           Dead Time   Address         Interface
      192.168.1.7       1   EXCHANGE/DR     00:00:36    10.2.10.3       FastEthernet0/0
      BackUpHomeLAN Router
      Code:
      BackUpHomeLAN#show ip route
      Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
             D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
             N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
             E1 - OSPF external type 1, E2 - OSPF external type 2
             i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
             ia - IS-IS inter area, * - candidate default, U - per-user static route
             o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
             + - replicated route, % - next hop override
      
      Gateway of last resort is 10.2.10.1 to network 0.0.0.0
      
      S*    0.0.0.0/0 [1/0] via 10.2.10.1
            10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C        10.2.10.0/29 is directly connected, FastEthernet0/0
      L        10.2.10.3/32 is directly connected, FastEthernet0/0
            50.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C        50.2.30.0/27 is directly connected, FastEthernet0/1
      L        50.2.30.1/32 is directly connected, FastEthernet0/1
      OSPF Neighbor -- BackupHomeLAN
      Code:
      BackUpHomeLAN#show ip ospf neighbor
      
      Neighbor ID     Pri   State           Dead Time   Address         Interface
      192.168.1.5       1   EXSTART/BDR     00:00:31    10.2.10.2       FastEthernet0/0
      Trace Route via 192.168.1.200
      Code:
      Microsoft Windows [Version 6.1.7601]
      Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
      
      C:\Users\jonathan.l.wood>tracert -d 50.2.30.1
      
      Tracing route to 50.2.30.1 over a maximum of 30 hops
      
        1     1 ms    <1 ms    <1 ms  192.168.1.5
        2     1 ms     1 ms     1 ms  10.2.10.1
        3     9 ms     8 ms     7 ms  10.68.128.1
        4     8 ms     8 ms     9 ms  24.234.16.33
        5     9 ms     8 ms     8 ms  24.234.6.25
        6     8 ms     8 ms     9 ms  24.234.6.218
        7    15 ms    13 ms    13 ms  68.1.5.137
        8    21 ms    20 ms    21 ms  66.160.133.113
        9    14 ms    22 ms    24 ms  72.52.92.122
       10    25 ms    35 ms    25 ms  184.105.222.85
       11    31 ms    31 ms    40 ms  216.218.230.254
       12    33 ms    32 ms    31 ms  50.2.30.1
      
      Trace complete.
      Before I change anything, is the 50.2.30.0 subnet a bad one to use, since it seems to be a public IP address? Would a 10.3.30.0 subnet be a better solution?

      Comment


      • #4
        Re: OSPF / Routing Issue

        The output from tracert shows that you can successfully reach the router IP in the 50.2.30.0/27 network. Your connection issues are not related to the routers at all. You should check the gateway and firewall settings on any hosts in the 50.2.30.0/27 network that you are unable to reach.

        Yes, 50.2.30.0/27 is a public IP network, and you shouldn't use it unless it has actually been allocated to you by an ISP. Instead, you should use addresses in the private address range as defined by RFC 1918 and incorporated into RFC 3330. They are:

        10.0.0.0/8 (10.0.0.0 - 10.255.255.255)
        172.16.0.0/12 (172.16.0.0 - 172.31.255.255)
        192.168.0.0/16 (192.168.0.0 - 192.168.255.255)

        Your OSPF setup is completely non-functional. This has not affected routing between the subnets, as you have manually specified default routes pointing to the opposite router.

        You should clear the current OSPF setup (no router ospf 1) and redefine the networks as belonging to area 0. On the "HomeLAN" router, this should do:
        Code:
        router ospf 1
         network 10.2.10.0 0.0.0.7 area 0
         network 192.168.1.0 0.0.0.255 area 0
        Same for the "BackUpHomeLAN" router:
        Code:
        router ospf 1
         network 10.2.10.0 0.0.0.7 area 0
         network 50.2.30.0 0.0.0.31 area 0
        ...except replace 50.2.30.0 with whichever private network you decide to use. One you've done this, you should be able to delete the static default routes.

        Comment


        • #5
          Re: OSPF / Routing Issue

          Ok, so I just did what you suggested, still can't ping the 10.3.30.0 subnet from my laptop 192.168.1.200. I attached a diagram showing my network topology, if that helps.

          Here are my current configs:

          HomeLAN
          Code:
          HomeLAN-Rotuer#show run
          Building configuration...
          
          
          Current configuration : 1773 bytes
          !
          ! Last configuration change at 10:58:52 UTC Thu Mar 27 2014
          !
          version 15.1
          service timestamps debug datetime msec
          service timestamps log datetime msec
          no service password-encryption
          !
          hostname HomeLAN-Rotuer
          !
          boot-start-marker
          warm-reboot
          boot-end-marker
          !
          !
          !
          no aaa new-model
          !
          dot11 syslog
          ip source-route
          !
          !
          !
          !
          !
          ip cef
          ip domain name jjkkcc.org
          ip name-server 68.105.28.16
          ip name-server 68.105.29.16
          ip name-server 8.8.8.8
          ip name-server 8.8.4.4
          ip name-server 192.168.1.252
          ip name-server 192.168.1.242
          no ipv6 cef
          !
          multilink bundle-name authenticated
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          voice-card 0
          !
          crypto pki token default removal timeout 0
          !
          !
          !
          !
          license udi pid CISCO2801 sn FTX1019Y2S4
          username woodjl1650 privilege 15 password 0 henry999 secret
          !
          redundancy
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          interface FastEthernet0/0
           ip address 10.2.10.2 255.255.255.248
           ip nat outside
           ip virtual-reassembly in
           duplex auto
           speed auto
          !
          interface FastEthernet0/1
           ip address 192.168.1.5 255.255.255.0
           ip nat inside
           ip virtual-reassembly in
           duplex auto
           speed auto
          !
          interface Serial0/1/0
           ip address 10.0.10.1 255.255.255.224
          !
          interface Serial0/2/0
           ip address 10.0.10.3 255.255.255.224
          !
          router ospf 1
           network 10.2.10.0 0.0.0.7 area 0
           network 192.168.1.0 0.0.0.255 area 0
          !
          ip default-gateway 192.168.1.5
          ip forward-protocol nd
          no ip http server
          no ip http secure-server
          !
          !
          ip nat inside source list NAT interface FastEthernet0/0 overload
          ip route 0.0.0.0 0.0.0.0 10.2.10.1
          !
          ip access-list standard NAT
           permit 192.168.1.0 0.0.0.255
           permit 50.2.30.0 0.0.0.31
           permit 10.2.10.0 0.0.0.7
          !
          logging esm config
          !
          !
          !
          !
          !
          !
          control-plane
          !
          !
          !
          !
          !
          !
          !
          !
          gatekeeper
           shutdown
          !
          !
          line con 0
          line aux 0
          line vty 0 4
           login local
           transport input ssh
          !
          scheduler allocate 20000 1000
          end
          IP Route -- HomeLAN
          Code:
          HomeLAN-Rotuer#show ip route
          Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                 E1 - OSPF external type 1, E2 - OSPF external type 2
                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                 ia - IS-IS inter area, * - candidate default, U - per-user static route
                 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
                 + - replicated route, % - next hop override
          
          Gateway of last resort is 10.2.10.1 to network 0.0.0.0
          
          S*    0.0.0.0/0 [1/0] via 10.2.10.1
                10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
          C        10.2.10.0/29 is directly connected, FastEthernet0/0
          L        10.2.10.2/32 is directly connected, FastEthernet0/0
                192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
          C        192.168.1.0/24 is directly connected, FastEthernet0/1
          L        192.168.1.5/32 is directly connected, FastEthernet0/1
          BackUpHomeLAN
          Code:
          BackUpHomeLAN#show run
          Building configuration...
          
          
          Current configuration : 1588 bytes
          !
          ! Last configuration change at 10:49:10 UTC Thu Mar 27 2014
          !
          version 15.1
          service timestamps debug datetime msec
          service timestamps log datetime msec
          no service password-encryption
          !
          hostname BackUpHomeLAN
          !
          boot-start-marker
          warm-reboot
          boot-end-marker
          !
          !
          !
          no aaa new-model
          !
          dot11 syslog
          ip source-route
          !
          !
          !
          !
          !
          ip cef
          ip domain name jjkkcc.com
          ip name-server 68.105.28.16
          ip name-server 68.105.29.16
          ip name-server 8.8.8.8
          ip name-server 8.8.4.4
          no ipv6 cef
          !
          multilink bundle-name authenticated
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          voice-card 0
          !
          crypto pki token default removal timeout 0
          !
          !
          !
          !
          license udi pid CISCO2801 sn FTX1028W1PY
          username woodjl1650 privilege 15 password 0 henry999 secret
          !
          redundancy
          !
          !
          !
          !
          !
          !
          !
          !
          !
          !
          interface FastEthernet0/0
           ip address 10.2.10.3 255.255.255.248
           ip nat outside
           ip virtual-reassembly in
           duplex auto
           speed auto
          !
          interface FastEthernet0/1
           ip address 10.3.30.1 255.255.255.224
           ip nat inside
           ip virtual-reassembly in
           duplex auto
           speed auto
          !
          interface Serial0/1/0
           ip address 10.0.10.2 255.255.255.224
          !
          router ospf 1
           network 10.2.10.0 0.0.0.7 area 0
           network 10.3.30.0 0.0.0.31 area 0
          !
          ip forward-protocol nd
          no ip http server
          no ip http secure-server
          !
          !
          ip nat inside source list NAT interface FastEthernet0/0 overload
          ip route 0.0.0.0 0.0.0.0 10.2.10.1
          !
          ip access-list standard NAT
           permit 10.2.10.0 0.0.0.7
           permit 10.3.30.0 0.0.0.31
          !
          logging esm config
          !
          !
          !
          !
          !
          !
          control-plane
          !
          !
          !
          !
          !
          !
          !
          !
          gatekeeper
           shutdown
          !
          !
          line con 0
          line aux 0
          line vty 0 4
           login local
           transport input ssh
          !
          scheduler allocate 20000 1000
          end
          IP Route --- BackUpHomeLAN
          Code:
          BackUpHomeLAN#show ip route
          Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                 E1 - OSPF external type 1, E2 - OSPF external type 2
                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                 ia - IS-IS inter area, * - candidate default, U - per-user static route
                 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
                 + - replicated route, % - next hop override
          
          Gateway of last resort is 10.2.10.1 to network 0.0.0.0
          
          S*    0.0.0.0/0 [1/0] via 10.2.10.1
                10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
          C        10.2.10.0/29 is directly connected, FastEthernet0/0
          L        10.2.10.3/32 is directly connected, FastEthernet0/0
          C        10.3.30.0/27 is directly connected, FastEthernet0/1
          L        10.3.30.1/32 is directly connected, FastEthernet0/1
          I am getting these error now, haven't seen them before, on both routers...
          Code:
          *Mar 27 10:55:17.413: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.5 on FastEthernet0/0 from EXSTART to DOWN, Neighbor Down: Too many retransmissions
          *Mar 27 10:56:17.413: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.5 on FastEthernet0/0 from DOWN to DOWN, Neighbor Down: Ignore timer expired
          Attached Files

          Comment


          • #6
            Re: OSPF / Routing Issue

            If you can ping 10. 3.30.1 but no other hosts on the 10.3.30.0/27 network, it could be because you've configured the "BackupHomeLAN" router to NAT all outgoing traffic behind the IP address of FastEthernet0/0 (10.2.10.3). You have a similar NAT setup on the other router, which doesn't really make sense for a private network, let alone one running OSPF. You may want to temporarily remove the ip nat commands and see if that makes a difference.

            As for the OSFP error, it's basically saying there's a problem with the neighbor with OSPF ID 192.168.1.5, which is the "HomeLAN" router. Did you reload both routers after changing the OSPF conffiguration?

            There's still no OSPF routes in the routing table, indicating that no adjacencies have been formed. Hopefully a reload will fix that. show ip route ospf should return a route to 10.3.30.0/27 on "HomeLAN" and a route to 192.168.1.0/24 on "BackUpHomeLAN".

            (The "NAT" access lists are wrong, by the way; they should only contain references to the source network being NATed.)

            Comment


            • #7
              Re: OSPF / Routing Issue

              Awesome, that worked...now I have an issue with pfSense... I can no longer ping that box...nor do I have internet connectivity...

              Comment


              • #8
                Re: OSPF / Routing Issue

                Probably because you lack a return route from the pfSense box. Does it have static routes to all the subnets involved? Does the NAT rules for Internet access cover the subnets as well?

                Does pfSense support OSPF, BTW?

                Comment


                • #9
                  Re: OSPF / Routing Issue

                  Not to familiar with pfSense, but I just added these static routes

                  192.168.1.0/24 ---via gateway 10.2.10.2
                  10.3.30.0/27 ---via gatewat 10.3.30.1

                  What is needed as far as NAT is concerned on the pfSense box?

                  also in order to get my internet working now, I had to configure NAT on the HomeLAN router...if I remove it, I loose internet connection...
                  Last edited by woodjl1650; 27th March 2014, 14:02.

                  Comment


                  • #10
                    Re: OSPF / Routing Issue

                    Originally posted by woodjl1650 View Post
                    Not to familiar with pfSense, but I just added these static routes

                    192.168.1.0/24 ---via gateway 10.2.10.2
                    10.3.30.0/27 ---via gatewat 10.3.30.1
                    The latter doesn't make any sense. The gateway ID should be an IP address in a connected network (in other words, 10.2.10.3).

                    Originally posted by woodjl1650 View Post
                    What is needed as far as NAT is concerned on the pfSense box?
                    There has to be some sort of NAT ruleset deciding which source addresses are NAT overloaded behind the public outside IP address. I had a quick look at the documentation, and it seems you may have to switch from "automatic" to "manual" NAT configuration to edit these rules.

                    Originally posted by woodjl1650 View Post
                    also in order to get my internet working now, I had to configure NAT on the HomeLAN router...if I remove it, I loose internet connection...
                    If you enable NAT on the HomeLAN router, outbound traffic from 192.168.1.0/24 is NATed twice: once behind 10.2.10.2, and then again behind the public IP of the pfSense firewall.

                    Try running tracert from a host in the 192.168.1.0/24 network against the internal AND the external address of the pfSense gateway, as well as an address on the Internet (8.8.8.8 should work). If my theory about NAT is correct, the first two will work and the latter will fail.

                    Comment


                    • #11
                      Re: OSPF / Routing Issue

                      I see what you are saying about the double NAT. I removed all the nat configs from the cisco routers and made some routes in the pfsense box. I can full connectivity to the routers as well as internet connectivity...just a strange thing is that i can not get a trace route to 8.8.8.8 via 192.168.1.185 (my laptop), but the internet connection s fine....

                      Comment


                      • #12
                        Re: OSPF / Routing Issue

                        Originally posted by woodjl1650 View Post
                        just a strange thing is that i can not get a trace route to 8.8.8.8 via 192.168.1.185 (my laptop), but the internet connection s fine....
                        How far does the trace get?

                        Windows tracert uses ICMP Echo Request packages ("ping"), not UDP as do most other implementations. Can you ping 8.8.8.8 from the laptop?

                        Have you tried an extended traceroute from the "HomeLAN" router with 192.168.1.1 as the source address?

                        Comment


                        • #13
                          Re: OSPF / Routing Issue

                          From my laptop, it reaches HomeLan Router 192.168.1.5

                          Comment


                          • #14
                            Re: OSPF / Routing Issue

                            So traceroute from both routers were successfull, must be some sort of firewall setting blocking my ICMP via the 192.168.1.0 subnet.

                            Not to worried about it, since everything seems to be working fine now.

                            Thanks for all your help...

                            Comment

                            Working...
                            X