Announcement

Collapse
No announcement yet.

Can't ping between 1841 router and 2950 switch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't ping between 1841 router and 2950 switch

    Hi peeps,

    I saw a few different threads on this but didn't find one with the specific problem, or with an idea that solved it.

    In a lab I have an 1841 router and 2950 switch connected via 1 trunk interface. I'll attach full configs, but the "key" bits are below.

    Both devices can ping themselves (the router on 192.168.1.254, 192.168.2.254, 192.168.3.254 and the switch on 192.168.2.1), but neither can ping the other.

    Fa0/0 on the router is connected to my home network on 192.168.1.0/24 and Fa0/1 (should be) a dot1Q trunk to Fa0/24 on the switch.

    Router:

    Code:
    !
    interface FastEthernet0/0
     ip address 192.168.1.201 255.255.255.0
     ip nat outside
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1.2
     encapsulation dot1Q 2 native
     ip address 192.168.2.254 255.255.255.0
     ip nat inside
    !
    interface FastEthernet0/1.3
     encapsulation dot1Q 3
     ip address 192.168.3.254 255.255.255.0
     ip nat inside
    !
    router rip
     network 192.168.1.0
     network 192.168.2.0
     network 192.168.3.0
    !
    ip route 0.0.0.0 0.0.0.0 192.168.1.254
    Switch:

    Code:
    interface FastEthernet0/24
     switchport trunk native vlan 2
     switchport mode trunk
    !
    interface Vlan1
     no ip address
     no ip route-cache
     shutdown
    !
    interface Vlan2
     ip address 192.168.2.1 255.255.255.0
     ip helper-address 192.168.1.31
     no ip route-cache
    !
    interface Vlan3
     no ip address
     ip helper-address 192.168.1.31
     no ip route-cache
     shutdown
    !
    ip default-gateway 192.168.2.254
    The Vlan2 interface on the switch shows as up, as does Fa0/24.

    Code:
    gforce-switch-1#sh ip int brief
    Interface                  IP-Address      OK? Method Status                Protocol
    Vlan1                      unassigned      YES unset  administratively down down
    Vlan2                      192.168.2.1     YES manual up                    up
    Vlan3                      unassigned      YES manual administratively down down
    FastEthernet0/24           unassigned      YES unset  up                    up
    The config of each device is based on a 2811 router and 2960 switch at work which can communicate with each other. I'm sure I've missed something basic here, but after much head scratching I'm not sure what

    Thanks in advance for any thoughts.
    Attached Files
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

  • #2
    Re: Can't ping between 1841 router and 2950 switch

    Hi, it looks like you need to remove the IP address from Vlan2 off the switch config.
    So from gforce-switch-1
    conf t
    no vlan 2
    When it's removed just add it again
    conf t
    vlan 2

    Here is a good reference to follow:
    http://community.spiceworks.com/how_...ter-on-a-stick
    Please remember to award reputation points if you have received good advice.
    I do tend to think 'outside the box' so others may not always share the same views.

    MCITP -W7,
    MCSA+Messaging, CCENT, ICND2 slowly getting around to.

    Comment


    • #3
      Re: Can't ping between 1841 router and 2950 switch

      Your configurations look fine. In fact, I tried them in Packet Tracer and was able to ping from the router to the switch and vice versa.

      I've seen VLAN-related communication issues before, and they were mostly caused by stuck VLAN interfaces on switches ("protocol down") or wrong (native) VLAN numbers. Your setup has neither of these problems.

      I see that the switch has no active ports in VLAN 2. Could you try adding a port temporarily to this VLAN and see what happens?

      When you try to ping the router from the switch or vice versa, do you get an entry in the ARP cache (show arp)?

      Have you tried specifying the encapsulation type for Fa0/24 on the switch with switchport trunk encapsulation dot1q? (A long shot, considering how unlikely it is that your switch should support ISL.)

      Comment


      • #4
        Re: Can't ping between 1841 router and 2950 switch

        Thanks for the suggestions guys. It looks like this may have been an impending hardware failure on the switch, as when I got home yesterday it was bricked. I just applied the same configuration to another unit (same model and IOS) and can ping both ways.

        A colleague and I spent a couple of hours on this one the other day as neither of us could figure out where it was going wrong - take the trunk out of the configuration and put everything into the same VLAN and everything could ping everything else no problem. Such is life
        Gareth Howells

        BSc (Hons), MBCS, MCP, MCDST, ICCE

        Any advice is given in good faith and without warranty.

        Please give reputation points if somebody has helped you.

        "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

        "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

        Comment

        Working...
        X