Announcement

Collapse
No announcement yet.

Serial interface Connectivity Help Requried

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial interface Connectivity Help Requried

    Dear All

    I have done a setup of Serial to Serial connection (Domestic Private Lease Circuit, by provider) between two Cisco 7200.

    Confs are as under

    Site-A end
    -------------

    interface GigabitEthernet0/2
    ip address 192.168.4.1 255.255.255.248 secondary
    !
    interface Serial1/0
    description Site-A DPLC-01
    bandwidth 2048
    ip address 192.168.42.21 255.255.255.252
    encapsulation ppp
    !
    ip route 192.168.2.0 255.255.255.248 192.168.42.22
    !

    Site-B End
    ------------
    interface GigabitEthernet0/1
    ip address 192.168.2.1 255.255.255.248 secondary
    !
    !
    interface Serial3/0
    description Site-B DPLC-01
    bandwidth 2048
    ip address 192.168.42.22 255.255.255.252
    encapsulation ppp
    !

    ip route 192.168.4.0 255.255.255.248 192.168.42.21
    !
    ---

    Able to ping from A to B, both serial and Giga interface,
    but when device are added to the pool the machines are not pingable
    like a machine at site A got ip 192.168.4.2, and a Machine at
    site B got IP 192.168.2.2
    both these IP remains unable to ping each other.
    though both connected machines can ping both routers.
    no ACL involved.

    Can any one help what i am missing.


    best regards

    Masriffa

  • #2
    Re: Serial interface Connectivity Help Requried

    This is obviously a routing issue, since the connection itself is working fine. Perhaps you're missing a gateway entry on the PCs.

    How far does a traceroute get? (tracert -d 192.168.2.2 from 192.168.4.2 or tracert -d 192.168.4.2 from 192.168.2.2)

    May I ask why 192.168.2.1 and 192.168.4.1 are added as secondary addresses on the router interfaces? What are the primary addresses?

    Comment


    • #3
      Re: Serial interface Connectivity Help Requried

      tracert was as under

      Trace Result from 192.168.4.2 to 192.168.2.2
      C:\Users\cda>tracert 192.168.2.2

      Tracing route to 192.168.2.2 over a maximum of 30 hops

      1 <1 ms <1 ms <1 ms 203.215.174.1
      2 19 ms 19 ms 19 ms 192.168.42.22
      3 * * * Request timed out.
      4 * * * Request timed out.
      5 * * * Request timed out.
      6 * * * Request timed out.
      7 * * ^C
      Trace Result from 192.168.4.2 to 192.168.2.2

      C:\Users\cda>tracert 192.168.2.1

      Tracing route to 192.168.2.1 over a maximum of 30 hops

      1 <1 ms <1 ms <1 ms 203.215.174.1
      2 19 ms 19 ms 19 ms 192.168.2.1

      Trace complete.

      Trace from 192.168.2.2 towards 192.168.4.2 is also same as above, as it remain unreachble to 2.2, but reachable to 2.1


      192.168.2.1 and 192.168.4.1 are added as secondary addresses on the router interfaces to allow specific devices to route via this DPLC. Primary are being use to route Public IP network devices.

      shud i assing 255.255.255.248 pool at Serial int, so that both P2P and devices should have one single pool, will it work ?

      BR

      Comment


      • #4
        Re: Serial interface Connectivity Help Requried

        Originally posted by masriffa View Post
        C:\Users\cda>tracert 192.168.2.2

        Tracing route to 192.168.2.2 over a maximum of 30 hops

        1 <1 ms <1 ms <1 ms 203.215.174.1
        2 19 ms 19 ms 19 ms 192.168.42.22
        3 * * * Request timed out.
        I guess 203.215.174.1 must be the primary IP address of the router interface?

        The second response verifies that the opposite router has a route back to the PC. The timeout in line 3 shows that the host at the other end is either unreachable (unlikely) or does not know where to send the reply.

        Originally posted by masriffa View Post
        Trace Result from 192.168.4.2 to 192.168.2.2

        C:\Users\cda>tracert 192.168.2.1

        Tracing route to 192.168.2.1 over a maximum of 30 hops

        1 <1 ms <1 ms <1 ms 203.215.174.1
        2 19 ms 19 ms 19 ms 192.168.2.1

        Trace complete.
        Which confirms the above. The remote router knows how to respond, but the host does not.
        Originally posted by masriffa View Post
        Trace from 192.168.2.2 towards 192.168.4.2 is also same as above, as it remain unreachble to 2.2, but reachable to 2.1
        So packets from either host can get as far as the remote router, but no further.

        You've established that 192.168.2.1 knows how to get to 192.168.4.1 and vice versa, and we also know that 192.168.2.2 and 192.168.4.2 knows where to send packets intended for the other party, yet when 192.168.4.2 tries to reach 192.168.2.2, there's no reply.

        Preliminary conclusion: When 192.168.4.2 tries to reach 192.168.2.2, it uses a different source address. Either the PC has multiple IP addresses (which would explain why the first hop is 203.215.174.1 rather than 192.168.4.1), or the router is performing NAT.

        Please post the output from route print and ipconfig on both PCs.

        Comment

        Working...
        X