Announcement

Collapse
No announcement yet.

Intervlan routing cisco SG300

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intervlan routing cisco SG300

    Dear all,

    I'm newbie here. and want to ask about cisco sg300.

    i want to create 3 vlan for my office: vlan10, vlan20, vlan30.

    i already create and setup ip address for each vlan:
    vlan10: 10.10.10.1, i make this as default vlan.
    vlan20: 10.10.20.1
    vlan30: 10.10.30.1

    and then setup port for each vlan.
    port 1-6 for vlan10
    port 7-12 for vlan20
    port 13-18 for vlan30.

    then i try with host1 on vlan 10 ping to host2 on vlan20 but doestn work.
    host1 ip address: 10.10.10.2/24 gateway: 10.10.10.1
    host2 ip address: 10.10.20.2/24 gateway: 10.10.20.1

    here the config:

    vlan database
    default-vlan vlan 10
    exit
    vlan database
    vlan 1,10,20,30
    exit
    interface range gi1-6
    switchport default-vlan tagged
    exit
    voice vlan oui-table add 0001e3 Siemens_AG_phone________
    voice vlan oui-table add 00036b Cisco_phone_____________
    voice vlan oui-table add 00096e Avaya___________________
    voice vlan oui-table add 000fe2 H3C_Aolynk______________
    voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
    voice vlan oui-table add 00d01e Pingtel_phone___________
    voice vlan oui-table add 00e075 Polycom/Veritel_phone___
    voice vlan oui-table add 00e0bb 3Com_phone______________
    interface vlan 10
    ip address 10.10.10.1 255.255.255.0
    exit
    interface vlan 20
    ip address 10.10.20.1 255.255.255.0
    exit
    interface vlan 30
    ip address 10.10.30.1 255.255.255.0
    exit
    no bonjour enable
    bonjour interface range vlan 1
    hostname switch3b0e47
    no snmp-server server
    interface gigabitethernet7
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet8
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet9
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet10
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet11
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet12
    switchport trunk allowed vlan add 20
    exit
    interface gigabitethernet13
    switchport trunk allowed vlan add 30
    exit
    interface gigabitethernet14
    switchport trunk allowed vlan add 30
    exit
    interface gigabitethernet15
    switchport trunk allowed vlan add 30
    exit
    interface gigabitethernet16
    switchport trunk allowed vlan add 30
    exit
    interface gigabitethernet17
    switchport trunk allowed vlan add 30
    exit
    interface gigabitethernet18
    switchport trunk allowed vlan add 30
    exit
    interface vlan 10
    name "vlan10"
    exit
    interface vlan 20
    name "vlan20"
    exit
    interface vlan 30
    name "vlan30"
    exit

    regards,

    here the ports configuration from web console:
    imageshack.com/scaled/large/32/o1i.png

  • #2
    Re: Intervlan routing cisco SG300

    Reading very quickly thru the spec sheet for the 300-series of switch, while inter-VLAN routing (Layer 3) is do-able, it's listed as an advanced feature.

    Traffic between VLANs must be routed, that's concrete. If your switch isn't routing, either it hasn't been told to, or it can't.

    First, are you sure the version of OS in your device has that feature available (if these can be purchased with different levels of OS)?

    Second, the running config you gave doesn't appear to have any commands showing that routing is turned on. Did you see anything in your config screens to tell you it was?


    Follow-up: just found a blog which describes how to setup inter-VLAN routing on a similar device to yours, see this link:
    https://supportforums.cisco.com/thread/2153236
    Step 1 is to enable the routing mode, which reboots the router with a clean config! So your current config will be wiped, but when re-entered means the routing should work.
    Last edited by RicklesP; 25th July 2013, 20:26. Reason: Additional comments.
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Re: Intervlan routing cisco SG300

      Hi, do you have a DNS server which both hosts can see? Also can you ping by Just the IP address (windows firewall will most likely block this)
      you could also use the IP Host command.
      ip host TEST 192.168.5.10
      Then try the ping again.
      Please remember to award reputation points if you have received good advice.
      I do tend to think 'outside the box' so others may not always share the same views.

      MCITP -W7,
      MCSA+Messaging, CCENT, ICND2 slowly getting around to.

      Comment


      • #4
        Re: Intervlan routing cisco SG300

        I'm using the SG-300 series at home and InterVlan routing does work over here.
        But I would like to see your answer on the questions already asked...
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: Intervlan routing cisco SG300

          Originally posted by RicklesP View Post
          Reading very quickly thru the spec sheet for the 300-series of switch, while inter-VLAN routing (Layer 3) is do-able, it's listed as an advanced feature.

          Traffic between VLANs must be routed, that's concrete. If your switch isn't routing, either it hasn't been told to, or it can't.

          First, are you sure the version of OS in your device has that feature available (if these can be purchased with different levels of OS)?

          Second, the running config you gave doesn't appear to have any commands showing that routing is turned on. Did you see anything in your config screens to tell you it was?


          Follow-up: just found a blog which describes how to setup inter-VLAN routing on a similar device to yours, see this link:
          supportforums.cisco.com/thread/2153236
          Step 1 is to enable the routing mode, which reboots the router with a clean config! So your current config will be wiped, but when re-entered means the routing should work.
          hello,

          i already setup the switch to layer 3 mode and follow whole step in the link you refer then upgrade firmware version to the latest still doesnt work.

          then set ip routing, but still doesnt work.
          here the command: imageshack.com/a/img28/6853/2vaf.png



          Originally posted by uk_network View Post
          Hi, do you have a DNS server which both hosts can see? Also can you ping by Just the IP address (windows firewall will most likely block this)
          you could also use the IP Host command.
          ip host TEST 192.168.5.10
          Then try the ping again.
          i dont have DNS, i just test it with two notebook with windows firewall off.
          ip host command doest work. any suggestion?

          Originally posted by Dumber View Post
          I'm using the SG-300 series at home and InterVlan routing does work over here.
          But I would like to see your answer on the questions already asked...
          okay, i still find out how to get rid of this.

          Comment


          • #6
            Re: Intervlan routing cisco SG300

            First, I do not see you assigned any ports to your VLANs. You should run from the CLI on you switch this:
            enable
            config t
            interface gig 10
            switch access vlan 10
            switch mode access
            interface gig 11
            switch access vlan 20
            switch mode access
            interface gig 12
            switch access vlan 30
            switch mode access

            It will add port 10 to the VLAN 10, port 11 to VLAN 20 and port 12 to VLAN 30
            It should be enough. As the part of troubleshooting steps I would recommend try to ping from the CLI of the switch laptop's IP address.

            Comment


            • #7
              Re: Intervlan routing cisco SG300

              Please run "sh ip route" and "sh ver"
              And what devices are connected to the switch?
              Marcel
              Technical Consultant
              Netherlands
              http://www.phetios.com
              http://blog.nessus.nl

              MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
              "No matter how secure, there is always the human factor."

              "Enjoy life today, tomorrow may never come."
              "If you're going through hell, keep going. ~Winston Churchill"

              Comment


              • #8
                Re: Intervlan routing cisco SG300

                Originally posted by tAnk View Post
                First, I do not see you assigned any ports to your VLANs. You should run from the CLI on you switch this:
                enable
                config t
                interface gig 10
                switch access vlan 10
                switch mode access
                interface gig 11
                switch access vlan 20
                switch mode access
                interface gig 12
                switch access vlan 30
                switch mode access

                It will add port 10 to the VLAN 10, port 11 to VLAN 20 and port 12 to VLAN 30
                It should be enough. As the part of troubleshooting steps I would recommend try to ping from the CLI of the switch laptop's IP address.
                first, because i assign ports to vlan member via web console.

                thank you so much tAnk for the command. it work.

                but in my CLI the command shoud be, first: switch mode access
                then : switch access vlan xx

                Originally posted by Dumber View Post
                Please run "sh ip route" and "sh ver"
                And what devices are connected to the switch?
                all vlan now can communicate each other.
                here, the result. (i changed ip address from 10.10.xx.xx to 172.17.xx.xx)

                switch3b0e47#sho ip route
                Maximum Parallel Paths: 1 (1 after reset)
                IP Forwarding: enabled
                Codes: > - best, C - connected, S - static


                C 172.17.88.0/24 is directly connected, vlan 88
                C 172.17.99.0/24 is directly connected, vlan 99
                switch3b0e47#sho ver
                SW version 1.3.0.62 ( date 02-May-2013 time 14:55:01 )
                Boot version 1.1.0.6 ( date 11-May-2011 time 18:31:00 )
                HW version V02
                thank you guys for the help.
                i love this forum..
                Last edited by kocak_gober; 20th August 2013, 11:34.

                Comment


                • #9
                  Re: Intervlan routing cisco SG300

                  Hi Kocak
                  i need ur help about inter vlan routing on sg 300 switch

                  Comment


                  • #10
                    Re: Intervlan routing cisco SG300

                    infact i have 1 sg 300-28 switch in l3 mode
                    i have run 2 vlan. vlan 1 and vlan 10. 24 ports taking ip from dhcp with scheme of 192.168.50.x/24 and they in vlan 1 which is by-default vlan of switch and vlan 1 have an ip address of 192.168.50.10/24. 4 ports in 2nd vlan name vlan 10 having ip 192.168.10.1/24.
                    The problem is that if i connected with the scheme of vlan 2's any ip the system only pings 192.168.50.10 ip address, but not the remaining ip's of this scheme and vlan 1's ip is also not communicating with vlan 2. My default gateway is 192.168.50.1 which is configure on a linksys router com access point with dhcp enable on it. plz help i want to configure two or more networks on sg 300 switch.
                    Last edited by momi; 10th January 2014, 07:02. Reason: some pharase are wrong

                    Comment

                    Working...
                    X